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Modules 1. Module: M1-R5: IT Tools & Basics of Networks 

 

 

Chapter 1: Basics of Computer 

• Computer Definition & Characteristics 
• Input Devices: Keyboard, Mouse, Scanner, etc. 
• Output Devices: Monitor, Printer, Speakers 
• Memory Types: RAM, ROM, Cache, Secondary Storage 
• Number System: Binary, Decimal, Conversion 
• Software: System Software, Application Software, Utility Software 
• Operating System basics (Windows, Linux) 

 

Chapter 2: Operating System 

• Functions of OS 
• File & Folder Operations 
• Types of OS: Single-user, Multi-user, Real-time, etc. 
• Windows OS Interface: Desktop, Icons, Start Menu, Settings 
• File Management in Windows 
• Linux Basic Commands 

 

Chapter 3: Word Processing (MS Word / LibreOffice Writer) 

• Creating, Opening & Saving Documents 
• Formatting: Font, Paragraph, Bullets, Numbering 
• Tables, Header & Footer 
• Mail Merge 
• Inserting Pictures, Charts 
• Page Setup, Printing 

 

Chapter 4: Spreadsheet (MS Excel / LibreOffice Calc) 

• Introduction to Spreadsheet 
• Entering Data: Numbers, Text, Date 
• Basic Formulas & Functions (SUM, AVG, IF, etc.) 
• Cell Referencing: Absolute & Relative 
• Charts & Graphs 
• Sorting & Filtering 
• Printing Spreadsheets 



Chapter 5: Presentation Software (MS PowerPoint / LibreOffice Impress) 

• Creating Presentation 
• Slide Layouts, Themes 
• Inserting Text, Images, Videos 
• Slide Transitions and Animations 
• Slide Show, Printing Slides 

 

Chapter 6: Introduction to Internet and WWW 

• What is Internet? 
• Web Browsers (Chrome, Firefox) 
• Search Engines (Google, Bing) 
• Email: Gmail, Yahoo (Sending, Receiving, Attachments) 
• Social Media, Blogs, Online Forums 
• Cyber Security Basics 

 

Chapter 7: Digital Financial Tools 

• Digital Payments: UPI, BHIM, Paytm, Google Pay 
• Net Banking Basics 
• Online Safety in Digital Transactions 
• Aadhaar Enabled Payment System (AEPS) 

 

Chapter 8: Networking Basics 

• What is Network? 
• Types: LAN, MAN, WAN 
• Network Devices: Modem, Router, Switch 
• IP Address, DNS, DHCP 
• Wi-Fi, Hotspot, Broadband 

Extra: Practical Assignments 

• Word/Excel/PowerPoint hands-on tasks 
• Email creation and usage 
• Download/upload files 
• Internet surfing exercises 

 

• Overview of Futureskills and Cyber Security Introduction to Internet of Things (IoT) = 

Big Data Analytics, Cloud Computing, Virtual Reality, Artificial Intelligence, Social & 

Mobile, Blockchain Technology, 3D Printing/ Additive Manufacturing, Robotics Process 



Automation, Cyber Security, Need of Cyber Security, Securing PC, Securing Smart 

Phone. 

       Chapter 1 

Basics of Computer  

Chapter 1: Basics of Computer 

• Computer Definition & Characteristics 
• Input Devices: Keyboard, Mouse, Scanner, etc. 
• Output Devices: Monitor, Printer, Speakers 
• Memory Types: RAM, ROM, Cache, Secondary Storage 
• Number System: Binary, Decimal, Conversion 
• Software: System Software, Application Software, Utility Software 
• Operating System basics (Windows, Linux) 

 

   1.1 कंप्यूटर क्या है? 

कंप्यूटर एक इलके्ट्रॉनिक मशीि है जो डाटा को प्रोसेस करके जािकारी में बदलता है। यह इिपुट लेता है, प्रोसेस 

करता है और आउटपुट देता है। 

   1.2 कंप्यूटर की विशेषताएं: 

• गनत (Speed) 

• सटीकता (Accuracy) 

• स्वचालि (Automation) 

• संग्रहण (Storage) 

• बहुउपयोगगता (Versatility) 

   1.3 इनपुट डििाइस ( input device) 

• Keyboard: अक्षर, अकं और कमांड देिे के ललए। 
• Mouse: स्रीि पर पॉइंटर चलािे के ललए। 
• Scanner: डॉक्ट्युमेंट की डडजजटल कॉपी बिािा 

 

    1. कीबोिड ( key board )क्या है? 



• कीबोडड एक इनपुट डििाइस है 

• इसका उपयोग कंप्यूटर में टेक््ट, नंबर, कमांि और अन्य निदेश देिे के ललए ककया जाता है 

• यह टाइपराइटर जैसा लेआउट वाला होता है और आमतौर पर QWERTY लेआउट में आता है 

 

 

   2. Keyboard का कायड (Functions of Keyboard) 

• कैरेक्ट्टर इिपुट करिा (A-Z, 0-9) 

• कमांड देिा (जैस:े Ctrl + S = Save) 

• प्रोग्राम या एजप्लकेशि खोलिा 
• स्पेशल कमांड और शॉटडकट्स का उपयोग 

• डडवाइस को नियंत्रित करिा (जैस:े वॉल्यूम, ब्राइटिेस) 

 

   3. Keyboard Keys के प्रकार (Types of Keys) 

Key Type उदाहरण कायड 

Alphanumeric Keys A-Z, 0-9 अक्षर और संख्या टाइप करिे के ललए 

Function Keys F1 से F12 ववशेष कायों के ललए (जसै ेHelp, Refresh) 

Control Keys Ctrl, Alt, Esc अन्य Keys के साथ शॉटडकट बिािे के ललए 

Navigation Keys Arrow Keys, Home, End कसडर को मूव करिे के ललए 

Modifier Keys Shift, Ctrl, Alt दसूरी keys के साथ काम करत ेहैं 

Special Keys Enter, Backspace, Delete खास कायड जैस ेलाइि बदलिा, लमटािा 

Numeric Keypad 0-9, +, -, *, / िंबर टाइप करिे और कैलकुलेशि के ललए 

 

   4. Important Keys और उनका कायड 



Key कायड 

Enter िई लाइि शुरू करता है / कमांड पूरा करता है 

Backspace वपछला कैरेक्ट्टर हटाता है 

Delete करसर के आगे का कैरेक्ट्टर हटाता है 

Shift Capital Letter या Symbol टाइप करिे के ललए 

Caps Lock सभी अक्षरों को Capital में बदलिे के ललए 

Tab करसर को अगल ेफील्ड या स्पेस में ले जाता है 

Esc ककसी कायड को रोकिे या बदं करिे के ललए 

Ctrl + C कॉपी 

Ctrl + V पेस्ट 

Ctrl + Z Undo 

Alt + F4 प्रोग्राम बंद करिा 

   5. Keyboard Layouts 

• QWERTY: सबसे सामान्य 

• AZERTY: फ्रें च लेआउट 

• DVORAK: टाइवपगं को आसाि और तेज़ बिािे के ललए डडज़ाइि ककया गया 

   6. Keyboard के प्रकार (Types of Keyboards) 

प्रकार वििरण 

Wired Keyboard केबल से कंप्यूटर से जुड़ता है 

Wireless Keyboard Bluetooth या USB Receiver से किेक्ट्ट होता है 

Multimedia Keyboard वॉल्यूम, म्यूजज़क, ब्राउज़र जसैी ववशेष Keys होती हैं 



प्रकार वििरण 

Virtual Keyboard स्रीि पर ददखता है, Touch से चलता है 

Mechanical Keyboard हर Key के िीच ेजस्वच होता है, तेज और दटकाऊ 

 

   7. Keyboard से जुड़ी अन्य बातें 

• Typing Practice: टाइवपगं स्पीड बढाि ेके ललए 

• Keyboard Shortcut Keys: काम को तेज़ और आसाि बिात ेहैं 
• Accessibility Features: जैस ेSticky Keys, On-Screen Keyboard 

 

 ननष्कषड: 

     कीबोडड एक महत्वपूणड इिपुट डडवाइस है जो कंप्यूटर को ऑपरेट करिे का मुख्य माध्यम है। 
 

  

Mouse क्या है?  

   1. Mouse क्या है? 

• Mouse एक इनपुट डििाइस है 

• यह कंप्यूटर ्रीन पर पॉइंटर (Cursor) को कंरोल करता है 

• Mouse के जररए हम कंप्यूटर को क्क्लक, डै्रग, और सेलेक्ट करिे जैस ेकायड कर सकते हैं 

 

   2. Mouse के मुख्य भाग (Parts of Mouse) 

भाग कायड 

Left Button लसलेक्ट्शि, जक्ट्लक, डबल-जक्ट्लक 

Right Button Context Menu खोलता है (जैस ेCopy, Paste) 



भाग कायड 

Scroll Wheel स्रीि ऊपर-िीच ेस्रॉल करिे के ललए 

Pointer (Cursor) स्रीि पर मूव होिे वाला तीर (Arrow) 

 

   3. Mouse के प्रकार (Types of Mouse) 

प्रकार वििरण 

Mechanical Mouse बॉल के ज़ररए मूव करता है (पुरािा मॉडल) 

Optical Mouse िीचे की तरफ LED light से चलता है 

Wireless Mouse Bluetooth या USB Receiver से चलता है 

Touchpad (Laptop Mouse) उंगली से टच कर के कंरोल करते हैं 

Trackball Mouse ऊपर की बॉल को घुमाकर कंरोल 

 

   4. Mouse की क्ररयाएं (Mouse Actions) 

क्ररया कायड 

Single Click ककसी आइटम को सेलेक्ट्ट करिा 

Double Click आइटम को ओपि करिा 

Right Click Shortcut Menu खोलिा 

Drag and Drop एक आइटम को खींचकर दसूरी जगह ले जािा 

Scroll पेज को ऊपर-िीचे करिा 

Hover आइटम पर माउस रोककर Tooltip देखिा 



   5. Mouse Pointer के प्रकार (Cursor Types) 

कसडर कायड 

Arrow सामान्य कायों के ललए 

I-Beam (Text Cursor) टेक्ट्स्ट एररया में ददखाई देता है 

Hourglass / Spinner लसस्टम व्यस्त है 

Hand Pointer ललकं पर जक्ट्लक करिे के ललए 

   6. Mouse Settings (Control Panel में) 

• Pointer Speed 
• Double Click Speed 

• Left या Right Click Preference 

• Pointer Trails (Motion ददखाई देिा) 

   7. Mouse का उपयोग कहााँ-कहााँ होता है? 

• फाइल्स ओपि करिे में 
• प्रोग्राम चलािे में 
• वेब ब्राउजज़ंग (ललकं जक्ट्लक करिा) 
• गेम्स खेलि ेमें 
• ड्रॉइंग या डडजाइनिगं टूल्स में 

   8. Mouse से जुडे शॉटडकट्स (Mouse + Keyboard) 

कायड Shortcut 

Ctrl + Mouse Scroll Zoom In/Out 

Shift + Click एक से ज़्यादा आइटम सेलेक्ट्ट करिा 

Right Click Shortcut Menu खोलिा 

Double Click ककसी फाइल/फोल्डर को खोलिा 



ननष्कषड: 

     Mouse कंप्यूटर का बहुत ही उपयोग़ी इनपुट डििाइस है जो त्रबिा कीबोडड टाइवपगं के काम करिे में मदद 

करता है 

 

Scanner क्या है?  

   1. Scanner क्या है? 

• Scanner एक इनपुट डििाइस है 

• यह ककसी कागज पर बऩी फोटो, द्तािेज़ या टेक््ट को डिक्जटल फॉमेट में कंप्यूटर में ले आता है 

• यह वप्रटंर का उल्टा कायड करता है 

   2. Scanner का कायड (Function of Scanner) 

• स्कैिर कागज़ की Image, Text, या Barcode को डिक्जटल िाटा में बदलता है 

• स्कैि की गई फाइलें JPG, PNG, PDF या DOC फॉमटे में सेव की जा सकती हैं 
• OCR (Optical Character Recognition) के ज़ररए हाथ से ललखा या वप्रटेंि टेक््ट को एडडटेबल टेक्ट्स्ट 

में बदल सकते हैं 

 

   3. Scanner के प्रकार (Types of Scanner) 

प्रकार वििरण 

Flatbed Scanner सबसे सामान्य, फोटोकॉपी मशीि जैसा ढक्ट्कि होता है 

Handheld Scanner हाथ से स्कैि करिे वाला छोटा स्कैिर 

Sheet-fed Scanner पेपर को अंदर खीचंकर स्कैि करता है 

Drum Scanner प्रोफेशिल/हाई-क्ट्वाललटी स्कैनिगं के ललए 

Barcode Scanner प्रोडक्ट्ट का कोड स्कैि करता है (जैस ेसुपरमाकेट में) 

QR Code Scanner QR कोड को स्कैि कर जािकारी प्राप्त करता है (जैस ेमोबाइल पेमेंट्स में) 

 



 

 

   4. Scanner का उपयोग (Uses of Scanner) 

• फोटो या डॉक्ट्युमेंट डडजजटल फॉमड में बदलिा 
• पुरािे डॉक्ट्युमेंट्स को सेव करिा 
• हस्तललखखत फॉम्सड को कंप्यूटर में लािा 
• ID Cards, Signatures स्कैि करिा 
• OCR की मदद से Text को Editable बिािा 
• Barcode या QR को स्कैि कर Product या ललकं एक्ट्ससे करिा 

 

   5. OCR (Optical Character Recognition) क्या है? 

• OCR टेक्ट्िोलॉजी स्कैि की गई Image/Text को Editable Text में बदलती है 

• उदाहरण: पेपर पर ललखा िाम स्कैि करके वडड फाइल में किवटड करिा 

 

   6. Scanner बनाम Printer 

फीचर Scanner Printer 

कायड पेपर को डडजजटल बिाता है डडजजटल को पेपर में बदलता है 

प्रकार Input Device Output Device 

उदाहरण फोटो स्कैि करिा डॉक्ट्युमेंट वप्रटं करिा 

 

   7. Scanner का आउटपुट क्या होता है? 

• Output: डडजजटल फॉमेट में Image या PDF 

• यह कंप्यूटर की RAM या हाडड डडस्क में सेव हो सकता है 

 



   8. Scanner को कंप्यूटर से कैस ेजोडें? 

• USB केबल या वायरलेस (Wi-Fi) 

• कंप्यूटर में ड्राइवर इंस्टॉल करिा होता है 

• सॉफ्टवेयर से स्कैनिगं ऑप्शि चुिकर Scan ककया जाता है 

 

ननष्कषड: 

     Scanner एक जरूरी इिपुट डडवाइस है जो डॉक्ट्युमेंट्स और इमेज को डडजजटल फॉमड में लािे का काम करता 
है। 
     यह ऑकफस, स्कूल, बैंक और मोबाइल ऐप्स में रोज़मराड के कामों में इस्तेमाल होता है। 
     O Level एग्जाम में "Scanner क्ट्या है?", "Scanner के प्रकार", "Scanner vs Printer" जैस ेप्रश्ि पूछे 

जात ेहैं। 

आउटपुट डििाइस ( output device) 

• Monitor: जािकारी ददखाि ेके ललए। 
• Printer: जािकारी वप्रटं करिे के ललए। 
• Speaker: ऑडडयो आउटपुट के ललए। 

Monitor क्या है?  

   1. Monitor क्या है? 

• Monitor एक Output Device (आउटपुट डििाइस) है 

• इसका उपयोग कंप्यूटर द्वारा ककए गए कायों को दृश्य रूप (Visual Form) में ददखािे के ललए ककया 
जाता है 

• यह कंप्यूटर का मुख्य डि्प्ल े्रीन होता है 

   2. Monitor का कायड (Function of Monitor) 

• कंप्यूटर में जो भी प्रोसेस हो रहा है, उस ेText, Image, Video, या Graphical Format में ददखाता है 

• हम जो कुछ भी टाइप या जक्ट्लक करत ेहैं, उसका पररणाम Monitor पर ददखाई देता है 

 



   3. Monitor के प्रकार (Types of Monitor) 

प्रकार वििरण 

CRT Monitor पुरािा, भारी और मोटा Monitor (Cathode Ray Tube) 

LCD Monitor पतला और हल्का, कम त्रबजली खपत (Liquid Crystal Display) 

LED Monitor LCD से बेहतर, ब्राइट और तजे (Light Emitting Diode) 

OLED Monitor हाई क्ट्वाललटी, अल्रा जस्लम, महंगा (Organic LED) 

Touch Screen Monitor Display के साथ Input भी (ATM, मोबाइल) 

 

   4. Monitor के Parts (मुख्य भाग) 

भाग वििरण 

Screen/Panel जहााँ आउटपुट ददखता है 

Bezel फे्रम जो स्रीि को घेरे रहता है 

Stand/Base Monitor को सहारा देिे वाला दहस्सा 

Ports (VGA/HDMI/USB) कंप्यूटर से किेक्ट्ट करिे के ललए 

 

   5. Monitor से जुडे मापदंि (Specifications) 

मापदंि मतलब 

Size (इंच में) स्रीि का आकार (जैस े15”, 24”) 

Resolution वपक्ट्सेल की संख्या (जैस े1920x1080) 

Refresh Rate स्रीि अपडेट की गनत (जैस े60Hz, 144Hz) 



मापदंि मतलब 

Aspect Ratio Width:Height (जसै े16:9, 4:3) 

   6. Monitor के उपयोग (Uses of Monitor) 

• कंप्यूटर पर काम करत ेसमय स्रीि पर आउटपुट देखिा 
• टेक्ट्स्ट टाइवपगं, प्रोग्रालमगं 

• फोटो एडडदटगं, वीडडयो देखिा 
• गेलमगं और डडजाइनिगं 

• प्रेजेंटेशि और पढाई में उपयोग 

 

   7. Monitor इनपुट या आउटपुट डििाइस? 

• Monitor एक Output Device है 

• क्ट्योंकक यह लसफड  कंप्यूटर से िाटा लेकर उस ेददखाता है, कोई इिपुट िहीं लेता (लसवाय Touch Screen 

के) 

   8. Monitor बनाम Printer 

फीचर Monitor Printer 

प्रकार Output Device Output Device 

आउटपुट Screen पर ददखाई देता है पेपर पर ददखाई देता है 

फॉमेट डडजजटल (Temporary) Physical (Permanent) 

खचड त्रबजली कागज और इंक 

 

   9. Monitor से जुडे पोट्डस (Ports) 

• VGA (पुराना) 
• HDMI (HD Display) 
• DisplayPort 



• USB-C (नया मॉननटर) 

 

 ननष्कषड 

 Monitor कंप्यूटर का एक मुख्य Output Device है 

यह कंप्यूटर द्वारा ककए गए सभी कायों को यूज़र को विज़अुल रूप में ददखाने का माध्यम है 

 O Level में "Monitor क्ट्या है?", "Monitor के प्रकार", और "Output Devices  

 

  1. Printer क्या है? 

• Printer एक Output Device है 

• यह कंप्यूटर में तैयार की गई जािकारी को पेपर पर वप्रटं करता है 

• वप्रटंर का आउटपुट Hard Copy (कागज़ पर जानकारी) होता है 

 

   2. Printer का कायड (Function of Printer) 

• स्रीि पर ददख रही जािकारी जैस:े 

o टेक्ट्स्ट डॉक्ट्युमेंट 

o इमेज 

o ररपोट्डस 

o फोटो 
इि सभी को कागज़ पर ्थाय़ी रूप में छापना 

 

   3. Printer के प्रकार (Types of Printers) 

A. Impact Printers 

प्रकार वििरण 

Dot Matrix Printer छोटे वपन्स से डॉट बिाकर वप्रटं करता है; शोर करता है 



प्रकार वििरण 

Daisy Wheel Printer टाइपराइटर जैसा; धीमा लेककि साफ वप्रदंटगं 

Line Printer एक बार में पूरी लाइि वप्रटं करता है (बडे़ संस्थािों में उपयोग) 

 Non-Impact Printers 

प्रकार वििरण 

Inkjet Printer स्याही की बंूदों से वप्रटं करता है; फोटो वप्रटं में अच्छा 

Laser Printer लेज़र बीम से तेज़ और स्पष्ट वप्रदंटगं करता है; ऑकफस उपयोग में 

Thermal Printer गमी से वप्रटं करता है; त्रबल मशीि/ATM में 

3D Printer असली चीज़ें बिाता है (3D मॉडल जैस ेखखलौिे, पाट्डस) 

 

   4. Printer के Parts (मुख्य भाग) 

भाग कायड 

Tray पेपर रखि ेके ललए 

Cartridge Ink या Toner भरिे के ललए 

Rollers पेपर को अंदर खीचंि ेके ललए 

Print Head स्याही/टोिर को पेपर पर डालिे के ललए 

Port (USB/Wi-Fi) कंप्यूटर से किेक्ट्शि के ललए 

 

   5. Printer से जुड़ी यूननट्स (Important Terms) 



शब्द अथड 

Print Quality DPI (Dots Per Inch) – जजतिी ज़्यादा DPI, उतिी बेहतर क्ट्वाललटी 

Speed PPM (Pages Per Minute) – एक लमिट में ककतिे पेज वप्रटं होत ेहैं 

Duplex Printing दोिों साइड (front + back) वप्रटं करिा 

Draft Mode जल्दी और कम स्याही में वप्रदंटगं मोड 

 

   6. Printer का उपयोग (Uses of Printer) 

• दस्तावेज़ वप्रटं करिा (जैस ेफॉमड, लेटर) 
• स्कूल प्रोजेक्ट्ट्स, असाइिमेंट्स 

• फोटो वप्रटं करिा 
• ऑकफस ररपोट्डस 

• इिवॉइस/त्रबल 

• 3D मॉडल (3D Printing) 

 

   7. Printer Output क्या होता है? 

• Printer का आउटपुट होता है: 

Hard Copy (कागज़ पर वप्रटेंि जानकारी) 

 

   8. Printer इनपुट या आउटपुट डििाइस है? 

• Printer एक Output Device है 

• क्ट्योंकक यह कंप्यूटर की जािकारी को डिक्जटल से क्रफक्जकल फॉमड में बदलता है 

 

   9. Printer बनाम Monitor 



फीचर Printer Monitor 

प्रकार Output Device Output Device 

आउटपुट कागज़ पर (Hard Copy) स्रीि पर (Soft Copy) 

स्थानयत्व स्थायी अस्थायी 

उपयोग डॉक्ट्युमेंट, ररपोटड देखिा, एडडट करिा 

 

   10. Wireless Printers 

• Wi-Fi या Bluetooth से चलते हैं 
• मोबाइल या लैपटॉप से डायरेक्ट्ट वप्रटं 

• अब अगधकतर ऑकफस और घरों में Wireless Printer आम हैं 

 

 ननष्कषड: 

 Printer कंप्यूटर का महत्वपूणड Output Device है 

 यह टेक्ट्स्ट और इमेज को हाडड कॉपी में बदलिे का कायड करता है 

 O Level में "Printer के प्रकार", "Impact vs Non-Impact", और "Printer vs Monitor" जैस ेप्रश्ि पूछे जात ेहैं 

 

 मेमोरी (MEMORY) 

• Primary Memory: RAM (Temporary), ROM (Permanent) 
• Secondary Memory: Hard Disk, Pen Drive 

• Cache Memory: प्रोसेसर के पास Temporary Storage 

   1. Primary Memory क्या है? (RAM और ROM ) 

• Primary Memory को Main Memory या Internal Memory भी कहा जाता है 

• यह कंप्यूटर की वह मेमोरी होती है, जो सीध ेCPU से जुड़ी होती है 

• यह डाटा को अ्थाय़ी (Temporary) या ्थाय़ी (Permanent) रूप में स्टोर करती है 

• इसमें दो प्रमुख प्रकार होत ेहैं: RAM और ROM 



 

   2. RAM (Random Access Memory) 

विशेषता वििरण 

पूरा िाम Random Access Memory 

प्रकार Temporary Memory (अ्थाय़ी) 

कायड प्रोग्राम और डेटा को अस्थायी रूप से स्टोर करता है, जब तक कंप्यूटर चालू है 

वोलाटाइल (Volatile) हााँ – कंप्यूटर बदं होत ेही RAM का डाटा लमट जाता है 

गनत (Speed) तेज़ 

यूज़ जब हम कोई ऐप, ब्राउज़र, गमे या फाइल खोलत ेहैं, तो वह RAM में लोड होती है 

उदाहरण DDR4, DDR5 RAM 

 

 RAM का उपयोग: 

• ऑपरेदटगं लसस्टम को चलािे 

• सॉफ्टवेयर एजप्लकेशि रि करिे 

• मल्टीटाजस्कंग करिे में सहायता 

   3. ROM (Read Only Memory) 

विशेषता वििरण 

पूरा िाम Read Only Memory 

प्रकार Permanent Memory (्थाय़ी) 

कायड कंप्यूटर के शुरू होत ेसमय आवश्यक निदेश स्टोर करता है 

वोलाटाइल (Volatile) िहीं – डाटा स्थायी रूप से सेव रहता है 



विशेषता वििरण 

गनत (Speed) RAM से धीमी 

यूज़ Booting प्रकरया में उपयोग होता है – BIOS स्टोर करता है 

उदाहरण PROM, EPROM, EEPROM 

ROM का उपयोग: 

• BIOS (Basic Input Output System) स्टोर करिे के ललए 

• कंप्यूटर को ऑि करत ेसमय आवश्यक स्टेप्स को याद रखिे के ललए 

 

   4. RAM vs ROM (तुलना चाटड) 

फीचर RAM ROM 

पूरा िाम Random Access Memory Read Only Memory 

प्रकार Temporary Permanent 

डेटा लमटता है? हााँ (Power Off होिे पर) िहीं 

डाटा बदल सकते हैं? हााँ िहीं (लसफड  ववशेष तरीकों से) 

कायड रनिगं प्रोग्राम और प्रोसेस स्टाटडअप निदेश 

गनत तेज़ धीमी 

उदाहरण DDR4, DDR5 BIOS, Firmware 

   5. Primary Memory की विशेषताएाँ 

• CPU के सबसे िज़दीक होती है 

• कंप्यूटर के प्रदशडि (Performance) में बड़ा योगदाि 

• RAM जजतिी ज़्यादा होगी, उतिा ही तेज़ कंप्यूटर 



• त्रबिा RAM के कंप्यूटर चालू िहीं होता 

 

   6. Primary Memory बनाम Secondary Memory 

फीचर Primary Memory Secondary Memory 

गनत तेज़ धीमी 

वोलाटाइल हााँ (RAM) िहीं 

स्टोरेज सीलमत (2GB-32GB) बहुत ज़्यादा (500GB - 2TB+) 

उदाहरण RAM, ROM Hard Disk, SSD, Pen Drive 

 

 ननष्कषड: 

 RAM और ROM कंप्यूटर की Primary Memory हैं 
 RAM अ्थाय़ी मेमोरी है जो कायड करत ेसमय उपयोग होती है 

 ROM ्थाय़ी मेमोरी है जजसमें कंप्यूटर शुरू होिे के निदेश होते हैं 
 O Level में RAM vs ROM, और Primary vs Secondary Memory जैस ेसवाल आत ेहैं 

 

    1. Secondary Memory क्या है? 

• Secondary Memory को External Memory या Storage Device भी कहत ेहैं 
• यह कंप्यूटर की वह मेमोरी होती है जो डेटा को ्थाय़ी (Permanent) रूप से संग्रदहत करती है 

• इसमें डेटा तब तक सुरक्षक्षत रहता है जब तक उस ेमैन्युअली डडलीट ि ककया जाए 

 

 

 

   2. Secondary Memory की विशेषताएाँ 



विशेषता वििरण 

प्रकार Permanent Memory (स्थायी) 

डेटा लमटता है? िहीं (पावर ऑफ करिे पर भी रहता है) 

गनत Primary Memory से धीमी 

स्टोरेज क्षमता बहुत अगधक (GB से TB तक) 

डेटा लंबे समय तक संग्रहण के ललए 

उपयोग फाइल्स, फोल्डर, सॉफ़्टवेयर, डॉक्ट्युमेंट, वीडडयो स्टोर करिे के ललए 

 

   3. Secondary Memory के प्रकार 

 1. Hard Disk Drive (HDD) 

विशेषता वििरण 

क्ट्या है? कंप्यूटर के अंदर लगा स्टोरेज डडवाइस 

क्षमता 500 GB से 10 TB तक 

प्रकार Internal और External 

गनत औसत (5400 RPM, 7200 RPM) 

उपयोग लसस्टम और डेटा स्टोरेज के ललए 

 2. Solid State Drive (SSD) 

विशेषता वििरण 

क्ट्या है? तेज़ और दटकाऊ स्टोरेज 

गनत बहुत तेज़ (HDD से 5 गुिा तक) 



विशेषता वििरण 

कोई मूववगं पाटड? िहीं 

कीमत HDD से महंगी 

उपयोग OS, गेम्स, हाई-स्पीड स्टोरेज में 

3. Pen Drive (USB Flash Drive) 

विशेषता वििरण 

पोटेबल? हााँ, जेब में ले जा सकते हैं 

क्षमता 4GB से 1TB तक 

उपयोग फाइल रांसफर, स्टोरेज 

किेक्ट्शि USB Port से 

 4. Memory Card (SD Card) 

उपयोग -कैमरा, मोबाइल, टैबलेट में स्टोरेज | 

 प्रकार - SD, MicroSD | 

 पोटेबल - हााँ | 

 5. Optical Disk (CD/DVD) 

 CD - लगभग 700MB | 

 DVD - 4.7 GB या 8.5 GB | 

 उपयोग - म्यूजज़क, कफल्म, सॉफ्टवेयर इंस्टॉल करिा | 

 6. External Hard Disk 

 ववशेषता - कंप्यूटर से बाहर USB केबल से किेक्ट्ट होता है | 

 उपयोग - बैकअप और बडे़ फाइल्स के ललए | 

 क्षमता - 500GB से 5TB+ | 

   4. Secondary Memory बनाम Primary Memory 



विशेषता Primary Memory Secondary Memory 

उदाहरण RAM, ROM Hard Disk, SSD, Pen Drive 

डेटा स्थानयत्व अस्थायी (RAM) स्थायी 

गनत तेज़ धीमी 

स्टोरेज क्षमता कम (2GB–32GB) बहुत अगधक (500GB–10TB+) 

CPU से जुड़ाव डायरेक्ट्ट इिडायरेक्ट्ट (I/O Channel के माध्यम से) 

 

 

   5. Cloud Storage भ़ी Secondary Memory है 

 उदाहरण - Google Drive, Dropbox, OneDrive | 

 लाभ - कही ंसे भी एक्ट्सेस, बकैअप | 

 सीमा - इंटरिेट पर निभडर | 

 ननष्कषड: 

 Secondary Memory कंप्यूटर की स्थायी मेमोरी है, जहााँ हम अपिे फाइल्स, सॉफ्टवेयर और डेटा को लंबे 

समय तक सुरक्षित रख सकते हैं 
 Hard Disk, Pen Drive, SSD, CD/DVD इसके मुख्य उदाहरण हैं 
 O Level में इससे जुडे़ प्रश्ि जैस े– 

“Secondary Memory क्या है?”, “Hard Disk और Pen Drive में अतंर”, “Primary vs Secondary 

Memory” पूछे जात ेहैं 

 Cache Memory क्या है?  

   1. Cache Memory क्या है? 

• Cache Memory एक छोटी लेक्रकन तेज़ Temporary Memory होती है 

• यह CPU (Processor) के बहुत करीब होती है – अक्ट्सर उसी के अदंर बिी होती है 

• इसका काम है – अक्सर इ्तमेाल होने िाले िेटा और इं्रक्शन को अ्थाय़ी रूप से ्टोर करना 



   2. Cache Memory क्यों जरूरी है? 

• CPU को बार-बार RAM तक पहंुचिे में समय लगता है 

• Cache Memory CPU और RAM के बीच एक ब्रिज की तरह काम करती है 

• इससे CPU को तजेी से डेटा लमलता है → कंप्यूटर की स्पीड बढती है 

 

   3. Cache Memory की विशेषताएाँ 

विशेषता वििरण 

प्रकार Temporary Memory 

आकार बहुत छोटा (1MB से 64MB तक) 

गनत RAM से भी तेज़ 

स्थाि CPU के अंदर या बहुत पास 

डेटा Frequently used डेटा स्टोर करती है 

 

 

   4. Cache Memory के Levels (्तर) 

Level वििरण 

L1 Cache सबसे तेज़ और सबसे छोटा (CPU Core के अंदर) 

L2 Cache थोड़ा बड़ा, लेककि L1 से धीमा 

L3 Cache CPU के सभी कोर के ललए साझा कैश; सबसे बड़ा लेककि सबसे धीमा 

   5. Cache Memory vs RAM 



फीचर Cache Memory RAM 

स्थाि CPU के अंदर या िजदीक Motherboard पर 

स्पीड RAM से तजे़ Cache से धीमी 

आकार बहुत छोटा बड़ा (2GB – 32GB) 

लागत महाँगी सस्ती 

उपयोग CPU को जल्दी डेटा देिा सॉफ्टवेयर और OS रि करिा 

 

   6. Cache Memory कैसे काम करत़ी है?  

pgsql 
CopyEdit 

User Request → CPU → Cache Memory → (यदद उपलब्ध हो तो तुरंत डेटा)   
            → िहीं तो RAM → Cache → CPU 

 इस प्रकरया को Cache Hit (लमल गया) और Cache Miss (िहीं लमला) कहा जाता है। 

 

 ननष्कषड: 

 Cache Memory CPU के पास जस्थत एक तजे़ और अ्थाय़ी मेमोरी है 

 इसका काम है CPU को बार-बार RAM तक जािे से बचािा 
 इससे कंप्यूटर की Processing Speed काफी बढ जाती है 

 O Level में पूछा जा सकता है: 

“Cache Memory क्या है?”, “Cache vs RAM”, “L1, L2, L3 Cache क्या है?” 

 

सॉफ्टिेयर (software) 

• System Software: OS, जैस ेWindows/Linux 

• Application Software: MS Word, Excel आदद 

• Utility Software: Antivirus, Compression Tools 



    1. System Software क्या है? 

• System Software वह सॉफ्टवेयर होता है जो कंप्यूटर हािडिेयर और यूज़र के बीच पुल (Bridge) की 
तरह काम करता है 

• यह कंप्यूटर लसस्टम को चलाने, ननयंब्रित करने और अन्य सॉफ्टवेयर को चलाने का प्लटेफॉमड देता है 

   2. System Software के मुख्य कायड 

• कंप्यूटर को चालू करिा (Booting) 

• हाडडवेयर और यूज़र के बीच कम्युनिकेशि 

• एजप्लकेशि सॉफ्टवेयर को सपोटड देिा 
• फाइल्स और मेमोरी को मैिेज करिा 
• इिपुट/आउटपुट डडवाइस को नियंत्रित करिा 

   3. System Software के प्रकार (Types of System Software) 

प्रकार उदाहरण कायड 

Operating System 

(OS) 
Windows, Linux, macOS कंप्यूटर को चलािा, यूज़र इंटरफेस देिा 

Device Drivers Printer Driver, Sound Driver हाडडवेयर को सही तरीके से चलािा 

Utility Programs Antivirus, Disk Cleaner लसस्टम की मेंटेिेंस और सुरक्षा 

Language Translators 
Compiler, Interpreter, 

Assembler 

प्रोग्रालमगं लैंग्वेज को मशीि लैंग्वेज में 
बदलिा 

 

   4. Operating System (OS) क्या है? 

• Operating System एक मुख्य System Software है 

• यह कंप्यूटर को यूज़र के ननदेशों के अनुसार सचंालन करिे में मदद करता है 

• ब्रबना OS, कंप्यूटर काम नही ंकर सकता 

 

   5. Operating System के उदाहरण 



OS का नाम टाइप उपयोग 

Windows GUI Based सबसे लोकवप्रय OS, उपयोग में आसाि 

Linux Open Source फ्री, प्रोग्रामर और सवडर के ललए अच्छा 

macOS Apple का OS Apple कंप्यूटर में 

Android मोबाइल OS स्माटडफोि के ललए 

Ios Apple मोबाइल OS iPhone, iPad के ललए 

   6. System Software vs Application Software 

फीचर System Software Application Software 

कायड लसस्टम को चलािा यूज़र के कायड करिा 

उदाहरण OS, Drivers MS Word, Excel, VLC 

निभडरता हाडडवेयर से जुड़ा System Software पर निभडर 

इंस्टॉल कब होता है पहल ेसे बाद में यूज़र द्वारा 

   7. System Software के लाभ 

• लसस्टम को ऑटोमेदटक मैिेज करता है 

• प्रोग्राम्स को चलािे का प्लटेफॉमड देता है 

• वायरस, एरर चकेकंग जैस ेटूल्स भी देता है 

• मल्टीटाजस्कंग और यूज़र इंटरफेस संभव बिाता है 

 ननष्कषड: 

 System Software कंप्यूटर के ललए आवश्यक सॉफ्टवेयर है 

 यह हाडडवेयर और यूज़र के बीच काम करता है 

 OS (Windows/Linux) इसका मुख्य उदाहरण है 

  
 



 

 

 

 

 

System Software क्या है?”, “OS के प्रकार”, “System vs Application Software 

 System Software vs Application Software –  

विशेषता (Feature) 
System Software (लस्टम 

सॉफ्टिेयर) 
Application Software (एक्प्लकेशन 

सॉफ्टिेयर) 

पररभाषा 
कंप्यूटर हाडडवेयर को चलािे और 
नियंत्रित करिे वाला सॉफ्टवयेर 

यूज़र द्वारा ववलशष्ट कायड करिे के ललए 

उपयोग ककया जािे वाला सॉफ्टवेयर 

उद्देश्य 
लसस्टम को ऑपरेट करिे और अन्य 

सॉफ्टवेयर को सपोटड देिा 
यूज़र के कायड जैस ेललखिा, गगििा, फोटो 
एडडट करिा आदद करिा 

उदाहरण 
Windows, Linux, Device Drivers, 

BIOS, Compiler 

MS Word, Excel, VLC Player, Tally, 

Photoshop 

कौन पहल ेचलता है? 
सबसे पहल ेSystem Software चलता 
है (जैस ेOS) 

बाद में यूज़र की ज़रूरत अिुसार चलाया जाता 
है 

क्रकस पर ननभडर करता 
है? 

हाडडवेयर पर System Software पर 

GUI (Graphical 

Interface) 

कुछ System Software (जसै े

Windows) GUI प्रदाि करत ेहैं 
अगधकतर एजप्लकेशि GUI आधाररत होत ेहैं 

्थापना 
(Installation) 

आमतौर पर पहल ेसे इंस्टॉल होता है या 
OS के साथ आता है 

यूज़र अपिी जरूरत के अिुसार इंस्टॉल करता 
है 

उपयोगकताड इंटरफेस 
ज़रूरी िहीं कक यूज़र इस ेसीध ेउपयोग 

करे 
यूज़र सीध ेइसका उपयोग करता है 



 (Summary) 

• System Software = कंप्यूटर को चलाने के ललए 

• Application Software = यूज़र के काम करने के ललए 

 

Application Software क्या है?  

   1. Application Software क्या है? 

• Application Software वह प्रोग्राम होत ेहैं जो यूज़र की विशेष जरूरतों या कायों को पूरा करने के ललए 

बिाए जात ेहैं 
• ये सॉफ्टवेयर System Software के ऊपर चलत ेहैं और उसका उपयोग करके काम करत ेहैं 
• इन्हें आम भाषा में “Apps” भी कहा जाता है 

 

   2. Application Software के कायड 

• यूज़र को ववलभन्ि कायड करिे में मदद करिा जैस:े 

o टेक्ट्स्ट ललखिा (MS Word) 

o कैलकुलेशि करिा (Excel) 

o फोटो एडडट करिा (Photoshop) 

o वीडडयो देखिा (VLC) 

o ई-मेल भेजिा (Outlook, Gmail) 

   3. Application Software के प्रकार 

 1. General Purpose Software (सामान्य उपयोग) 

हर कोई उपयोग कर सकता है: 

उदाहरण कायड 

MS Word डॉक्ट्युमेंट बिािा 

MS Excel डेटा कैलकुलेशि 



उदाहरण कायड 

PowerPoint प्रेजेंटेशि 

VLC Player म्यूजज़क/वीडडयो देखिा 

Google Chrome इंटरिेट ब्राउजज़ंग 

 2. Specific Purpose Software (विलशष्ट उपयोग) 

खास कायों के ललए बिाए गए सॉफ्टवेयर: 

उदाहरण कायड 

Tally अकाउंदटगं 

Photoshop इमेज एडडदटगं 

AutoCAD इंजीनियररगं डडज़ाइि 

TurboTax टैक्ट्स भरिा 

 3. Customized Software (क्टम बनाया गया) 

ककसी कंपिी/यूज़र की ज़रूरत अिुसार बिाया गया: 

उदाहरण कायड 

School Management Software स्कूल के छािों का डेटा मैिेज करिा 

Hospital Software मरीजों की जािकारी रखिा 

 

   4. Application Software की विशेषताएाँ 



विशेषता वििरण 

यूज़र फ्रें डली इंटरफेस आसाि होता है 

इंस्टॉल करिा यूज़र की ज़रूरत के अिुसार 

काम ववशेष या सामान्य कायड करिा 

निभडरता System Software पर निभडर होता है 

 

   5. Application Software के लाभ 

• कायड को आसाि और तेज़ बिात ेहैं 
• ऑटोमेशि द्वारा समय बचात ेहैं 
• हर क्षेि के अिुसार सॉफ्टवेयर उपलब्ध हैं 

जैस:े बैंककंग, एजुकेशि, मेडडकल, त्रबज़िेस, डडज़ाइि 

 

   6. Application Software vs System Software 

फीचर Application Software System Software 

उद्देश्य यूज़र का काम करिा लसस्टम को चलािा 

उदाहरण Word, Excel, VLC Windows, Linux 

उपयोग टेक्ट्स्ट, कैलकुलेशि आदद Booting, Memory Management 

निभडरता System Software पर स्वतंि 

 

 

 

 ननष्कषड: 



Application Software हमारे दैननक कायों को कंप्यूटर पर करने के ललए उपयोग होता है 

 यह System Software पर निभडर होता है 

 

Utility Software क्या है? 

   1. Utility Software क्या होता है? 

• Utility Software एक प्रकार का System Software होता है 

• इसका काम कंप्यूटर लसस्टम को सुरक्षित रखना, प्रदशडन सुधारना, और मेंटेनेंस करिा होता है 

• इस ेहम सहायक सॉफ्टिेयर (Helper Programs) भी कह सकते हैं 

 

   2. Utility Software के कायड 

• कंप्यूटर को वायरस से बचािा 
• फाइल को कंप्रेस करिा (छोटा करिा) 
• हाडड डडस्क को साफ करिा 
• डाटा बैकअप लेिा 
• लसस्टम को तेज़ और सुरक्षक्षत बिािा 

   3. Utility Software के प्रकार और उदाहरण 

प्रकार कायड उदाहरण 

    Antivirus Software वायरस, मालवेयर, स्पाइवेयर को हटािा Quick Heal, Avast, Norton 

       File Compression 

Software 
बड़ी फाइल को छोटा करिा WinRAR, 7-Zip, WinZip 

       Backup Software डेटा की कॉपी बिािा Acronis, Windows Backup 

      Disk Cleanup Tools Temporary Files हटािा Windows Disk Cleanup 

        Disk Defragmenter 
Fragmented Files को व्यवजस्थत 

करिा 
Windows Defragment 

Tool 

  Encryption Tools फाइल्स को पासवडड से सुरक्षक्षत करिा VeraCrypt, BitLocker 



प्रकार कायड उदाहरण 

       System Performance 

Tools 
RAM/CPU यूज़ मॉनिटर करिा Task Manager, CCleaner 

 

 

 

   4. Utility Software की विशेषताएाँ 

विशेषता वििरण 

साइज में छोटा परंतु कायड में शजक्ट्तशाली 

लसस्टम हेल्थ बिाए रखता है स्पीड और सुरक्षा बढाता है 

यूज़र द्वारा चलाया जाता है या ऑटोमेदटक भी रि हो सकता है 

OS के साथ आता है या अलग से इंस्टॉल होता है  

 

   5. Utility Software vs System/Application Software 

तुलना Utility Software System Software Application Software 

कायड मेंटेिेंस व सुरक्षा लसस्टम चलािा यूज़र का काम करिा 

उदाहरण Antivirus, Backup Windows, Linux Word, Excel 

जरूरी हााँ – पर कुछ वैकजल्पक होत ेहैं अत्यंत जरूरी यूज़र पर निभडर 

 

 ननष्कषड: 

Utility Software कंप्यूटर के ललए डॉक्ट्टर जैसा होता है — 

यह लसस्टम को स्वस्थ, तेज़ और सुरक्षक्षत रखि ेमें मदद करता है 

 



 O Level में पूछे जात ेहैं प्रश्ि जैस:े 

"Utility Software क्या है?", "Antivirus और Compression Tool का उपयोग", "System vs Utility 

Software" 

 नंबर लस्टम ( NUMBER SYSTEM ) 

• Binary (0,1) 
• Decimal (0-9) 

• Conversion जैस ेDecimal to Binary 

Binary Number System क्या है?  

 

   1. Binary Number System क्या है? 

• Binary System कंप्यूटर की भाषा होती है 

• इसमें केवल दो अंक (Digits) होत ेहैं: 
0 (शून्य) और 1 (एक) 

• इस ेBase-2 System भी कहा जाता है 

• कंप्यूटर सभी डेटा को अंततः 0 और 1 में ही प्रोसेस करता है 

 

   2. Binary System का महत्ि 

• कंप्यूटर केवल ऑन (1) और ऑफ (0) को समझ सकता है 

• इसललए सभी टेक्ट्स्ट, िंबर, इमेज, वीडडयो — सब कुछ Binary (0,1) में बदला जाता है 

• जैस:े 

o "A" = 01000001 
o "5" = 00110101 

 

   3. Binary Digits को क्या कहत ेहैं? 

• Binary Digit को "Bit" कहा जाता है 

• 8 Bits = 1 Byte 



Units Value 

1 Nibble 4 Bits 

1 Byte 8 Bits 

1 KB (Kilobyte) 1024 Bytes 

1 MB (Megabyte) 1024 KB 

1 GB (Gigabyte) 1024 MB 

1 TB (Terabyte) 1024 GB 

   4. Binary से Decimal में बदलना (Conversion) 

उदाहरण: Binary = 1010 

→ Position values (right to left): 
1×2³ + 0×2² + 1×2¹ + 0×2⁰ 
= 8 + 0 + 2 + 0 = 10 (Decimal) 

 

 

 

   5. Decimal से Binary में बदलना (Conversion) 

उदाहरण: Decimal = 13 

→ 2 से भाग करत ेजाएाँ: 

sql 
CopyEdit 
13 ÷ 2 = 6, remainder = 1   
6 ÷ 2 = 3, remainder = 0   
3 ÷ 2 = 1, remainder = 1   
1 ÷ 2 = 0, remainder = 1   
→ Binary = 1101 

 

   6. Binary Numbers का उपयोग 



िेि उपयोग 

कंप्यूटर प्रोसेलसगं सभी डेटा 0 और 1 में बदलकर प्रोसेस होता है 

िेटवककिं ग डेटा रांसफर में 

डडजजटल डडवाइसेस जैस:े Calculator, Microprocessor 

प्रोग्रालमगं Low-level languages में 

 

   7. Binary vs Decimal 

Feature Binary Decimal 

Base 2 10 

Digits 0, 1 0 से 9 

कंप्यूटर उपयोग करता है? हााँ िहीं 

समझिे में आसाि िहीं (मािव के ललए) हााँ 

 

ननष्कषड: 

     Binary System (0 और 1) कंप्यूटर की मूल भाषा है 

     कंप्यूटर सभी चीज़ें Bits (Binary Digits) में स्टोर और प्रोसेस करता है 

 

     O Level में प्रश्ि आत ेहैं जैस:े 

“Binary Number क्या है?”, “Decimal से Binary में बदलना”, “1 Byte में क्रकतने Bit होत ेहैं?” 

 Decimal Number System क्या है?  

   1. Decimal Number System क्या है? 

• Decimal System वह संख्या पद्धनत है जजस ेहम दैननक ज़ीिन में सबसे ज़्यादा इ्तेमाल करत ेहैं 
• इसमें 0 से 9 तक कुल 10 अकं (Digits) होत ेहैं: 

0, 1, 2, 3, 4, 5, 6, 7, 8, 9 



• इस ेBase-10 System भी कहा जाता है क्ट्योंकक इसमें 10 आधार अंकों का प्रयोग होता है 

   2. Decimal System की विशेषताएाँ 

विशेषता वििरण 

Base 10 

अंकों की संख्या 10 (0–9) 

प्रयोग सामान्य गणिा, मुद्रा, समय, माप आदद 

हर अंक की पोजीशि का माि होता है जैस े– 325 = 3×100 + 2×10 + 5×1 

 

   3. Place Value System (्थाननक मान प्रणाली) 

जैस ेसंख्या है: 458 

अंक ्थान गणना 

4 Hundreds (10²) 4 × 100 = 400 

5 Tens (10¹) 5 × 10 = 50 

8 Units (10⁰) 8 × 1 = 8 

 कुल = 400 + 50 + 8 = 458 

   4. Binary और Decimal में अंतर 

फीचर Decimal System Binary System 

Base 10 2 

Digits 0 से 9 केवल 0 और 1 

मािव उपयोग करता है? हााँ िहीं (कंप्यूटर करता है) 

कंप्यूटर समझता है? िहीं हााँ 



 

   5. Decimal से Binary में बदलना (Conversion) 

उदाहरण: Decimal = 13 

sql 
CopyEdit 
13 ÷ 2 = 6 remainder 1   
6 ÷ 2 = 3 remainder 0   
3 ÷ 2 = 1 remainder 1   
1 ÷ 2 = 0 remainder 1   
→ Binary = 1101 

   6. Binary से Decimal में बदलना (Conversion) 

उदाहरण: Binary = 1011 

= 1×2³ + 0×2² + 1×2¹ + 1×2⁰ 
= 8 + 0 + 2 + 1 = 11 (Decimal) 

 

   7. Decimal System का उपयोग कहााँ होता है? 

िेि उदाहरण 

गणिा जोड़, घटाव, गुणा, भाग 

माप ककमी, मीटर, ग्राम 

पैसे रुपये, पैसे 

समय घंटे, लमिट, सेकंड 

 ननष्कषड: 

     Decimal System हमारी सामान्य गणिा प्रणाली है 

     इसमें 0 से 9 तक 10 अकं होत ेहैं (Base 10) 

     कंप्यूटर इस लसस्टम को समझिे के ललए इस ेBinary (0 और 1) में बदलता है 

     O Level में अक्ट्सर पूछा जाता है: 

 



 

 

“Decimal System क्या है?”, “Decimal से Binary में कैस ेबदलें?” 

 Decimal to Binary Conversion  

   1. Decimal Number System (Base 10) 

• इसमें 10 digits होत ेहैं: 0 से 9 

• यह सामान्य गणिा प्रणाली है 

   2. Binary Number System (Base 2) 

• इसमें केवल 2 digits होत ेहैं: 0 और 1 

• यह कंप्यूटर की भाषा है 

 

 Decimal को Binary में कैसे बदलें 

Step-by-Step तरीका: 

1. Decimal संख्या को 2 से भाग करें 
2. Quotient को कफर से 2 से भाग करत ेरहें 
3. जब तक Quotient = 0 ि हो जाए 

4. Remainders को ऩीच ेसे ऊपर (Bottom to Top) पढें – वही Binary Number होगा 

 

उदाहरण 1: Decimal 13 को Binary में बदलें 

markdown 
CopyEdit 

13 ÷ 2 = 6   शेष (R) = 1   

6 ÷ 2  = 3   शेष = 0   

3 ÷ 2  = 1   शेष = 1   

1 ÷ 2  = 0   शेष = 1 

 

→ Binary = ऊपर से िीच:े **1101** 



 13 (Decimal) = 1101 (Binary) 

 

 उदाहरण 2: Decimal 25 को Binary में बदलें 

markdown 
CopyEdit 

25 ÷ 2 = 12  शेष = 1   

12 ÷ 2 = 6   शेष = 0   

6 ÷ 2 = 3    शेष = 0   

3 ÷ 2 = 1    शेष = 1   

1 ÷ 2 = 0    शेष = 1 

 
→ Binary = **11001** 

 25 (Decimal) = 11001 (Binary) 

 Decimal → Binary Conversion Table (0–15) 

Decimal Binary 

0 0 

1 1 

2 10 

3 11 

4 100 

5 101 

6 110 

7 111 

8 1000 

9 1001 

10 1010 

11 1011 

12 1100 



Decimal Binary 

13 1101 

14 1110 

15 1111 

 ननष्कषड: 

     Decimal से Binary में बदलिा आसाि है – बस 2 से भाग करत ेजाए ं

     O Level में अक्ट्सर 1 या 2 अकं के सवाल आत ेहैं: 
“Convert 19 to binary”, “Decimal to binary steps” आदद 

                                  Chapter 2 

   Operating System (ऑपरेदटगं लस्टम) 

2.1 ऑपरेदटगं लस्टम क्या है? 

ऑपरेदटगं लसस्टम (Operating System - OS) एक ऐसा लसस्टम सॉफ्टवेयर है जो कंप्यूटर हाडडवेयर और यूजर 
के बीच इंटरफेस का काम करता है। यह सभी सॉफ्टवेयर और हाडडवेयर ररसोसड को मैिेज करता है। 

मुख्य कायड: 

• फाइल और फोल्डर मैिेज करिा 
• मेमोरी और प्रोसेसर मैिेज करिा 
• यूजर इंटरफेस प्रदाि करिा 
• डडवाइस मैिेजमेंट 

2.2 ऑपरेदटगं लस्टम के प्रकार: 

1. Single-user OS: एक यूजर द्वारा एक समय में उपयोग (जैस:े MS-DOS) 

2. Multi-user OS: कई यूजर एक साथ उपयोग कर सकते हैं (जैस:े Unix) 

3. Real-Time OS: तुरंत प्रनतकरया देिे वाला OS (जैस:े RTLinux, VxWorks) 

4. Batch OS: एक साथ कई प्रोग्राम को बैच में चलाता है 

5. Time-sharing OS: प्रोसेसर का समय कई यूजर के बीच बांटता है 

 



 Single-User Operating System क्या है?  

   1. पररभाषा (Definition): 

• Single-User Operating System वह OS होता है जो एक समय में केिल एक ही यूज़र को काम 

करिे की अिुमनत देता है 

• यह OS एक व्यक्क्त के कायों को मैनेज करता है, चाहे उसमें कई प्रोग्राम चल रहे हों 

   2. विशेषताएाँ (Features): 

विशेषता वििरण 

     एक यूज़र एक समय में केवल एक यूज़र लॉग इि कर सकता है 

    सरल डडज़ाइि लसस्टम सरल होता है और आसाि इंटरफेस प्रदाि करता है 

      संसाधि उपयोग सभी लसस्टम संसाधि (CPU, RAM) एक ही यूज़र को लमलते हैं 

    मल्टीटाजस्कंग हो सकती है हााँ, पर एक ही यूज़र के ललए 

   लागत कम आसाि सेटअप और सस्ता मेंटेिेंस 

 

   3. उदाहरण (Examples): 

OS का नाम वििरण 

MS-DOS Command Line Based पुरािा OS 

Windows 10/11 (Home) Graphical Interface, एक ही यूज़र उपयोग करता है 

macOS (Single User Mode) Mac पर एक यूज़र के ललए 

Android (Mobile OS) स्माटडफोि पर एक यूज़र के ललए उपयोग 

 

   4. लाभ (Advantages): 



• उपयोग में आसाि 

• सेटअप और मेंटेिेंस कम 

• संसाधिों का पूरा उपयोग एक यूज़र द्वारा 
• Home और Personal यूज़ के ललए आदशड 

   5. स़ीमाएाँ (Limitations): 

• एक समय में केिल एक यूज़र ही काम कर सकता है 

• िेटवकड  पर साझा उपयोग (multi-user environment) िहीं कर सकत े

• बहुत अगधक उपयोग या प्रोफेशिल यूज़ के ललए सीलमत 

 

   6. Single-User vs Multi-User OS 

तुलना Single-User OS Multi-User OS 

यूज़र एक यूज़र कई यूज़र एक साथ 

उदाहरण MS-DOS, Windows 10 Home UNIX, Linux Server 

संसाधि बंटवारा पूरा एक यूज़र को संसाधि साझा होत ेहैं 

जदटलता कम अगधक 

 

 ननष्कषड: 

 Single-User Operating System एक सरल, व्यक्क्तगत उपयोग के ललए बिा OS है 

 यह एक यूज़र को लसस्टम कंरोल और मल्टीटाजस्कंग की सुववधा देता है 

 O Level में अक्ट्सर पूछा जाता है: 

“Single-User OS क्या है?”, “MS-DOS क्रकस प्रकार का OS है?”, या “Single vs Multi-user OS” 

 

Multi-user Operating System क्या है?  

   1. पररभाषा (Definition): 



• Multi-user Operating System वह OS होता है जजसमें एक साथ कई यूज़र एक ही कंप्यूटर लसस्टम 

को अलग-अलग टलमडनल्स से उपयोग कर सकत ेहैं 
• यह OS सभी यूज़सड को संसाधि (Resources) समान रूप से और सुरक्षित रूप से प्रदान करता है 

   2. विशेषताएाँ (Features): 

विशेषता वििरण 

   कई यूज़र एक समय में अिेक यूज़र लसस्टम पर लॉग इि कर सकते हैं 

    संसाधि नियंिण हर यूज़र को उगचत CPU, RAM, Disk Space लमलता है 

     सुरक्षा हर यूज़र की फाइल्स और डेटा सुरक्षक्षत रहत ेहैं 

      टलमडिल एक्ट्सेस यूज़र ववलभन्ि टलमडिल से लॉग इि कर सकते हैं (लोकल या िेटवकड ) 

    प्रोसेलसगं OS सभी यूज़र की ररक्ट्वसे्ट को सही ढंग से मैिेज करता है 

 

   3. उदाहरण (Examples): 

OS का नाम वििरण 

UNIX सबसे लोकवप्रय मल्टी-यूज़र OS 

Linux (Ubuntu, CentOS, etc.) Servers में सबसे ज़्यादा प्रयोग 

Windows Server कंपिी, िेटवकड  लसस्टम के ललए 

Mainframe OS (IBM z/OS) बैंककंग, रेलवे जैस ेबडे़ लसस्टम में 

 

   4. लाभ (Advantages): 

•        सभी यूज़सड एक ही लसस्टम को इस्तेमाल कर सकते हैं 
•        स्टोरेज और डेटा साझा कर सकते हैं 
•      व्यजक्ट्तगत सुरक्षा और एक्ट्सेस कंरोल 



•     High Performance और Reliability 

   5. स़ीमाएाँ (Limitations): 

•     Complex लसस्टम मैिेजमेंट 

•      Trained Admin की जरूरत होती है 

•    हाडडवेयर और िेटवककिं ग कॉस्ट अगधक 

•     खराब कॉजन्फगरेशि से लसस्टम स्लो हो सकता है 

   6. Single-User vs Multi-User OS 

तुलना Single-User OS Multi-User OS 

यूज़र एक समय में एक एक साथ कई यूज़र 

उदाहरण Windows 10, MS-DOS UNIX, Linux Server 

संसाधि ववतरण पूरा एक को बााँटकर सभी को 

उपयोग Personal Server/Network 

 

 ननष्कषड: 

     Multi-user Operating System एक ऐसा लसस्टम है जो कई यूज़सड को एक साथ कंप्यूटर लसस्टम के 

उपयोग की सुववधा देता है 

     यह सुरक्षा, संसाधि ववतरण और डेटा शेयररगं को प्रभावी रूप से मैिेज करता है 

     O Level में अक्ट्सर पूछा जाता है: 

“Multi-user OS क्या है?”, “UNIX क्रकस प्रकार का OS है?”, “Single vs Multi-user OS” 

 

Real-Time Operating System (RTOS) क्या है? 

   1. पररभाषा (Definition): 

• Real-Time Operating System (RTOS) वह OS होता है जो िेटा को तुरंत प्रोसेस करता है, त्रबिा 
ककसी देरी के 



• इसका मुख्य उद्देश्य होता है – सही समय पर सही प्रनतक्ररया देना (Time-Critical Response) 

• यह ननक्श्चत समय स़ीमा (Deadline) के भीतर कायड करता है 

 

   2. विशेषताएाँ (Features): 

विशेषता वििरण 

        समय की पाबंदी सभी कायड तय समय (Deadline) में पूरे होत ेहैं 

    Fast Processing बहुत तेज़ डेटा प्रोसेलसगं 

    Deterministic हर काम का समय पहल ेसे तय होता है 

    लगातार निगरािी मशीिों/लसस्टम्स की निरंतर Monitoring 

    Minimum Latency Delay ि के बराबर 

 

   3. प्रकार (Types of RTOS): 

प्रकार वििरण उदाहरण 

Hard RTOS हर Task समय पर पूरा होिा ज़रूरी Missile System, Medical System 

Soft RTOS थोड़ी-सी देरी स्वीकायड Mobile Games, Multimedia Apps 

 

   4. RTOS के उदाहरण (Examples): 

RTOS का नाम उपयोग िेि 

VxWorks एयरोस्पेस, रक्षा प्रणाली 

RTLinux रोबोदटक्ट्स, Embedded Systems 

QNX ऑटोमोबाइल्स (जैस ेTesla, BMW) 



RTOS का नाम उपयोग िेि 

FreeRTOS IoT Devices, Smart Appliances 

Windows CE Embedded devices (PDA, Handhelds) 

 

   5. RTOS कहााँ उपयोग होता है? (Uses): 

िेि उपयोग 

        रक्षा और एयरोस्पेस लमसाइल लसस्टम, रडार कंरोल 

          मेडडकल लसस्टम ICU मॉनिटररगं, हाटड मशीिें 

         ऑटोमोबाइल बे्रककंग लसस्टम, ऑटो-पायलट 

         रोबोदटक्ट्स Sensor और actuator नियंिण 

           इंडजस्रयल मशीि ऑटोमेशि और कंरोल लसस्टम 

 

   6. RTOS vs General Purpose OS (जैस ेWindows): 

फीचर RTOS General OS (Windows) 

प्रनतकरया समय निजश्चत और तेज़ अनिजश्चत 

मल्टीटाजस्कंग सटीक और नियंत्रित अगधक पर अनियलमत 

प्रयोग Time-critical लसस्टम Personal और Business use 

उदाहरण RTLinux, QNX Windows 10, Linux Ubuntu 

 

ननष्कषड: 

     Real-Time Operating System (RTOS) समय-संवेदिशील कायों के ललए प्रयोग होता है 

     यह उि क्षिेों में उपयोग होता है जहा ंलसफड  तेज़ नहीं, बक्ल्क समय-ननक्श्चत जिाब जरूरी होता है 



     O Level में पूछा जा सकता है: 

“RTOS क्या है?”, “RTOS के प्रकार”, “General OS और RTOS में अंतर” 

 

 Batch Operating System क्या है?  

   1. पररभाषा (Definition): 

• Batch Operating System वह लसस्टम होता है जजसमें यूज़र के कायों को बैच (Batch) में इकट्ठा 
करके एक साथ प्रोसेस ककया जाता है 

• इसमें स़ीधे यूज़र इंटरैक्शन नहीं होता — सभी जॉब्स पहल ेसे तैयार करके OS को ददए जात ेहैं 
• यह कंप्यूटर का पहला OS प्रकार था जो ऑटोमटेेि Execution करता था 

   2. Batch का मतलब क्या है? 

• Batch = एक साथ कई कामों का समूह 

• उदाहरण: वप्रदंटगं की 10 फाइलें पहल ेइकट्ठा करके एक साथ प्रोसेस करिा 

   3. कायड प्रणाली (Working Process): 

1. यूज़र अपिी जॉब तैयार करता है (जैस ेप्रोग्राम + डेटा) 
2. जॉब्स को Input Device से OS को भेजा जाता है 

3. OS इि जॉब्स को Batch (समूह) में इकट्ठा करता है 

4. कफर इि जॉब्स को एक-एक करके ऑटोमदैटक प्रोसेस करता है 

5. आउटपुट को Output Device पर भेजता है 

   4. विशेषताएाँ (Features): 

विशेषता वििरण 

     No Direct User Interaction यूज़र OS से सीधे बात िहीं करता 

       Time Efficient समय बचता है, कई काम एक साथ हो जात ेहैं 

    Jobs Automatically Execute जॉब्स को मैन्युअली चलािा िहीं पड़ता 

            Suitable for Repeated Tasks एक जैस ेकामों के ललए उपयोगी 



विशेषता वििरण 

    Input/Output Scheduling Proper समय से सभी जॉब्स चलती हैं 

 

   5. उदाहरण (Examples): 

उपयोग वििरण 

    पुरािे कंप्यूटर (Mainframe) IBM 1401 जैस ेलसस्टम में 

         Print Jobs ऑकफस में वप्रटं जॉब्स को Batch में प्रोसेस करिा 

      डेटा प्रोसेलसगं बैंक, रेलवे जैस ेक्षिेों में जहााँ ढेरों डेटा प्रोसेस होता है 

   6. लाभ (Advantages): 

•  बार-बार होिे वाले कामों के ललए अच्छा 
•  Manual कायड की आवश्यकता िहीं 
•  समय की बचत 

•  ऑटोमेदटक Execution 

   7. स़ीमाएाँ (Limitations): 

•  Real-Time Response िहीं लमलता 
•  यूज़र को पता िहीं चलता कक जॉब कब चलेगी 
•  धीमी प्रोसेलसगं अगर जॉब्स बहुत ज़्यादा हों 
•  Debugging कदठि – Error कहा ंआया ये तुरंत पता िही ंचलता 

   8. Batch OS vs Real-Time OS 

फीचर Batch OS Real-Time OS 

प्रनतकरया देरी से तुरंत (Instant) 

उपयोग पुरािे लसस्टम, डेटा प्रोसेलसगं मेडडकल, रोबोदटक्ट्स, लमसाइल 



फीचर Batch OS Real-Time OS 

यूज़र इंटरफेस िहीं कुछ हद तक होता है 

उदाहरण IBM OS/360 QNX, RTLinux 

 

     ननष्कषड: 

     Batch Operating System पुरािे समय में िेटा प्रोसेलसगं और जॉब Execution के ललए उपयोग होता था 
     यह लसस्टम ऑटोमेदटक होता है लेककि यूज़र इंटरफेस नहीं होता 
     O Level में अक्ट्सर पूछा जाता है: 

"Batch OS क्या है?", "Batch OS की विशेषताएाँ", "Batch vs Real-Time OS" 

 Windows OS इंटरफेस 

(i) Desktop: 

कंप्यूटर चालू करत ेही जो स्रीि ददखाई देती है, उस ेDesktop कहत ेहैं। इसमें Icons, Taskbar, Wallpaper 

होत ेहैं। 

(ii) Icons: 

Shortcuts होत ेहैं ककसी फाइल, प्रोग्राम या फोल्डर को खोलिे के ललए। 

(iii) Start Menu: 

Start बटि पर जक्ट्लक करिे से खुलता है, जजसस ेआप Programs, Settings, Power Options आदद खोल 

सकते हैं। 

(iv) File Explorer                                                                                             

Files और Folders को देखिे, खोलिे और मैिेज करिे का टूल है। 

1. File Explorer खोलने के तरीके: 

तरीका कैस ेखोलें 
Shortcut Key Windows + E 

Start Menu Start > Search “File Explorer” 



तरीका कैस ेखोलें 
Taskbar Folder आइकि (जैस े  ) पर जक्ट्लक करें 

 

 2. File Explorer की मुख्य जगहें (Sections) 

Section काम 

Quick Access Frequently used folders और recent files को जल्दी access करिे के ललए 

This PC / My Computer Hard drive (C:, D:), USB, Documents, Downloads आदद को देखिे के ललए 

OneDrive Microsoft Cloud storage (अगर synced है) 

Network िेटवकड  में जुडे़ अन्य कंप्यूटर या डडवाइस 

Recycle Bin Deleted files को recover या permanently delete करिे के ललए 

 3. मुख्य Components: 

Component वििरण 

Address Bar 
ऊपर की लाइि जो ददखाती है कक आप ककस फोल्डर में हैं (e.g., 

C:\Users\Abha\Documents) 

Navigation Pane बाईं साइड में folder structure 

Ribbon (Menu 
Bar) 

ऊपर का Menu: File, Home, Share, View 

Search Box ककसी फाइल या फोल्डर को खोजिे के ललए 

Preview Pane ककसी फाइल का preview देखिे के ललए (enable करिा पड़ता है) 

 4. File Explorer में क्या-क्या कर सकते हैं? 

काम तरीका 
Folder/फाइल बनाना Right-click > New > Folder या File 

Rename करना Right-click > Rename या F2 key 

Copy / Paste Ctrl + C (Copy), Ctrl + V (Paste) 

Move करना Drag & Drop या Cut (Ctrl + X) 

Search Top-right में Search box 

Sort & View View टैब से (Details, Large Icons, आदद) 



 5. Hidden Files कैस ेदेखें? 

1. View टैब पर जक्ट्लक करें 
2.    "Hidden items" चेक करें 

 

6. Recycle Bin से फाइल Recover या Delete करना 

• Open Recycle Bin 

• Right-click > Restore = वापस original जगह पर 
• या Delete = permanently delete 

 

(v) Control Panel / Settings 

हाडडवेयर, साउंड, िेटवकड  आदद की Settings करिे के ललए उपयोग होता है। 

 Control Panel Open करने के तरीके: 

• Start Menu > Search “Control Panel” > Enter 
• Run Command: control 

 

2.4 फाइल और फोल्िर मैनेजमेंट: 

फाइल (File): 

डाटा और जािकारी का संग्रह, जैस:े Word डॉक्ट्युमेंट, Excel फाइल आदद। 

फोल्िर (Folder): 

फाइल्स को व्यवजस्थत रखि ेके ललए कंटेिर। 

कायड: 

• फाइल बिािा, कॉपी करिा, मूव करिा, डडलीट करिा 
• फोल्डर बिािा और उसका िाम बदलिा 
• File Extension पहचाििा (.docx, .xlsx, .jpg) 



 

2.5 ललनक्स ऑपरेदटगं लस्टम: 

ललनक्स एक Open Source OS है: 

• मुफ्त में उपलब्ध 

• Programmer इस ेModify कर सकते हैं 

Linux Basic Commands: 

Command काम 

pwd वतडमाि डायरेक्ट्टरी ददखािा 
Ls फोल्डर की फाइल्स देखिा 
Cd डायरेक्ट्टरी बदलिा 
mkdir िया फोल्डर बिािा 
Rm फाइल हटािा 
Cp फाइल कॉपी करिा 

 

2.6 मल्टीटाक््कंग और मल्टीप्रोसेलसगं 

• Multitasking: एक समय में एक से अगधक कायड करिा (जैस,े Word और Chrome एक साथ चलािा) 
• Multiprocessing: एक से अगधक CPU का उपयोग करिा ताकक कई प्रोग्राम एक साथ चलें 

 

2.7 फाइल एक्सटेंशन के उदाहरण: 

फाइल टाइप एक्सटेंशन 

वडड डॉक्ट्युमेंट .docx 

एक्ट्सेल शीट .xlsx 

पॉवरपॉइंट .pptx 

इमेज .jpg, .png 

वीडडयो .mp4, .avi 

 



 

 

 

 

 

 

 

 

 

 

                                              

 

 

 

 

                                                   Chapter 3 

                                              Word Processing (ििड प्रोसेलसगं) 

ििड प्रोसेलसगं क्या है? 

वडड प्रोसेलसगं एक सॉफ्टवेयर का उपयोग करके टेक्ट्स्ट आधाररत दस्तावेज़ तैयार करिे, संपाददत करिे, सजािे 

और वप्रटं करिे की प्रकरया है। 

प्रमुख ििड प्रोसेलसगं सॉफ्टिेयर: 

• MS Word (Microsoft Word) 
• LibreOffice Writer 

• Google Docs (ऑिलाइि) 

 



3.2 द्तािेज़ बनाना (Creating a Document) 

• नई फाइल बनाना: File → New 

• फाइल सेि करना: File → Save या Save As → िाम दें और लोकेशि चुिें 
• फाइल खोलना: File → Open → ककसी सेव फाइल को खोलिा 

 

3.3 टेक््ट का फॉमेदटगं (Text Formatting) 

(i) फॉन्ट सेदटगं: 

• Font Type (Arial, Calibri) 
• Font Size (10, 12, 14...) 
• Bold, Italic, Underline 
• Font Color, Highlight 

(ii) पैरा फॉमेदटगं: 

• Alignments: Left, Center, Right, Justify 
• Line Spacing: Single, 1.5, Double 

• Bullets और Numbering 

• Indentation और Paragraph Spacing 

 

3.4 पेज सेटअप और वप्रदंटगं 

• Page Size (A4, Letter) 

• Orientation: Portrait या Landscape 

• Margins सेट करिा 
• Header और Footer जोड़िा 
• Page Number देिा 
• File → Print → Printer, Page Range और Copies सटे करके वप्रटं करिा 

 

3.5 टेबल बनाना और फॉमदेटगं करना 

• Table Insert करना: Insert → Table → Rows × Columns चुिें 
• सेल में टेक्ट्स्ट जोड़िा 



• पंजक्ट्तयााँ (Rows) और कॉलम जोड़िा/हटािा 
• Table Design: Border Style, Shading, Alignment 

 

3.6 चचि, चचिांकन और चाटड जोडना (Inserting Images and Objects) 

• Insert → Picture: Image जोड़िा 
• Insert → Shapes: आकृनत (Circle, Box आदद) जोड़िा 
• Insert → Chart: डेटा के आधार पर ग्राफ जोड़िा 

3.7 ्पले चके और ग्रामर चके 

• Tools → Spelling and Grammar 

• गलत शब्दों को सही सुझाव देिा 
• AutoCorrect Settings 

3.8 Mail Merge (मेल मजड) 

Mail Merge एक ऐसा टूल है जजसस ेआप एक ही डॉक्ट्युमेंट को कई लोगों के ललए अलग-अलग िाम और 
जािकारी के साथ बिा सकते हैं। 

     STEPS: 

1. Main Document तैयार करें (जैस ेएक Letter) 

2. Data Source जोड़ें (Excel Sheet) 

3. Merge Fields Insert करें (जैस ेName, Address) 

4. Preview और Finish Merge 

 

3.9 अन्य उपयोग़ी फीचसड: 

• Find and Replace: ककसी शब्द को ढंूढकर उस ेबदलिा 
• Undo/Redo: ककए गए बदलावों को वापस लािा 
• Zoom and View Modes: Document का आकार और दृश्य बदलिा 
• Track Changes & Comments: टीम में काम करिे के ललए दटप्पखणयााँ जोड़िा 

3.10 शॉटडकट की (Shortcut Keys): 



क्ररया शॉटडकट की 
िई फाइल Ctrl + N 

सेव करिा Ctrl + S 

खोलिा Ctrl + O 

कॉपी करिा Ctrl + C 

पेस्ट करिा Ctrl + V 

वप्रटं करिा Ctrl + P 

Undo Ctrl + Z 

Redo Ctrl + Y 

बोल्ड Ctrl + ⓑ 

इटैललक Ctrl + I 

अंडरलाइि Ctrl + U 

 

1. LibreOffice Writer क्या है? 

• LibreOffice Writer एक फ्री और ओपन-सोसड ििड प्रोसेलसगं सॉफ्टिेयर है। 
• यह Microsoft Word का ववकल्प है और LibreOffice Suite का दहस्सा है। 

मुख्य उपयोग: 

• टेक्ट्स्ट डॉक्ट्युमेंट बिािा 
• लेटर, ररज्यूमे, ररपोटड तैयार करिा 
• PDF फाइल बिािा 
• डॉक्ट्युमेंट वप्रटं करिा 

 

   2. Writer Interface (मुख्य भाग) 

भाग कायड 
Title Bar फाइल का िाम और प्रोग्राम का िाम ददखाता है 

Menu Bar File, Edit, View, Insert, Format आदद ववकल्प 

Toolbar Quick Icons (New, Save, Print, Bold, Italic आदद) 

Formatting Bar Font, Size, Alignment आदद 



भाग कायड 
Status Bar पेज िंबर, भाषा, ज़ूम आदद 

Workspace जहााँ आप कंटेंट टाइप करत ेहैं 
 

 

 

   3. नया िॉक्युमेंट बनाना और सेि करना 

• New Document: File → New → Text Document 
• Open Document: File → Open 
• Save: File → Save / Save As (.odt, .docx, .pdf) 
• Export as PDF: File → Export as PDF 

 

   4. टेक््ट फॉमदेटगं (Text Formatting) 

• Font Type/Size बदलिा 
• Bold (Ctrl+B), Italic (Ctrl+I), Underline (Ctrl+U) 
• Font Color, Highlight 
• Text Alignment: Left, Center, Right, Justify 

• Line Spacing और Paragraph Indent 

 

   5. पेज सेदटगं और लेआउट 

• Margins सेट करिा: Format → Page Style → Page 

• Orientation: Portrait / Landscape 

• Header/Footer जोड़िा: Insert → Header/Footer 

• Page Number: Insert → Page Number 
• Background Color: Format → Page Style → Area 

 

   6. टेबल और चचि जोडना 

• Table Insert: Table → Insert Table → Rows & Columns चुिें 
• Image Insert: Insert → Image → फाइल से चयि करें 
• Shapes / Drawing: Insert → Shape 



• Chart: Insert → Chart (Pie, Bar, Line आदद) 

 

   7. ्टाइल्स और टेम्पप्लेट्स 

• Styles & Formatting (F11) का उपयोग करके Headings, Titles का यूनिफॉमड लुक दे सकते हैं 
• Templates से तैयार फॉमेट में फाइल बिा सकते हैं: File → Templates 

 

   8. ्पेललगं और ग्रामर चके 

• Tools → Spelling and Grammar 

• गलत शब्द पर Right Click → Correct Suggestion 

• AutoCorrect सदेटगं: Tools → AutoCorrect Options 

 

   9. Find, Replace और Navigation 

• Find: Ctrl + F 
• Replace: Ctrl + H 

• Navigation Panel: View → Navigator (F5) → Heading, Table, Bookmarks देखिा 

 

   10. Mail Merge (मेल मजड) 

      STEPS: 

1. Create Form Letter 

2. Connect to Address Data Source (.csv या Spreadsheet) 

3. Insert Fields → Name, Address 
4. Print → Mail Merge Document → Output as PDF or Print directly 

 

   11. Track Changes और Comments 

• Edit → Track Changes → Record / Show 

• Insert → Comment → Feedback जोड़िा 
• Useful for collaborative editing 



 

   12. वप्रटं और PDF सेि करना 

• Print: File → Print (Ctrl + P) 

• PDF Export: File → Export as PDF → Quality और Password ववकल्प चुिें 

 

   13. LibreOffice Writer शॉटडकट की 

कायड शॉटडकट 

िया डॉक्ट्युमेंट Ctrl + N 

सेव करिा Ctrl + S 

खोलिा Ctrl + O 

वप्रटं करिा Ctrl + P 

बोल्ड Ctrl + ⓑ 

अंडरलाइि Ctrl + U 

फाइंड Ctrl + F 

ज़ूम इि/आउट Ctrl + Mouse Scroll 

 LibreOffice Writer और MS Word में अंतर: 

फीचर LibreOffice Writer MS Word 

Cost फ्री और ओपि-सोसड पेड (Microsoft Office) 

Default Format .odt .docx 

Compatibility Word Compatible ज़्यादा ब्रॉडली सपोटेड 

PDF Export Built-in Available 

 

 नोट: O Level एग्ज़ाम में LibreOffice Writer पर आधाररत प्रैक्क्टकल प्रश्न जैस:े 

• एक Letter तैयार करिा 
• Table बिाकर Data भरिा 
• Resume या Application ललखिा 



• Header/Footer, Page Number डालिा 
पूछे जा सकते हैं। 

Google Docs – Complete Notes  

   1. Google Docs क्या है? 

Google Docs एक ऑनलाइन ििड प्रोसेलसगं एक्प्लकेशन है, जो Google द्वारा प्रदाि ककया गया है। 
यह Microsoft Word या LibreOffice Writer का वेब-बसे्ड ववकल्प है। 

मुख्य विशेषताएाँ: 

• इंटरिेट पर डॉक्ट्युमेंट बिाए ंऔर सेव करें 
• टीम के साथ ररयल-टाइम में काम करें 
• ऑटोमैदटक सेववगं (Auto-save) 

• मोबाइल और लैपटॉप दोिों पर उपलब्ध 

   2. Google Docs कैस ेखोलें? 

     STEPS: 

1. ब्राउज़र में जाएाँ: https://docs.google.com 

2. अपिे Gmail अकाउंट से लॉग इि करें 
3. +Blank या Template चुिें 
4. टाइवपगं शुरू करें – सब कुछ ऑटो सेव होता है 

 

   3. इंटरफेस (Google Docs Interface) 

भाग कायड 
Title Bar डॉक्ट्युमेंट का िाम (Untitled document) 

Menu Bar File, Edit, View, Insert, Format आदद ववकल्प 

Toolbar Font, Size, Bold, Italic, Align आदद आइकि 

Document Area जहााँ आप कंटेंट टाइप करत ेहैं 
Share Button डॉक्ट्युमेंट को दसूरों के साथ शयेर करिा 

 

https://docs.google.com/


   4. िॉक्युमेंट बनाना और सेि करना 

• िया डॉक्ट्युमेंट: +Blank 

• सेव करिा: Auto Save (हर बदलाव अपिे-आप सेव होता है) 

• Rename करिा: Title bar पर जक्ट्लक करें 
• डाउिलोड करिा: 

o File → Download As → 

.docx, .pdf, .odt, .txt, आदद 

 

   5. टेक््ट फॉमदेटगं 

• Font Style, Size 
• Bold (Ctrl+B), Italic (Ctrl+I), Underline (Ctrl+U) 
• Text Color, Highlight 
• Paragraph Alignment: Left, Center, Right, Justify 
• Line Spacing, Bullets/Numbering 

 

   6. पेज सेटअप और लेआउट 

• File → Page Setup: 
o Orientation: Portrait / Landscape 
o Size: A4, Letter 

o Margins सेट करें 
• Header/Footer जोड़िा: 

o Insert → Header / Footer 
• Page Number: 

o Insert → Page Numbers 

   7. टेबल और चचि जोडना 

• Insert → Table → Rows × Columns 
• Insert → Image → Upload, Camera, Google Drive, URL 

• Insert → Drawing → िई आकृनत बिाए ं

• Insert → Chart → Bar, Pie, Line (Google Sheets ललकं कर सकते हैं) 

   8. Voice Typing (आिाज़ से टाइप करें) 

• Tools → Voice Typing 

• माइक ऑि करें और बोलें – टेक्ट्स्ट अपिे-आप टाइप होगा 



• दहदंी में बोलिे के ललए → Language चुिें: Hindi 

   9. Collaboration (एक साथ काम करना) 

• Share बटि → ईमेल डालें या Link Generate करें 
• Access Type चुिें: View / Comment / Edit 

• Real-time में साथ में एडडदटगं और चदैटगं संभव 

 

   10. Spelling, Grammar और Word Count 

• Tools → Spelling and Grammar 

• गलनतयों को सुधारें 
• Tools → Word Count (Ctrl+Shift+C) → शब्दों की गगिती 

 

   11. Comment और Suggestion Mode 

• ककसी लाइि पर जक्ट्लक करें → Add Comment 

• Suggestion Mode: Editor त्रबिा बदलाव ककए सुझाव दे सकता है 

o View → Mode → Suggesting 

 

   12. Templates और Resume Tools 

• Home Page → Template Gallery → Resume, Letter, Report Formats 

• Pre-designed डॉक्ट्युमेंट्स से जल्दी काम करें 

   13. शॉटडकट की (Google Docs Shortcuts) 

कायड शॉटडकट 

िया डॉक्ट्युमेंट docs.new ब्राउज़र में टाइप करें 
सेव Auto Save (कोई की िहीं) 
फाइल डाउिलोड Ctrl + P (PDF) 

बोल्ड Ctrl + B 

अंडरलाइि Ctrl + U 



कायड शॉटडकट 

फाइंड Ctrl + F 

Undo Ctrl + Z 

Redo Ctrl + Y 

   14. Offline Mode (ब्रबना इंटरनेट काम करें) 

      STEPS : 

1. Chrome ब्राउज़र में जाएाँ 
2. Google Docs Offline एक्ट्सटेंशि इंस्टॉल करें 
3. Google Drive Settings → Offline Mode Enable करें 

 

   15. PDF बनाना और वप्रटं करना 

• File → Download → PDF Document (.pdf) 

• या File → Print → Select Printer / Save as PDF 

 

   16. Google Docs vs MS Word vs LibreOffice Writer 

फीचर Google Docs MS Word LibreOffice 

इंटरिेट जरूरी हां (Offline Mode भी संभव) िहीं िहीं 
टीम के साथ काम ररयल टाइम सीलमत िहीं 
ऑटो सेव हां िहीं िहीं 
इंस्टॉलेशि िहीं हां हां 
मोबाइल से एक्ट्सेस हां हां हां 

 

 

 

 

 



 

 

 

 

 

 

 

 

                                                                    Chapter 4 

                                    Spreadsheet (MS Excel / LibreOffice Calc) 

 

4.1 ्प्रेिश़ीट क्या है? 

स्प्रेडशीट एक इलके्ट्रॉनिक वकड बुक होती है जजसमें डेटा रो (Rows) और कॉलम (Columns) में व्यवजस्थत होता है। 
इसका उपयोग संख्यात्मक डेटा के ववश्लेषण, गणिा (Calculation), चाटड और ग्राफ बिािे में ककया जाता है। 

प्रमुख सॉफ्टिेयर: 

• Microsoft Excel 
• LibreOffice Calc 

• Google Sheets (ऑिलाइि) 

 

4.2 िकड बुक और िकड श़ीट का अंतर 

• Workbook: पूरी Excel फाइल जजसमें कई Worksheets होती हैं। 
• Worksheet: एक पजे जजसमें Rows और Columns होत ेहैं (जैस ेSheet1, Sheet2...) 

 

4.3 िेटा दजड करना (Entering Data) 



आप एक सेल (Cell) में टेक्ट्स्ट, संख्याएाँ, तारीख, समय आदद डाल सकते हैं। 

• Text Data: कोई भी अक्षर (जैस ेिाम) 

• Numeric Data: अकं (जैस े100, 75.50) 

• Date/Time: 25/06/2025, 11:30 AM 

 

4.4 सेल और रेंज 

• Cell: Row और Column के इंटरसेक्ट्शि को Cell कहत ेहैं (जैस ेA1, B3) 

• Range: एक से अगधक सेल का समूह (जैस ेA1:B5) 

 

 

 

4.5 सेल एडिदटगं और फॉमेदटगं 

• टेक्ट्स्ट को Bold, Italic, Underline 

• Text Alignment: Left, Center, Right 

• Cell Color, Border लगािा 
• Font Size और Font Style बदलिा 
• Number Formatting: Currency, Percentage, Date 

 

4.6 फॉमूडला और फंक्शन 

(i) Formula: 

स्वतः कैलकुलेशि के ललए उपयोग ककया जाता है। सभी फामूडला = से शुरू होत ेहैं। 
उदाहरण: 

=A1+B1 → A1 और B1 का योग 

(ii) Functions: 

Excel में पहल ेसे बिे कैलकुलेशि फंक्ट्शंस होत ेहैं। 



Function कायड 
=SUM(A1:A5) योग 

=AVERAGE(A1:A5) औसत 

=MAX(A1:A5) सबसे बड़ी संख्या 
=MIN(A1:A5) सबसे छोटी संख्या 
=IF(A1>50,"Pass","Fail") शतड आधाररत ररजल्ट 

4.7 सेल रेफरेंलसगं 

• Relative Reference (A1): कॉपी करिे पर एडे्रस बदलता है 

• Absolute Reference ($A$1): कॉपी करिे पर एडे्रस कफक्ट्स रहता है 

• Mixed Reference (A$1 या $A1): आधा कफक्ट्स 

 

4.8 चाटड और ग्राफ बनाना 

Steps: 

1. डेटा सेलेक्ट्ट करें 
2. Insert → Chart → Chart Type चुिें (Column, Pie, Line) 

3. Chart Title, Axis Titles आदद जोड़ें 

 

4.9 िेटा सॉदटिंग और क्रफल्टररगं 

• Sorting: डेटा को Ascending या Descending रम में व्यवजस्थत करिा 
• Filtering: ककसी खास डेटा को छाटंिा 

उदाहरण: सभी “Pass” वाले छाि ही ददखािा 

 

4.10 वप्रदंटगं ्प्रेिश़ीट 

• Page Setup: Margins, Orientation 

• Print Area Set करिा 



• File → Print → Preview और Print 

 

4.11 Excel के उपयोग: 

• ररपोटड बिािा 
• ररजल्ट शीट तैयार करिा 
• बजट प्लाि करिा 
• माकड शीट जिरेट करिा 
• डेटा एिालललसस करिा 

4.12 Excel शॉटडकट की 

कायड शॉटडकट की 
िई शीट Shift + F11 

सेव करिा Ctrl + S 

फॉमूडला देखिा Ctrl + ` 

ऑटोसम Alt + = 

कट Ctrl + X 

कॉपी Ctrl + C 

पेस्ट Ctrl + V 

Undo Ctrl + Z 

Redo Ctrl + Y 

 

Microsoft Excel – Complete Notes  

   1. Microsoft Excel क्या है? 

• Excel एक इलेक्ट्रॉनिक स्प्रेडशीट सॉफ्टवेयर है 

• इसमें िेटा को रो और कॉलम में व्यिक््थत कर गणिा (Calculation), एिालललसस (Analysis), चाटड 
आदद बिाए जात ेहैं 

• Excel माइरोसॉफ्ट ऑकफस पैकेज का दहस्सा है 

 



   2. Excel Interface (मुख्य भाग) 

भाग कायड 
Workbook पूरी Excel फाइल (जैस े.xlsx) 

Worksheet एक-एक शीट, जैस ेSheet1, Sheet2 

Rows क्षैनतज लाइिें (1, 2, 3…) 

Columns ऊध्वाडधर लाइिें (A, B, C…) 

Cell Row + Column (जैस ेA1, B2) 

Formula Bar फॉमूडला और डेटा ददखाता है 

Name Box करसर ककस Cell में है – बताता है 

 

   3. िेटा दजड करना (Data Entry) 

आप Cell में Text, Numbers, Date, Time, या Formulas डाल सकते हैं। 

उदाहरण: 

• Text: िाम, पता 
• Numbers: 100, 5000 
• Date/Time: 25/06/2025, 10:30 AM 

   4. Formatting Options 

• Font Style, Size, Color 
• Bold (Ctrl + B), Italic, Underline 

• Cell Color और Border 

• Alignment: Left, Center, Right 
• Merge Cells, Wrap Text 
• Number Formatting: Currency, Percentage, Decimal, Date Format 

 

   5. Formulas and Functions 

(i) Formula Basics: 

• Always starts with = 
• Example: =A1 + B1 

 



 

(ii) Basic Functions: 

Function उपयोग 

=SUM(A1:A5) योग 

=AVERAGE(A1:A5) औसत 

=MAX(A1:A5) सबसे बड़ी संख्या 
=MIN(A1:A5) सबसे छोटी संख्या 
=IF(A1>50, "Pass", "Fail") शतड आधाररत 

=COUNT(A1:A5) िॉि-ब्लैंक सेल्स की गगिती 
 

   6. Cell Referencing 

प्रकार उदाहरण वििरण 

Relative A1 कॉपी करिे पर बदलता है 

Absolute $A$1 कफक्ट्स रहता है 

Mixed A$1 या $A1 आंलशक रूप से कफक्ट्स 

 

   7. Data Sorting और Filtering 

• Sorting: डेटा को A-Z या Z-A में रमबद्ध करिा 
• Filtering: कुछ खास ररकॉडड ददखािा (जैस ेलसफड  "Pass" वाले) 

Steps: 

1. Data → Sort or Filter 

2. Criteria चुिें 

 

   8. Charts और Graphs 

Types: 

• Column Chart 
• Line Chart 



• Pie Chart 
• Bar Chart 

Steps: 

1. डेटा सेलेक्ट्ट करें 
2. Insert → Chart 

3. Chart Type, Title, Axis Labels सेट करें 

   9. Conditional Formatting 

• ककसी शतड के आधार पर सेल को रंग दें 
• उदाहरण: माक्ट्सड < 35 हो तो Red 

Steps: 

1. Select Cells 
2. Home → Conditional Formatting 

3. Rule चुिें 

   10. Table और Data Validation 

• Insert → Table: डेटा को प्रोफेशिल लुक 

• Data Validation: Drop-down List बिािा 
o Data → Data Validation → List 

   11. Sheet Manageme 

nt 

कायड ्टेप्स 

New Sheet Shift + F11 

Rename Right Click → Rename 

Delete Right Click → Delete 

Move/Copy Right Click → Move or Copy 

 

   12. Excel में वप्रदंटगं 

• Page Layout → Margins, Orientation (Portrait/Landscape) 
• Set Print Area 
• File → Print → Preview 



 

   13. Excel Shortcuts (महत्िपूणड शॉटडकट्स) 

कायड शॉटडकट 

िई शीट Shift + F11 

सेव Ctrl + S 

कट Ctrl + X 

कॉपी Ctrl + C 

पेस्ट Ctrl + V 

Undo Ctrl + Z 

Redo Ctrl + Y 

ऑटो सम Alt + = 

फॉमूडला ददखािा Ctrl + ` 

सेल एडडट करिा F2 

 

   14. Practical Examples (O Level में आने योग्य) 

• माकड शीट बिािा 
• बजट प्लानिगं 

• Salary Sheet 
• Attendance Sheet 

• Invoice या Bill Sheet 

   15. Excel फाइल फॉमेट 

फॉमेट अथड 
.xlsx Default Excel फाइल 

.xls Excel 97-2003 फाइल 

.csv Comma Separated Values (टेक्ट्स्ट डेटा) 

.pdf Exported File 

 

O Level Exam में आने िाले प्रश्नों के उदाहरण: 



• SUM, AVERAGE का उपयोग करके शीट तैयार करें 
• ग्राफ या चाटड बिाइए 

• Conditional Formatting का उपयोग करें 
• Drop-down List बिाए ं

• माकड शीट में टोटल और ररजल्ट निकाललए 

 

LibreOffice Calc – Complete Notes  

LibreOffice Calc एक फ्री और ओपन-सोसड ्प्रेिश़ीट सॉफ्टिेयर है, जो Microsoft Excel जैसा ही कायड करता 
है। 

 

   1. LibreOffice Calc क्या है? 

• Calc एक Spreadsheet Tool है 

• यह LibreOffice Suite का दहस्सा है 

• इसमें आप डेटा मैिेज, कैलकुलेट, एिालाइज और ग्राफ बिा सकते हैं 

 

   2. Calc का इंटरफेस (Main Parts of Interface) 

भाग वििरण 

Title Bar डॉक्ट्युमेंट का िाम 

Menu Bar File, Edit, View, Insert आदद 

Standard Toolbar Save, Print, Undo आदद शॉटडकट 

Formatting Toolbar Font, Bold, Alignment आदद 

Formula Bar फॉमूडला टाइप करिे के ललए 

Name Box करसर ककस सेल पर है (जैस ेA1) 

Worksheet Area सेल्स का गग्रड जहााँ डेटा होता है 

 

   3. Cell, Row, Column क्या है? 



• Cell = एक बॉक्ट्स (जैस ेA1) 

• Row = क्षैनतज लाइि (1, 2, 3...) 

• Column = ऊध्वाडधर लाइि (A, B, C...) 

 

   4. िेटा िालना और सेि करना 

• Text, Numbers, Dates डाल सकते हैं 
• Save करिे के ललए: Ctrl + S 

• Format: .ods (LibreOffice default), .xls, .xlsx, .csv 

   5. Formatting Tools 

• Font Style, Size 
• Bold, Italic, Underline 
• Cell Borders, Cell Background 
• Merge Cells, Text Alignment 
• Number Format: Currency, %, Decimal, Date 

   6. Formula और Functions 

 Basic Formula: 

=A1 + B1 
=A1 * 10 

  

 

 

Common Functions: 

Function कायड 
=SUM(A1:A5) योग 

=AVERAGE(A1:A5) औसत 

=MAX(A1:A5) अगधकतम 

=MIN(A1:A5) न्यूितम 

=COUNT(A1:A5) गगिती 



Function कायड 
=IF(A1>35;"Pass";"Fail") शतड 

   7. Cell Referencing 

प्रकार उदाहरण वििरण 

Relative A1 कॉपी करिे पर बदलता है 

Absolute $A$1 हमेशा कफक्ट्स रहता है 

Mixed A$1 या $A1 आंलशक कफजक्ट्संग 

 

   8. Sorting और Filtering 

• Sort (Ascending/Descending): Data → Sort 

• AutoFilter: Data → AutoFilter → Filter List बिाए ं

 

   9. Charts बनाना 

्टेप्स वििरण 

Step 1 डेटा सेलेक्ट्ट करें 
Step 2 Insert → Chart 

Step 3 Chart Type चुिें (Bar, Line, Pie आदद) 

Step 4 Chart Title, Axis Labels दें 
 

   10. Conditional Formatting 

• Format → Conditional → Condition 

• उदाहरण: Cell value < 35 → Red Background 

 

 

 

   11. Sheet Management 



कायड ्टेप 

िई शीट Shift + F11 

िाम बदलिा Double Click on Sheet Tab 

शीट डडलीट Right Click → Delete Sheet 

Move/Copy Right Click → Move/Copy Sheet 

 

   12. Print और Export 

• Print: File → Print 
• Page Layout: Format → Page → Margins, Orientation 
• Export as PDF: File → Export as PDF 

   13. शॉटडकट की (LibreOffice Calc) 

कायड शॉटडकट 

िई फाइल Ctrl + N 

सेव Ctrl + S 

फॉमूडला ददखािा Ctrl + ` (backtick) 

कट / कॉपी / पसे्ट Ctrl + X / C / V 

Undo / Redo Ctrl + Z / Y 

ऑटो सम Alt + = 

Insert Row Ctrl + "+" 

Delete Row Ctrl + "-" 

 

   14. Practical Uses (O Level Exam में पूछे जा सकते हैं) 

• माकड शीट बिािा 
• Salary Sheet 
• Attendance Record 
• Budget Sheet 
• Invoice Sheet 
• Result with IF Function 

 

   15. Calc vs Excel तुलना (Comparison) 



फीचर LibreOffice Calc MS Excel 

Price Free/Open Source Paid 

Format .ods .xlsx 

Interface Basic Advanced 

Compatibility Good (With Excel) Best 

 

O Level Practical Tips: 

• शीट पर Table तैयार करिा 
• Function जैस ेSUM, IF, COUNT उपयोग करिा 
• Chart बिािा 
• Conditional Formatting लगािा 
• PDF Export करिा 

 

 

Google Sheets – Complete Notes  

Google Sheets एक ऑनलाइन फ्री ्प्रेिश़ीट एक्प्लकेशन है, जो Google द्वारा Gmail यूज़सड के ललए उपलब्ध 

कराया गया है। यह Microsoft Excel और LibreOffice Calc का वेब-बेस्ड ववकल्प है। 

 

   1. Google Sheets क्या है? 

• Google Sheets एक क्ट्लाउड-आधाररत स्प्रेडशीट टूल है 

• आप इसमें डेटा स्टोर, कैलकुलेट, एिालललसस और ग्राफ बिा सकते हैं 
•  

• यह ररयल-टाइम में कई लोगों के साथ साझा कर काम करिे की सुववधा देता है 

 

   2. Google Sheets कैसे खोलें? 

      STEPS : 

1. ब्राउज़र में टाइप करें: https://sheets.google.com 

2. Gmail से लॉगगि करें 

https://sheets.google.com/


3. +Blank spreadsheet पर जक्ट्लक करें 
4. िाम दें और कायड शुरू करें – सब कुछ ऑटो सेि होता है 

 

 

 

 

   3. Google Sheets Interface (मुख्य भाग) 

भाग कायड 
Title Bar फाइल का िाम 

Menu Bar File, Edit, View, Insert आदद ववकल्प 

Toolbar Formatting Tools, Font, Size, Align आदद 

Formula Bar फॉमूडला और डेटा दजड करिे का स्थाि 

Grid Area सेल्स (A1, B2, आदद) जहााँ डेटा होता है 

Share Button दसूरों के साथ साझा करें 
 

 

   4. बेलसक ऑपरेशन 

• डेटा डालिा (Text, Numbers, Dates) 

• सेल लसलके्ट्शि, Row/Column जोड़िा 
• Undo (Ctrl + Z), Redo (Ctrl + Y) 

• Auto Save – इंटरिेट पर तुरंत सेव 

   5. Formatting Options 

• Bold, Italic, Underline 
• Cell Color, Font Color 
• Merge Cells, Wrap Text 
• Text Alignment: Left, Center, Right 
• Number Format: Currency, %, Date 

 



   6. Formula और Functions 

 Formula शुरू होता है: = 

 Important Functions: 

Function कायड 
=SUM(A1:A5) योग 

=AVERAGE(A1:A5) औसत 

=MAX(A1:A5) अगधकतम 

=MIN(A1:A5) न्यूितम 

=COUNT(A1:A5) गगिती 
=IF(A1>35, "Pass", "Fail") शतड 

 

   7. Charts और Graphs बनाना 

Steps: 

1. डेटा सेलेक्ट्ट करें 
2. Insert → Chart 

3. Chart Type चुिें (Bar, Pie, Line आदद) 

4. Chart Title और Formatting सेट करें 

 

   8. Sorting और Filtering 

• Sort: Data → Sort range 

• Filter: Data → Create a filter → Dropdown से कफल्टर करें 
• जल्दी से ररकॉडड खोजिे के ललए उपयोगी 

 

   9. Data Validation (Drop-down List) 

1. Data → Data Validation 
2. Criteria: List of items 

3. Drop-down बिाएाँ – जैस े"Pass, Fail" 



 

   10. Conditional Formatting 

1. Format → Conditional Formatting 

2. Rule Set करें: जैस ेCell < 35 → Background Red 

3. Apply करें 

 

   11. Sharing और Collaboration 

• Share → ईमेल से ललकं भेजें 
• Viewer / Commenter / Editor roles चुिें 
• Multiple लोग एक साथ Edit कर सकत ेहैं 
• Suggestion Mode भी उपलब्ध 

 

   12. Import, Export और Download 

• Import Excel File: File → Import 
• Export as: File → Download → 

.xlsx, .ods, .pdf, .csv 
• Print: File → Print (Ctrl + P) 

   13. Google Sheets शॉटडकट्स 

कायड शॉटडकट 

िया शीट sheets.new (Browser में) 
सेव Auto Save 

Bold Ctrl + ⓑ 

Merge Cells Alt + Shift + M 

Insert Row Alt + I → R 

Delete Row Alt + E → D 

Comment Ctrl + Alt + M 

Formula View Ctrl + ` (Backtick) 

 

 



Practice Sheet 1: Marksheet (Student Report Card) 

Roll No Student Name Hindi English Math Total Percentage Result 

101 Ravi Kumar 78 67 89    

102 Sita Verma 88 72 90    

103 Aman Singh 34 40 29    

Formulas: 

• Total: =C2+D2+E2 
• Percentage: =F2/3 
• Result (Pass/Fail): 

=IF(AND(C2>=35, D2>=35, E2>=35), "Pass", "Fail") 

 Conditional Formatting: 

Fail होिे पर पूरी पजंक्ट्त को लाल रंग करें। 

 

 Practice Sheet 2: Salary Sheet 

Emp ID Name Basic Salary HRA (20%) DA (10%) Gross Salary PF (12%) Net Salary 

E101 Anil Kumar 15000      

E102 Reena Gupta 20000      

 Formulas: 

• HRA: =C2*20% 
• DA: =C2*10% 
• Gross Salary: =C2+D2+E2 
• PF: =C2*12% 
• Net Salary: =F2-G2 

 Format Net Salary in ₹ currency style. 

 

 Practice Sheet 3: Result Sheet with Grade 

Roll No Name Science Maths English Total % Grade 

201 Ramesh Yadav 65 80 55    

202 Komal Singh 45 67 89    

 Formulas: 

• Total: =C2+D2+E2 



• % (Percentage): =F2/3 
• Grade: 

excel 
CopyEdit 
=IF(G2>=80, "A", IF(G2>=60, "B", IF(G2>=45, "C", "Fail"))) 

 Use color codes for each grade (A = Green, B = Yellow, Fail = Red). 

 

 कैस ेइ्तेमाल करें? 

✔ इि टेबल्स को Google Sheets / Excel / Calc में कॉपी करें 
✔ ऊपर ददए गए Formulas को अपिे अिुसार एडजस्ट करें 
✔ Conditional Formatting लगाकर Sheet को और बेहतर बिाए ं

✔ PDF या Print निकालिे का अभ्यास करें 

 

   14. Offline Access (ब्रबना इंटरनेट के उपयोग) 

1. Chrome में जाएाँ 
2. Google Docs Offline एक्ट्सटेंशि इंस्टॉल करें 
3. Google Drive → Settings → Offline Mode Enable करें 

 

   15. Google Sheets बनाम Excel बनाम LibreOffice 

फीचर Google Sheets MS Excel LibreOffice Calc 

इंटरिेट जरूरी हााँ िहीं िहीं 
Auto Save हााँ िहीं िहीं 
Collaboration ररयल टाइम सीलमत िहीं 
PDF Export हााँ हााँ हााँ 
प्राइस फ्री पेड फ्री 

 

   16. O Level Practical में आने िाले कायड: 



• माकड शीट बिािा 
• IF Function लगािा 
• Drop-down List 

• Chart बिािा 
• Result Sheet 
• Budget Sheet 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Chapter 5 

Presentation Software (प्रेजेंटेशन सॉफ्टिेयर) 

5.1 प्रेजेंटेशन सॉफ्टिेयर क्या है? 

प्रेजेंटेशि सॉफ्टवेयर का उपयोग विजअुल ्लाइड्स के रूप में जािकारी प्रस्तुत करिे के ललए ककया जाता है। 
इसका उपयोग मीदटगं, क्ट्लासरूम, सलेमिार, और रेनिगं में होता है। 

प्रमुख सॉफ्टिेयर: 



• Microsoft PowerPoint 
•  
• LibreOffice Impress 

• Google Slides (ऑिलाइि) 

 

5.2 ्लाइि क्या है? 

• स्लाइड एक स्रीि पेज है जहााँ टेक्ट्स्ट, इमेज, चाटड, वीडडयो आदद डाल ेजात ेहैं। 
• एक प्रेजेंटेशि में कई स्लाइड्स हो सकती हैं। 

 

5.3 नई प्रजेेंटेशन बनाना 

    STEPS : 

1. Open PowerPoint → File → New 

2. Template चुिें या Blank Presentation 

3. स्लाइड्स बिािा शुरू करें 

 

5.4 ्लाइि में टेक््ट जोडना 

• Placeholder बॉक्ट्स में जक्ट्लक करें और टेक्ट्स्ट टाइप करें 
• Text Formatting: Bold, Italic, Font Size, Font Color, Alignment 

 

5.5 ्लाइि डिज़ाइन और लआेउट 

• Design → Themes: आकषडक डडज़ाइि टेम्पलटे्स चुिें 
• Layout: टाइटल स्लाइड, कंटेंट स्लाइड, दो कॉलम आदद 

• Slide Size, Background Change करिा 

5.6 ्लाइि में इमेज, ि़ीडियो, ऑडियो जोडना 

• Insert → Picture: लोकल इमेज जोड़ें 
• Insert → Video: वीडडयो जक्ट्लप जोड़ें 



• Insert → Audio: म्यूजजक या वॉयस जक्ट्लप जोड़ें 

 

5.7 ्माटडआटड और चाटड जोडना 

• SmartArt: Steps, Process, Hierarchy जैस ेववज़ुअल एललमेंट 

• Chart: Column, Pie, Line Charts 

• डेटा से Auto Generate होता है 

 

5.8 रांक्जशन और एननमेशन 

(i) Slide Transitions: 

• एक स्लाइड से दसूरी में जािे के दौराि प्रभाव (Effect) 

• Tab: Transitions → Choose Effect (Fade, Wipe, Push) 

• Duration और Sound सेट करिा 

(ii) Animations: 

• Text या Object में मूवमेंट देिा 
• Tab: Animations → Select Animation (Fly In, Zoom, etc.) 

• Animation Pane से Sequence बदल सकते हैं 

 

5.9 ्लाइि शो (Slide Show) 

• Start Slide Show → From Beginning या From Current Slide 

• स्लाइड ऑटोमैदटक चलािे के ललए Timing सेट करें 

शॉटडकट: 

• Start Slide Show: F5 
• Next Slide: → (Arrow Key) 
• End Show: Esc 

 

 



 

5.10 प्रेजेंटेशन को सेि और वप्रटं करना 

• File → Save As: फाइल को .pptx या .pdf में सेव करें 
• File → Print: स्लाइड्स का वप्रटं लेिा 

o Print All Slides / Selected Slides 
o 1 Slide per Page / Handouts (3 slides per page with notes) 

 

5.11 नोट्स पैन और कमेंट्स 

• Notes Pane: स्लाइड के िीचे प्रेजेंटर िोट्स जोड़ सकते हैं 
• Comments: टीम में काम करत ेसमय ररव्यू के ललए 

 

5.12 प्रभाि़ी प्रेजेंटेशन के ललए दटप्स 

• Slide पर ज्यादा टेक्ट्स्ट ि रखें 
• फॉन्ट बड़ा और साफ हो 
• अगधकतर Visual Content (Image, Graphs) का उपयोग करें 
• एकसमाि Theme और Design रखें 
• हर स्लाइड पर फोकस एक ही ववषय पर हो 

 

5.13 शॉटडकट की (PowerPoint Shortcuts) 

कायड शॉटडकट 

िई स्लाइड Ctrl + M 

सेव करिा Ctrl + S 

स्लाइड शो शुरू F5 

अगली स्लाइड → 

वपछली स्लाइड ← 

टेक्ट्स्ट बोल्ड Ctrl + B 

स्लाइड हटािा Delete 



 

   उपयोग के ििे: 

• ऑकफस प्रेजेंटेशि 

• स्कूल/कॉलेज प्रोजेक्ट्ट 

• सेलमिार और वते्रबिार 
• ट्यूटररयल और रेनिगं सेशि 

 

LibreOffice Impress – Complete Notes  

   1. LibreOffice Impress क्या है? 

• Impress एक Presentation Software है 

• यह Microsoft PowerPoint का फ्री और ओपि-सोसड ववकल्प है 

• इसका उपयोग ्लाइि शो, प्रजे़ेंटेशन, और ऑडियो-विज़ुअल कंटेंट बिािे के ललए ककया जाता है 

 

   2. LibreOffice Impress का Interface (मुख्य भाग) 

भाग कायड 
Title Bar फाइल का िाम ददखाता है 

Menu Bar File, Edit, View, Slide आदद ववकल्प 

Standard Toolbar Save, Open, Print, Undo, आदद 

Formatting Toolbar Font, Size, Bold, Color आदद 

Workspace जहााँ स्लाइड्स डडज़ाइि होती हैं 
Sidebar Layout, Animation, Slide Properties 

Slide Pane बाईं तरफ सभी स्लाइड्स की ललस्ट 

Notes Area िोट्स ललखि ेके ललए, जो प्रजे़ेंटेशि में िहीं ददखत े

 

   3. नई प्रेज़ेंटेशन बनाना 

1. Open LibreOffice Impress 

2. Presentation Wizard खुलेगा (Blank, Template चुिें) 



3. Layout चुिें 
4. स्लाइड्स बिािा शुरू करें 

 

   4. ्लाइि बनाना और लआेउट चुनना 

• Insert → Slide या Ctrl + M 

• Right-click on Slide Pane → New Slide 

• Slide Layout: Title Slide, Content Slide, Two Column Slide आदद 

 

   5. टेक््ट जोडना और फॉमेट करना 

• जक्ट्लक करें: “Click to add title” या “Click to add text” 

• Text Formatting Options: 
o Font Style & Size 
o Bold, Italic, Underline 
o Text Color 
o Bullet / Number List 
o Text Alignment: Left, Center, Right 

 

   6. Image, Audio, Video जोडना 

• Insert → Image → File से चुिें 
• Insert → Audio या Video 

• Drawing Tools से Shapes, Lines, Arrows डाल सकते हैं 

 

   7. Table और Chart जोडना 

• Insert → Table → Row/Column चुिें 
• Insert → Chart → Chart Type (Pie, Bar, Line) 

• Chart का डेटा एडडट करिे के ललए: Right-click → Data Table 

 

   8. Animation और Transition 



टूल उपयोग 

Custom Animation Text/Image को स्लाइड में मूव या Fade करें 
Slide Transition एक स्लाइड से दसूरी पर जात ेसमय Animation 

Steps: 

• View → Animation 

• Slide पर जक्ट्लक करें → Effect चुिें 
• Start: On Click / With Previous / After Previous 
• Speed: Slow, Medium, Fast 

 

   9. Master Slide (सभ़ी ्लाइड्स पर एक जैसा Layout) 

• View → Master Slide 

• Company Logo, Footer, Date, Slide Number एक बार में सभी स्लाइड्स पर जोड़ सकते हैं 
• कफर View → Normal पर लौटें 

   10. Notes और Handouts 

• Notes: Presenter Notes ललखें जो दशडकों को िही ंददखेंगे 
• Handouts: वप्रटं के ललए 

• View → Notes या Handout View 

   11. Slide Show शुरू करना 

• Slide Show → Start from First Slide (F5) 
• Slide Show → Start from Current Slide (Shift + F5) 
• Keyboard Navigation: Arrow Keys, Page Up/Down 

 

   12. Export और Save Options 

• Save As: .odp (default), .ppt, .pdf 
• Export as PDF: File → Export As → Export as PDF 

• Export as Images: File → Export → JPEG, PNG आदद 

   13. शॉटडकट की (LibreOffice Impress) 



कायड शॉटडकट 

िई स्लाइड Ctrl + M 

सेव करिा Ctrl + S 

स्लाइड शो शुरू F5 

वप्रव्यू स्लाइड शो Shift + F5 

Undo Ctrl + Z 

Bold Ctrl + B 

Text Box Insert F2 

 

   14. O Level Practical Sheet  (प्रैक्क्टस के ललए) 

Topic: "Digital India Mission Presentation" 

• Slide 1: Title Slide 
• Slide 2: Introduction Text + Image 
• Slide 3: Objectives (Bullet Points) 
• Slide 4: Chart/Data 
• Slide 5: Thank You Slide 

• Animation और Transition जोड़ें 
• Footer में िाम और तारीख जोड़ें 
• PDF में Export करें 

   15. LibreOffice Impress / PowerPoint 

फीचर Impress PowerPoint 

Price Free / Open Source Paid 

Format .odp .ppt / .pptx 

Templates कम ज़्यादा 
Features Basic से Mid Advanced 

Google Slides – Complete Notes  

   1. Google Slides क्या है? 

• Google Slides एक ऑनलाइन प्रेज़ेंटेशन सॉफ्टिेयर है, जो PowerPoint या LibreOffice Impress 

जैसा ही है 

• यह Google Workspace का दहस्सा है 

• आप इसमें स्लाइड्स बिाकर उन्हें शेयर, एडडट, और प्रेज़ेंट कर सकते हैं – वो भी ररयल-टाइम में 



 

   2. Google Slides कैसे खोलें? 

Steps: 

1. ब्राउज़र में जाएाँ: https://slides.google.com 

2. Gmail अकाउंट से लॉगगि करें 
3. +Blank पर जक्ट्लक करें या टेम्प्लेट चुिें 
4. स्लाइड बिािा शुरू करें – सब कुछ Auto Save होता है 

 

   3. इंटरफेस (Main Parts of Google Slides) 

भाग कायड 
Title Bar स्लाइड का िाम 

Menu Bar File, Edit, View, Insert आदद ववकल्प 

Toolbar Font, Size, Bold, Text Color, आदद 

Slide Pane बाईं ओर सभी स्लाइड्स की सूची 
Main Slide Area स्लाइड डडज़ाइि करिे की जगह 

Speaker Notes िीचे िोट्स ललखि ेकी जगह 

Share Button दसूरों के साथ शेयर करिे का ववकल्प 

 

   4. नई ्लाइि बनाना और लेआउट चुनना 

• New Slide: Click + या Ctrl + M 

• Right-click on slide panel → New Slide 

• Slide Layout: Title Slide, Section Header, Two Column आदद 

• Layout बदलिे के ललए: Slide → Apply Layout 

 

   5. टेक््ट जोडना और फॉमेट करना 

• Click → “Click to add title/text” 
• Font Type, Size 
• Bold, Italic, Underline 

https://slides.google.com/


• Text Color, Highlight 
• Bulleted/Numbered List 
• Text Alignment: Left, Center, Right 

   6. Image, Audio और Video Insert करना 

• Insert → Image → Upload from computer / Drive / Web 

• Insert → Video → YouTube या Google Drive से 

• Insert → Audio → Drive से MP3 जोड़ें 
• Insert → Shape, Line, Arrow, Callouts 

 

   7. Table और Chart जोडना 

• Insert → Table → Rows × Columns 
• Insert → Chart → Bar, Column, Pie, Line 

• Chart को Google Sheets से ललकं ककया जा सकता है 

 

   8. Slide Transition और Object Animation 

Slide Transition (्लाइि बदल ेपर इफेक्ट): 

• Slide → Transition → Choose Effect 

Object Animation (Text या Object पर इफेक्ट): 

• Select Text/Image 
• Right Click → Animate 
• Choose: Fade In, Fly In, etc. 
• Set: On Click / With Previous / After Previous 

 

   9. Theme और Background बदलना 

• Theme: Right Side → Choose a Theme 
• Background: Right-click on Slide → Change Background → Color / Image 

 

   10. Master Slide / Layout Editing 



• View → Master 

• यहां से सभी स्लाइड्स के ललए एक जैसा टेम्प्लटे, Logo, Footer आदद सेट करें 
• कफर View → Normal पर वापस आएाँ 

   11. Notes और Presenter View 

• िीचे “Click to add speaker notes” 

• लसफड  Presenter को ददखता है, दशडकों को िही ं
• View → Speaker Notes 

 

   12. Slide Show Start करना 

• Click: Present → From Beginning या From Current Slide 

• Fullscreen Mode 

• Arrow Keys से Control करें 
• Esc से Exit करें 

 

   13. Download / Export / Print 

• File → Download As: 
o Microsoft PowerPoint (.pptx) 
o PDF Document (.pdf) 
o Image (.jpeg / .png per slide) 

• File → Print (with Notes या त्रबिा Notes) 

 

   14. Sharing & Real-time Collaboration 

• Share Button → Invite by Email / Create Link 
• Set Roles: Viewer, Commenter, Editor 

• Real-time में एक से अगधक लोग साथ काम कर सकते हैं 
• Comment और Suggestion भी जोडे़ जा सकते हैं 

 

   15. Offline Mode (ब्रबना इंटरनेट के उपयोग) 



• Google Docs Offline Extension इंस्टॉल करें 
• Drive Settings → Enable Offline Access 

• अब आप त्रबिा इंटरिेट Slides खोल और एडडट कर सकत ेहैं 

 

 

 

 

   16. शॉटडकट की (Google Slides Shortcuts) 

कायड शॉटडकट 

िई स्लाइड Ctrl + M 

सेव करिा Auto Save 

स्लाइड शो Ctrl + F5 

डुजप्लकेट स्लाइड Ctrl + D 

Undo Ctrl + Z 

Bold Ctrl + B 

Center Align Ctrl + Shift + E 

Add Comment Ctrl + Alt + M 

   17. O Level Practice Topic (्लाइि प्रोजके्ट ) 

Title: "Clean India Mission" 
Slides: 

1. Title Slide – Topic + Image 
2. Objectives – Bullet Points 
3. Progress – Chart 
4. Images – Before & After 
5. Thank You 

Include: 

• Animation 
• Slide Transition 
• Speaker Notes 
• Export as PDF or PPT 

   18. Google Slides बनाम PowerPoint / Impress 



फीचर Google Slides PowerPoint Impress 

Internet जरूरी हााँ (Offline भी संभव) िहीं िहीं 
Auto Save हााँ िहीं िहीं 
Sharing ररयल टाइम सीलमत िहीं 
टेम्प्लेट्स सीलमत बहुत ज़्यादा सीलमत 

प्राइस फ्री पेड फ्री 

 ननष्कषड: 

Google Slides एक फ्री, सुरक्षित और कोलैबोरेदटि टूल है जो छािों और प्रेज़ेंटरों के ललए बेहद उपयोगी है — 

खासकर O Level के प्रैजक्ट्टकल में। 

 

Chapter 6 

Introduction to Internet and WWW (इंटरनेट और िल्िड िाइि िेब का पररचय) 

6.1 इंटरनेट क्या है? (What is Internet?) 

इंटरिेट एक वैजश्वक िेटवकड  है जो लाखों कंप्यूटर और डडवाइसेस को आपस में जोड़ता है। यह जािकारी साझा 
करिे, सचंार, ईमेल, फाइल रांसफर, वेबसाइट ब्राउजज़ंग आदद के ललए प्रयोग होता है। 

मुख्य उपयोग: 

• सूचिा प्राप्त करिा 
• ईमेल भेजिा 
• सोशल मीडडया उपयोग 

• ऑिलाइि पढाई और शॉवपगं 

 

6.2 िल्िड िाइि िेब (WWW) क्या है? 

• WWW इंटरिेट पर आधाररत एक सेवा है जजसमें HTML पजे और वेबसाइटें होती हैं। 
• यह हाइपरटेक््ट और हाइपरललकं का उपयोग करके काम करता है। 
• वेबसाइटें Web Browser द्वारा एक्ट्सेस की जाती हैं। 



उदाहरण: 

www.google.com, www.wikipedia.org 

 

6.3 िेब िाउज़र क्या है? 

वेब ब्राउज़र एक सॉफ्टवेयर होता है जो वेबसाइट को देखिे और इंटरैक्ट्ट करिे के ललए उपयोग होता है। 

प्रमुख िाउज़र: 

• Google Chrome 
• Mozilla Firefox 
• Microsoft Edge 
• Safari 
• Opera 

6.4 URL (Uniform Resource Locator) 

URL वह एडे्रस होता है जजससे ककसी वेबसाइट या वेबपजे तक पहुाँचा जाता है। 

उदाहरण: 

https://www.google.com 

URL के भाग: 

• https:// – प्रोटोकॉल 

• www.google.com – डोमेि िाम 

• /search – पथ या रूट 

6.5 सचड इंजन क्या है? 

सचड इंजि इंटरिेट पर जािकारी खोजिे का टूल होता है। यह वेबपेज, इमेज, वीडडयो आदद को खोजिे में मदद 

करता है। 

प्रमुख सचड इंजन: 

• Google 
• Bing 
• Yahoo 
• DuckDuckGo 

http://www.google.com/
http://www.wikipedia.org/


6.6 ईमेल (Email - Electronic Mail) 

ईमेल एक डडजजटल संदेश सेवा है जजसस ेटेक्ट्स्ट, इमेज, डॉक्ट्युमेंट आदद भेज ेजा सकते हैं। 

ईमेल बनाने की प्रक्ररया: 

• Gmail, Yahoo या Outlook पर अकाउंट बिाए ं

• Compose → Recipient (To), Subject, Message 

• Attachments जोड़ें 
• Send पर जक्ट्लक करें 

ईमेल टम्पसड: 

• Inbox: प्राप्त ईमेल 

• Sent: भेज ेगए ईमेल 

• Draft: सेव ककया गया ईमेल 

• CC/BCC: दसूरों को कॉपी में भेजिा 

6.7 सोशल म़ीडिया और ब्लॉचगगं 

(i) सोशल म़ीडिया प्लेटफॉम्पसड: 

• Facebook 
• Instagram 
• WhatsApp 
• Twitter (X) 
• LinkedIn 

उपयोग: चैदटगं, शेयररगं, माकेदटगं 

 

(ii) ब्लॉग: 

ब्लॉग एक प्रकार की वेबसाइट है जहााँ लेखक (Blogger) ववचार और जािकारी पोस्ट करता है। 
प्लेटफॉमड: Blogger, WordPress 

 

6.8 िाउनलोि और अपलोि 



• Download: इंटरिेट से अपिे डडवाइस में डेटा लािा 
• Upload: अपिे डडवाइस से इंटरिेट पर डेटा भजेिा 

उदाहरण: 

फोटो अपलोड करिा, डॉक्ट्युमेंट डाउिलोड करिा 

6.9 साइबर सुरिा का पररचय 

साइबर लसक्योररटी: इंटरिेट पर आपकी जािकारी और डडवाइस को सुरक्षक्षत रखि ेकी प्रकरया 

जरूरी बातें: 

• मजबूत पासवडड रखें 
• अिजाि ईमेल/ललकं से बचें 
• एंटीवायरस सॉफ्टवेयर इंस्टॉल करें 
• 2-Factor Authentication का उपयोग करें 

6.10 इंटरनेट कनेक्शन के प्रकार 

प्रकार वििरण 

Dial-Up पुरािी धीमी किेक्ट्शि तकिीक 

Broadband Fast और लगातार चलता है 

Wi-Fi वायरलेस लोकल िेटवकड  
Mobile Data 4G/5G मोबाइल िेटवकड  
Fiber Optic बहुत तेज़ इंटरिेट किेक्ट्शि 

 

6.11 शॉटडकट और सामान्य शब्द 

शब्द अथड 
HTTP / HTTPS वेबपेज एक्ट्सेस का प्रोटोकॉल 

Domain Name वेबसाइट का िाम (जैस ेgoogle.com) 

IP Address इंटरिेट पर कंप्यूटर की पहचाि 

Bookmark वेबपेज को सेव करिा 
Incognito Mode प्राइवेट ब्राउजज़ंग 



Chapter 7 

 Digital Financial Tools (डिक्जटल वित्त़ीय टूल्स) 

7.1 डिक्जटल भुगतान क्या है? (What is Digital Payment?) 

डडजजटल भुगताि एक ऐसी प्रकरया है जजसमें िकद (Cash) के त्रबिा ऑिलाइि माध्यम से पैसे का लेि-देि होता 
है। इसमें कंप्यूटर, मोबाइल, इंटरिेट और बैंक अकाउंट का उपयोग होता है। 

 

7.2 डिक्जटल भुगतान के प्रकार (Types of Digital Payments) 

तरीका वििरण 

UPI (Unified Payments Interface) मोबाइल से तुरंत बैंक-टू-बैंक रांसफर 
BHIM App NPCI द्वारा ववकलसत एक UPI आधाररत ऐप 

Mobile Wallets 
Paytm, PhonePe, Google Pay जैस ेऐप्स में पैसा स्टोर 
करके पेमेंट 

Net Banking बैंक की वेबसाइट से पेमेंट या रांसफर करिा 
Debit/Credit Card काडड स्वाइप करके या ऑिलाइि िंबर डालकर पेमेंट 

AEPS (Aadhaar Enabled Payment 
System) 

आधार िंबर और कफंगरवप्रटं से बैंककंग सेवा लेिा 
 

7.3 UPI क्या है और कैस ेकाम करता है? 

UPI (Unified Payments Interface) एक ररयल-टाइम पेमेंट लसस्टम है जो मोबाइल ऐप्स के माध्यम से बैंक 

रांसफर करता है। 

मुख्य ऐप्स: 

• Google Pay 
• PhonePe 
• Paytm 
• BHIM 

      STEPS : 

1. UPI ऐप डाउिलोड करें 



2. मोबाइल िंबर से बैंक ललकं करें 
3. UPI PIN सटे करें 
4. मोबाइल िंबर या UPI ID से पैसे भेजें 

7.4 QR कोि से पेमेंट कैस ेकरें? 

• दकुाि पर लगे QR कोड को ऐप से स्कैि करें 
• अमाउंट दजड करें और UPI PIN डालें 
• तुरंत पेमेंट हो जाएगा 

7.5 AEPS (Aadhaar Enabled Payment System) 

यह सेवा उि लोगों के ललए है जजिके पास ATM काडड या स्माटडफोि िही ंहै। 

सेिाए:ं 

• बैलेंस चेक 

• िकद निकासी 
• आधार िंबर + बैंक चुििा + कफंगरवप्रटं से रांजके्ट्शि 

 

7.6 नेट बैंक्रकंग क्या है? 

Net Banking से यूज़र बैंक की वेबसाइट पर लॉगगि करके फंड रांसफर, त्रबल पेमेंट, अकाउंट चके आदद कर सकत े

हैं। 

जरूरी बातें: 

• यूजर आईडी और पासवडड 
• OTP वेररकफकेशि 

• IMPS, NEFT, RTGS से रासंफर 

 

7.7 डिक्जटल भुगतान में सािधाऩी 

• मजबूत पासवडड और PIN का उपयोग करें 
• अिजाि ललकं या ऐप्स से पमेेंट ि करें 



• रांजेक्ट्शि के बाद SMS/Email अलटड चके करें 
• नियलमत रूप से बैंक स्टेटमेंट चेक करें 

 

7.8 डिक्जटल भुगतान के फायदे 

• 24x7 लेि-देि 

• कैशलेस लेि-देि 

• रैक करिे में आसाि 

• सुरक्षक्षत और तेज़ 

• कोरोिा काल में Social Distancing के ललए सुरक्षक्षत 

 

7.9 सामान्य शब्द और शॉटडकट 

शब्द अथड 
OTP One Time Password (एक बार उपयोग होिे वाला कोड) 

VPA Virtual Payment Address (UPI ID) 

IMPS Immediate Payment Service (तुरंत रांसफर) 
NEFT National Electronic Fund Transfer (कुछ घंटों में रांसफर) 
RTGS Real Time Gross Settlement (बडे़ अमाउंट का तुरंत रांसफर) 

 

   उपयोग के ििे 

• दकुाि पर सामाि खरीदिा 
• त्रबजली/पािी/फोि त्रबल भरिा 
• ऑिलाइि शॉवपगं 

• ररचाजड और दटकट बुककंग 

• स्कूल/कॉलेज फीस भरिा 

 

 

 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

Chapter 8 

    Networking Basics (नेटिक्रकिं ग का पररचय) 

8.1 नेटिकड  क्या है? (What is a Network?) 

जब दो या दो से अगधक कंप्यूटर या डडवाइस को आपस में जोड़कर जािकारी साझा की जाती है, तो उस ेनेटिकड  
(Network) कहत ेहैं। 

उदाहरण: ऑकफस में सभी कंप्यूटर एक वप्रटंर से जुडे़ हैं – यह एक िेटवकड  है। 

 

8.2 नेटिकड  के लाभ (Benefits of Networking) 

• डेटा शेयर करिा 
• हाडडवेयर (जैस ेवप्रटंर) शेयर करिा 



• कम्युनिकेशि आसाि बिािा 
• इंटरिेट साझा करिा 
• सेंरलाइज्ड डेटा मैिेजमेंट 

 

8.3 नेटिकड  के प्रकार (Types of Networks) 

नेटिकड  वििरण 

LAN (Local Area Network) सीलमत एररया में (जैस ेऑकफस, स्कूल) 

MAN (Metropolitan Area Network) पूरे शहर को जोड़ता है 

WAN (Wide Area Network) देश/दनुिया भर के िेटवकड  को जोड़ता है (जैस:े इंटरिेट) 

PAN (Personal Area Network) बहुत छोटे िेटवकड  जैस ेBluetooth 

 

8.4 नेटिकड  टोपोलॉज़ी (Network Topology) 

टोपोलॉजी से मतलब होता है कक िेटवकड  में डडवाइसेस कैस ेजुडे़ हैं। 

टोपोलॉज़ी विशेषता 
Bus सभी डडवाइसेस एक लाइि से जुड़ी होती हैं 
Star एक सेंरल डडवाइस से सभी जडेु़ होत ेहैं 
Ring एक ररगं (चर) के रूप में जुडे़ होत ेहैं 
Mesh हर डडवाइस हर डडवाइस से जडु़ी होती है 

 

 

8.5 नेटिकड  डििाइस (Network Devices) 

डििाइस कायड 
Modem डडजजटल ↔ एिालॉग लसग्िल कन्वटड करता है (इंटरिेट के ललए) 

Router िेटवकड  को आपस में जोड़ता है और इंटरिेट प्रदाि करता है 

Switch िेटवकड  डडवाइसेस को जोड़िे का काम करता है 

Hub डेटा को सभी पोट्डस पर भेजता है 



डििाइस कायड 
Access Point वायरलेस िेटवकड  बिाता है (Wi-Fi) 

 

8.6 आईप़ी एडे्रस क्या है? (What is IP Address?) 

IP Address कंप्यूटर का इंटरिेट पर एक यूनिक पता होता है, जैस ेककसी व्यजक्ट्त का मोबाइल िंबर। 

उदाहरण: 192.168.0.1 

IP के प्रकार: 

• Static IP: Permanent address 

• Dynamic IP: हर बार िया address 

 

8.7 DNS (Domain Name System) 

DNS डोमेि िाम को IP एडे्रस में बदलता है। 

उदाहरण: 

जब हम www.google.com खोलत ेहैं, DNS इस ेIP Address में बदलकर सवडर से किेक्ट्ट करता है। 

 

8.8 DHCP (Dynamic Host Configuration Protocol) 

DHCP लसस्टम ऑटोमैदटक तरीके से कंप्यूटर को IP Address देता है ताकक यूजर को मैन्युअली सेदटगं ि करिी 
पडे़। 

8.9 िॉिबैंि और िाई-फाई 

• Broadband: इंटरिेट का हाई-स्पीड किेक्ट्शि, केबल या फाइबर से 

• Wi-Fi: Wireless तरीके से इंटरिेट एक्ट्सेस करिा 

Wi-Fi के लाभ: 

• केबल की जरूरत िही ं
• मोबाइल और लैपटॉप से किेजक्ट्टववटी 

http://www.google.com/


• हॉटस्पॉट के ज़ररए शेयररगं 

8.10 नेटिक्रकिं ग प्रोटोकॉल (Protocols) 

Protocol वो नियम होत ेहैं जजिसे िेटवककिं ग होती है। 

प्रोटोकॉल कायड 
HTTP/HTTPS वेबसाइट एक्ट्सेस के ललए 

FTP फाइल रांसफर के ललए 

TCP/IP इंटरिेट कम्युनिकेशि का बसे 

SMTP/POP3 ईमेल भेजिे और प्राप्त करिे के ललए 

 

   नेटिक्रकिं ग का उपयोग: 

1. इंटरनेट एक्सेस क्या है? 

इंटरनेट एक्सेस (Internet Access) का मतलब है – ककसी डडवाइस (जैस ेकंप्यूटर, मोबाइल, टैबलेट आदद) को 
इंटरिेट से जोड़िा ताकक आप वेबसाइट देख सकें , ईमेल भेज सकें , वीडडयो देख सकें  या ऑिलाइि जािकारी प्राप्त 

कर सकें । 

 

इंटरनेट से कनेक्ट होने के तरीके (Modes of Internet Access): 

1. Dial-up Connection 

o पुरािे ज़मािे की तकिीक 

o बहुत धीमी स्पीड 

o टेलीफोि लाइि का इस्तेमाल 

2. Broadband Connection 

o हाई स्पीड इंटरिेट 

o DSL, ADSL, केबल, फाइबर ऑजप्टक 

3. Wi-Fi (Wireless Fidelity) 

o वायरलेस इंटरिेट 

o राउटर के माध्यम से घर या ऑकफस में उपयोग 

4. Mobile Internet (3G/4G/5G) 

o मोबाइल िेटवकड  के जररए इंटरिेट 

o मोबाइल डाटा या हॉटस्पॉट के ज़ररए 



5. Satellite Internet 

o ररमोट एररया में उपयोग 

o सैटेलाइट के ज़ररए किेक्ट्शि 

o थोड़ा महंगा और धीमा 
6. Hotspot (Wi-Fi Tethering) 

o मोबाइल को राउटर की तरह इस्तेमाल करिा 

 

 इंटरनेट एक्सेस करने के ललए आिश्यक च़ीजें: 

1. कंप्यूटर, लैपटॉप, स्माटडफोि आदद 

2. िेटवकड  डडवाइस (राउटर, मॉडेम) 

3. इंटरिेट सेवा प्रदाता (ISP) 

4. वेब ब्राउज़र (जैस ेChrome, Firefox, Edge) 

 

 इंटरनेट उपयोग में सािधाननयााँ: 

• एंटीवायरस लगािा 
• फायरवॉल का उपयोग 

• लसक्ट्योर वेबसाइट (https) पर जािा 
• पजब्लक वाई-फाई पर सावधािी 

 

2. क्लाउि ्टोरेज (Cloud Storage)  

क्लाउि ्टोरेज क्या है? 

क्लाउि ्टोरेज एक ऐसी तकिीक है जजसमें आपका डेटा (जैसे फाइल, फोटो, वीडडयो) इंटरिेट के ज़ररए ककसी 
दरूदराज़ सवडर पर स्टोर ककया जाता है, ि कक आपके कंप्यूटर में। 

इस े"Online Storage" भी कहते हैं। 

 

 क्लाउि ्टोरेज कैस ेकाम करता है? 



1. आप इंटरिेट से जुडे़ डडवाइस से डेटा अपलोड करत ेहैं। 
2. डेटा क्ट्लाउड सवडर पर सेव हो जाता है। 
3. जब चाहें और जहााँ चाहें – आप उस डेटा को एक्ट्सेस या डाउिलोड कर सकत ेहैं। 

 

 क्लाउि ्टोरेज के उदाहरण (Cloud Storage Services): 

सेिा का नाम कंपऩी 
Google Drive Google 

OneDrive Microsoft 

Dropbox Dropbox Inc. 

iCloud Apple 

Mega Mega Ltd. 

 

 क्लाउि ्टोरेज के फायदे (Advantages): 

1. कही ंसे भ़ी एक्सेस – इंटरिेट से ककसी भी जगह से डेटा एक्ट्सेस कर सकत ेहैं। 
2. डििाइस ्पेस की बचत – कफजजकल स्टोरेज की जरूरत िहीं होती। 
3. िेटा बैकअप – फाइल्स सुरक्षक्षत रहती हैं, डडवाइस खराब हो जािे पर भी। 
4. शेयररगं आसान – ललकं के ज़ररए आसािी से दसूरों के साथ शेयर कर सकते हैं। 
5. लसकं्रकंग – सभी डडवाइस में डेटा ऑटोमदैटक अपडेट होता है। 

 

 क्लाउि ्टोरेज के नुकसान (Disadvantages): 

1. इंटरनेट जरूरी – त्रबिा इंटरिेट एक्ट्सेस संभव िहीं। 
2. लसक्योररटी खतरे – डेटा हैक या लीक हो सकता है। 
3. प्राइिेस़ी इश्यू – सवडर पर डेटा स्टोर होिे से गोपिीयता प्रभाववत हो सकती है। 
4. ्पेस लललमट – फ्री वजडि में सीलमत स्टोरेज। 

 

 क्लाउि ्टोरेज में सुरिा (Security in Cloud Storage): 

• डेटा एजन्रप्शि 

• पासवडड प्रोटेक्ट्शि 



• टू-फैक्ट्टर ऑथेंदटकेशि 

• लसक्ट्योर लॉगगि 

 

 

 

 O Level परीिा में कैस ेपूछा जाता है? 

उदाहरण प्रश्न: 

Q. क्ट्लाउड स्टोरेज क्ट्या है? इसके दो लाभ और दो हानियााँ ललखखए। 
उत्तर: 
क्ट्लाउड स्टोरेज वह तकिीक है जजसमें डेटा को इंटरिेट के माध्यम से ररमोट सवडर पर स्टोर ककया जाता है। 
लाभ: 

1. कही ंसे भी एक्ट्सेस ककया जा सकता है। 
2. स्टोरेज डडवाइस की आवश्यकता िहीं होती। 

हाननयााँ: 
3. इंटरिेट के त्रबिा उपयोग संभव िहीं। 
4. डेटा हैक होिे का खतरा रहता है। 

 

3. ईमेल और ि़ीडियो कॉल  

 ईमेल (E-mail – Electronic Mail) 

   ईमेल क्या है? 

ईमेल एक इलके्ट्रॉनिक सदेंश सेवा है जजसस ेहम इंटरिेट के माध्यम से टेक्ट्स्ट, डॉक्ट्युमेंट्स, फोटो, वीडडयो आदद 

भेज और प्राप्त कर सकत ेहैं। 

 

 ईमेल के मुख्य घटक (Components of Email): 



भाग वििरण 

To मुख्य प्राप्तकताड का ईमेल पता 
Cc (Carbon Copy) अन्य को कॉपी भेजिे के ललए 

Bcc (Blind Carbon Copy) छुपी हुई कॉपी 
Subject ईमेल का ववषय 

Body मुख्य संदेश 

 

 ईमेल में अन्य सुविधाएं: 

• Attachment (फाइल जोड़िा) 
• Signature (प्रेषक की जािकारी) 
• Reply / Forward (जवाब देिा या आग ेभेजिा) 
• Spam Filter (अिचाहे मेल से बचाव) 

 

 ईमेल सेिा प्रदाता (Popular Email Providers): 

• Gmail 
• Yahoo Mail 
• Outlook 
• ProtonMail 

 

 ईमेल के लाभ (Advantages of Email): 

1. तेज और मुफ्त संचार 
2. दस्तावेज़ संलग्ि करिा संभव 

3. कई लोगों को एक साथ भजे सकते हैं 
4. ररकॉडड सेव रहता है 

 

 ईमेल के नुकसान: 

1. स्पैम और वायरस का खतरा 
2. इंटरिेट के त्रबिा उपयोग संभव िहीं 



3. गोपिीयता का खतरा 

 

4. ि़ीडियो कॉल (Video Calling) 

   ि़ीडियो कॉल क्या है? 

ि़ीडियो कॉल एक ऐसी तकिीक है जजसमें दो या अगधक लोग इंटरिेट के माध्यम से एक-दसूरे को देखते हुए बात 

कर सकते हैं। 

 

 

 ि़ीडियो कॉललगं ऐप्स के उदाहरण: 

ऐप कंपऩी 
WhatsApp Meta 

Zoom Zoom Inc. 

Google Meet Google 

Microsoft Teams Microsoft 

Skype Microsoft 

 

 ि़ीडियो कॉल के ललए जरूरी च़ीजें: 

1. स्माटडफोि / लैपटॉप / कंप्यूटर 
2. कैमरा और माइरोफोि 

3. इंटरिेट किेक्ट्शि 

4. वीडडयो कॉललगं ऐप 

 

 ि़ीडियो कॉल के फायदे: 

1. आमिे-सामिे बात करिे जसैा अिुभव 

2. घर बैठे मीदटगं, क्ट्लासेस आदद संभव 

3. समय और यािा की बचत 

4. ररकॉडडिंग की सुववधा 



 

 ि़ीडियो कॉल के नुकसान: 

1. इंटरिेट पर निभडरता 
2. प्राइवेसी की समस्या 
3. तकिीकी समस्या (लैग, ऑडडयो कटिा आदद) 

 

 O Level परीिा के संभावित प्रश्न: 

Q1. ईमेल क्या है? इसके दो लाभ और दो हाननयााँ ललखखए। 
Q2. ि़ीडियो कॉल क्या है? इसके उपयोग और स़ीमाएाँ बताइए। 
Q3. ईमेल और ि़ीडियो कॉल में अंतर ललखखए। 

 ईमेल और ि़ीडियो कॉल में अतंर: 

ब्रबदं ु ईमेल ि़ीडियो कॉल 

प्रकार टेक्ट्स्ट आधाररत संचार ऑडडयो-ववज़ुअल संचार 
वास्तववक समय िहीं हााँ 
उपकरण ईमेल क्ट्लाइंट कैमरा + माइक 

प्रयोग आगधकाररक सचंार व्यजक्ट्तगत + प्रोफेशिल बातचीत 

 

5. फाइल शेयररगं क्या है? 

फाइल शेयररगं का मतलब है ककसी फाइल (जैस ेडॉक्ट्युमेंट, फोटो, वीडडयो, ऑडडयो आदद) को एक डडवाइस से दसूरे 
डडवाइस पर भजेिा या साझा करिा। 

यह लोकल िेटवकड  या इंटरिेट के माध्यम से ककया जा सकता है। 

 

फाइल शेयररगं के प्रकार (Types of File Sharing): 

1. लोकल फाइल शेयररगं (Local File Sharing) 



o LAN (Local Area Network) के माध्यम से 

o एक ही िेटवकड  में जुडे़ कंप्यूटर 
2. ऑनलाइन फाइल शेयररगं (Online File Sharing) 

o इंटरिेट के ज़ररए 

o क्ट्लाउड स्टोरेज या ईमेल का उपयोग 

3. प़ीयर-टू-प़ीयर (P2P) शेयररगं 

o जैस ेBitTorrent 

o त्रबिा सवडर के, एक डडवाइस से सीध ेदसूरे को 
4. ब्लूटूथ / िायरलेस शेयररगं 

o पास के मोबाइल या लैपटॉप में फाइल भजेिा 

 

 फाइल शेयररगं के उदाहरण (File Sharing Tools/Services): 

टूल / सेिा प्रकार 
Google Drive क्ट्लाउड शेयररगं 

WeTransfer ऑिलाइि रांसफर 
Bluetooth वायरलेस लोकल शेयररगं 

Dropbox क्ट्लाउड स्टोरेज 

Email Attachment इंटरिेट द्वारा भेजिा 
USB Drive कफजजकल शेयररगं 

 

 फाइल शेयररगं के फायदे (Advantages): 

1. तेज़ और आसाि डेटा रांसफर 
2. कई लोगों के साथ एक ही फाइल साझा करिा 
3. ऑकफस वकड  और टीमवकड  में सहूललयत 

4. क्ट्लाउड से कभी भी एक्ट्सेस सभंव 

 

 फाइल शेयररगं के नुकसान (Disadvantages): 

1. वायरस या मालवेयर फैलिे का खतरा 



2. डेटा चोरी या लीक की संभाविा 
3. कुछ सेवाओं में साइज़ लललमट 

4. स्लो िेटवकड  पर धीमा रांसफर 

 

 सुरिा के उपाय (Security in File Sharing): 

• पासवडड से सुरक्षक्षत ललकं भेजिा 
• केवल "View Only" परलमशि देिा 
• एंटीवायरस सॉफ्टवेयर लगािा 
• लसक्ट्योर िेटवकड  का उपयोग करिा 

 

 O Level परीिा में पूछे जाने िाले संभावित प्रश्न: 

Q1. फाइल शेयररगं क्या है? इसके दो लाभ और दो हाननयााँ ललखखए। 
Q2. क्लाउि ्टोरेज और फाइल शेयररगं में अंतर बताइए। 
Q3. फाइल शेयररगं के कौन-कौन से माध्यम होत ेहैं? 

 संक्षिप्त रूप में (Revision Table): 

विषय वििरण 

पररभाषा फाइल को एक डडवाइस से दसूरे तक भजेिा 
मुख्य माध्यम ब्लूटूथ, क्ट्लाउड, ईमेल, P2P, USB 

लाभ आसाि, तेज, गु्रप शेयररगं 

िुकसाि वायरस, डेटा चोरी, लललमट 

 

6. सिडर-आधाररत एक्प्लकेशन क्या है? 

सिडर-आधाररत एक्प्लकेशन वे सॉफ़्टवेयर होत ेहैं जो ककसी सिडर (Server) पर चलत ेहैं और जजिका उपयोग 

क्लाइंट डििाइस (जैस ेकंप्यूटर, मोबाइल) इंटरिेट या िेटवकड  के माध्यम से करत ेहैं। 

उदाहरण के ललए: Gmail, Facebook, Google Docs, Online Banking 



 

 कैस ेकाम करता है? 

1. सवडर पर एजप्लकेशि इंस्टॉल होता है। 
2. उपयोगकताड वेब ब्राउज़र या ऐप के माध्यम से अिुरोध भेजता है। 
3. सवडर उस अिुरोध को प्रोसेस करता है और पररणाम क्ट्लाइंट को भेजता है। 

 

 उदाहरण (Examples of Server-Based Applications): 

एक्प्लकेशन कायड 
Gmail ईमेल सेवा 
Google Docs ऑिलाइि डॉक्ट्यूमेंट एडडदटगं 

YouTube वीडडयो स्रीलमगं 

Net Banking ऑिलाइि बैंककंग 

Zoom / Google Meet वीडडयो कॉन्फ्रें लसगं 

ERP Systems ऑकफस या त्रबजिेस मैिेजमेंट 

 

 

   सिडर-आधाररत एक्प्लकेशन के लाभ (Advantages): 

1. कोई इंस्टॉलेशि ज़रूरी िहीं – लसफड  ब्राउज़र से एक्ट्सेस करें 
2. एक ही एजप्लकेशि को कई लोग एक साथ उपयोग कर सकत ेहैं 
3. डेटा सवडर पर सेव रहता है – सुरक्षक्षत और बैकअप संभव 

4. सेंरल अपडेट – सबको एक साथ िया वजडि लमल जाता है 

 

 सिडर-आधाररत एक्प्लकेशन की स़ीमाएाँ (Disadvantages): 

1. इंटरिेट किेक्ट्शि आवश्यक 

2. सवडर डाउि हुआ तो एजप्लकेशि बंद 

3. डेटा प्राइवेसी और लसक्ट्योररटी की समस्या 
4. िेटवकड  स्पीड पर निभडरता 



 

 O Level परीिा में संभावित प्रश्न: 

Q1. सिडर-आधाररत एक्प्लकेशन क्या है? उदाहरण सदहत समझाइए। 
Q2. सिडर-आधाररत और िे्कटॉप-आधाररत एक्प्लकेशन में अंतर बताइए। 
Q3. सिडर-आधाररत एक्प्लकेशन के दो लाभ और दो हाननयााँ ललखखए। 

 

 िे्कटॉप और सिडर-आधाररत एक्प्लकेशन में अंतर: 

विशेषता िे्कटॉप एक्प्लकेशन सिडर-आधाररत एक्प्लकेशन 

इंस्टॉलेशि कंप्यूटर पर होता है सवडर पर होता है 

एक्ट्सेस केवल उसी डडवाइस से ककसी भी डडवाइस से 

अपडेट हर डडवाइस में अलग एक बार सवडर पर 
इंटरिेट की आवश्यकता िहीं हााँ (अगधकतर मामलों में) 
 

 

 

 

 

 नेटिकड  सुरिा के सुझाि: 

1.मजबूत पासििड (Strong Password)  

   पासििड क्या है? 

पासवडड एक गुप्त कोि होता है जजसका उपयोग ककसी लसस्टम, ईमेल, अकाउंट या डडवाइस को सुरक्षित रूप से 

एक्सेस करने के ललए ककया जाता है। 

 

मजबूत पासििड क्या होता है? 



मजबूत पासििड (Strong Password) वह पासवडड होता है जजस ेअिुमाि लगािा, हैक करिा या बू्रट फोसड से 

तोड़िा बहुत कदिन हो। 

यह पासवडड आपके व्यजक्ट्तगत डेटा और ऑिलाइि सुरक्षा का पहला स्तर होता है। 

 

 मजबूत पासििड की विशेषताएाँ: 

एक मजबूत पासवडड में ये चीज़ें होती हैं: 

विशेषता वििरण 

      अंकों का उपयोग (Numbers) जैस:े 0-9 

     अिरों का उपयोग (Letters) छोटे और बडे़ दोिों जैस:े a-z, A-Z 

         विशेष चचन्ह (Special Characters) जैस:े @, #, $, %, &, * 

      कम से कम 8–12 कैरेक्टर जजतिा लंबा पासवडड, उतिा बेहतर 
   व्यक्क्तगत जानकारी नहीं जैस:े जन्मनतगथ, िाम, मोबाइल िंबर 

 

   मजबूत पासििड का उदाहरण: 

perl 
CopyEdit 
P@ssW0rd#2025 
My$BankAcc@786 

 

 कमज़ोर पासििड के उदाहरण (क्जनसे बचें): 

css 
CopyEdit 
123456, password, abcd1234, india@123, myname 

 

 मजबूत पासििड बनाने के सुझाि: 

1. हमेशा अिर + अकं + चचन्ह लमलाकर बिाएं। 
2. अपिे पासवडड को क्रकस़ी से साझा न करें। 
3. समय-समय पर पासवडड बदलत ेरहें। 
4. हर अकाउंट के ललए अलग पासििड बिाएं। 



5. पासवडड पासििड मैनेजर में सुरक्षक्षत रखें (जैस:े Bitwarden, LastPass)। 

 

 O Level परीिा में संभावित प्रश्न: 

Q1. मजबूत पासििड क्या होता है? इस ेबनाने के ननयम बताइए। 
Q2. कमज़ोर और मजबूत पासििड में क्या अंतर है? उदाहरण सदहत समझाइए। 
Q3. मजबूत पासििड की दो विशेषताएाँ ललखखए। 

 

 संिेप में (Quick Revision Table): 

मजबूत पासििड में होना चादहए क्यों? 

कम से कम 8–12 कैरेक्ट्टर अगधक सुरक्षक्षत 

बड़ी व छोटी अक्षरें जदटलता बढती है 

अंक और ववशेष गचन्ह पासवडड कदठि बिता है 

व्यजक्ट्तगत जािकारी िही ं अिुमाि लगािा मुजश्कल 

 

 

 

 

2.Firewall का उपयोग –  

   Firewall क्या है? 

Firewall एक सुरक्षा प्रणाली है जो कंप्यूटर िेटवकड  में आिे-जािे वाले डाटा को ननयंब्रित करता है और अनचाहे या 
हाननकारक रैक्रफक को रोकता है। 

 सरल भाषा में: Firewall एक गेटकीपर (Gatekeeper) की तरह काम करता है जो तय करता है कक कौि-सा 
डाटा अदंर आएगा और कौि-सा िहीं। 

 



 Firewall के प्रकार (Types of Firewall): 

1. Software Firewall 

o कंप्यूटर में इंस्टॉल ककया जाता है 

o जैस:े Windows Defender Firewall 

2. Hardware Firewall 

o िेटवकड  राउटर या अलग डडवाइस के रूप में 
o बडे़ िेटवकड  के ललए उपयुक्ट्त 

 

 Firewall का उपयोग (Uses of Firewall): 

उपयोग वििरण 

   हैकर से सुरिा लसस्टम में अिगधकृत एक्ट्सेस को रोकता है 

   मालिेयर और िायरस से बचाि संददग्ध वेबसाइट या डाटा को ब्लॉक करता है 

   नेटिकड  मॉननटररगं कौि-कौि से डडवाइस जुड़ रहे हैं, यह देखता है 

   इनकलमगं/आउटगोइंग रैक्रफक को ननयंब्रित करना कौि-सा रैकफक अिुमनत योग्य है, तय करता है 

   ्पैम और क्रफलशगं से सुरिा हानिकारक ईमेल या ललकं को रोकता है 

 

 Firewall की स़ीमाएाँ (Limitations): 

1. यह भ़ीतर के हमलों (Internal Attacks) से हमेशा िहीं बचा सकता 
2. हर वायरस को िहीं पहचािता 
3. कॉजन्फगरेशि गलत होिे पर सुरक्षा कम हो सकती है 

4. केवल िेटवकड  रैकफक को कंरोल करता है – हर प्रकार की थ्रटे से िही ंबचाता 

Firewall के कुछ लोकवप्रय उदाहरण: 

• Windows Defender Firewall 
• Norton Firewall 
• Cisco ASA 
• Sophos 
• pfSense 

 

O Level परीिा में संभावित प्रश्न: 



Q1. Firewall क्या होता है? इसका उपयोग ललखखए। 
Q2. Software और Hardware Firewall में अंतर ललखखए। 
Q3. Firewall से संबंचधत दो लाभ और एक स़ीमा ललखखए। 

 

संक्षिप्त सारांश (Quick Table): 

ब्रबदं ु वििरण 

पररभाषा िेटवकड  सुरक्षा उपकरण 

मुख्य कायड अवांनछत रैकफक को ब्लॉक करिा 
प्रकार सॉफ़्टवेयर और हाडडवेयर 
लाभ सुरक्षा, रैकफक कंरोल, निगरािी 
सीमा सभी हमलों से िहीं बचा सकता 

 

3.Antivirus और Anti-malware  

   Antivirus क्या है? 

Antivirus एक ऐसा सॉफ़्टवयेर है जो कंप्यूटर को िायरस (Virus) से सुरक्षित रखि ेके ललए बिाया गया है। यह 

वायरस को ्कैन, डिटेक्ट और डिलीट करता है। 

 वायरस एक हानिकारक प्रोग्राम होता है जो कंप्यूटर की फाइलें खराब कर सकता है। 

 

   Anti-malware क्या है? 

Anti-malware एक उन्ित सॉफ़्टवेयर है जो लसफड  िायरस ही नहीं, बजल्क सभ़ी प्रकार के मालिेयर (जैस े

स्पाइवेयर, रोजि, वॉमड, रैंसमवेयर) से लसस्टम को सुरक्षक्षत रखता है। 

 Malware = “Malicious Software” यािी हानिकारक सॉफ़्टवेयर। 

 

 Antivirus और Anti-malware में अंतर: 



विशेषता Antivirus Anti-malware 

सुरक्षा का दायरा लसफड  वायरस से सभी प्रकार के मालवेयर से 

उद्देश्य वायरस स्कैि व डडलीट वायरस + अन्य खतरों की पहचाि 

उदाहरण Norton, Quick Heal Malwarebytes, HitmanPro 

 

 मुख्य कायड (Functions): 

कायड वििरण 

    स्कैनिगं फाइल्स और लसस्टम की जाचं करिा 
    डडटेक्ट्शि खतरिाक सॉफ़्टवेयर की पहचाि 

      ररमूवल वायरस और मालवेयर को हटािा 
    ऑटोमैदटक अपडेट िए वायरस से सुरक्षा के ललए अपडेट 

        ररयल टाइम प्रोटेक्ट्शि लगातार सुरक्षा देिा 
 

   प्रलसद्ध Antivirus और Anti-malware सॉफ़्टिेयर: 

नाम प्रकार 
Quick Heal Antivirus 

Avast Antivirus 

Kaspersky Antivirus 

Malwarebytes Anti-malware 

Bitdefender Antivirus + Anti-malware 

Windows Defender दोिों प्रकार की सुरक्षा देता है 

 

 लाभ (Benefits): 

1. कंप्यूटर को सुरक्षक्षत रखत ेहैं 
2. डेटा चोरी से बचाव 

3. लसस्टम परफॉमेंस में सुधार 
4. ऑिलाइि ब्राउजज़ंग को सुरक्षक्षत बिात ेहैं 

 



स़ीमाएाँ (Limitations): 

1. सभी िए वायरस को तुरंत िहीं पहचाि पाते 

2. फ्री वजडि में सीलमत सुरक्षा 
3. अगधक RAM/CPU उपयोग कर सकते हैं 
4. कई बार फजी अलटड भी देत ेहैं 

 

O Level परीिा में संभावित प्रश्न: 

Q1. Antivirus क्या है? इसका कायड समझाइए। 
Q2. Anti-malware क्या होता है? Antivirus से इसका अंतर समझाइए। 
Q3. दो प्रलसद्ध Antivirus सॉफ़्टिेयरों के नाम ललखखए। 
Q4. Antivirus और Anti-malware के दो लाभ ि दो स़ीमाएाँ ललखखए। 

 

 संिेप में (Quick Revision): 

ब्रबदं ु Antivirus Anti-malware 

पररभाषा वायरस से सुरक्षा सभी प्रकार के मालवेयर से सुरक्षा 
कायड वायरस स्कैि/ररमूव वॉमड, रोजि, रैंसमवेयर आदद से सुरक्षा 
उपयोग सभी कंप्यूटर/मोबाइल में ज़रूरी  

 

 

 

 

4.Secure Wi-Fi (WPA2 / WPA3)  

   Wi-Fi क्या है? 

Wi-Fi एक वायरलेस िेटवककिं ग तकिीक है जजसस ेडडवाइस त्रबिा तार के इंटरिेट या लोकल िेटवकड  से जुड़ते हैं। 

 



 Secure Wi-Fi क्या है? 

Secure Wi-Fi का मतलब है कक Wi-Fi िेटवकड  को पासििड और एक्न्रप्शन के ज़ररए सुरक्षक्षत करिा ताकक 

अनचधकृत उपयोग या हैक्रकंग से बचा जा सके। 

 

 WPA2 और WPA3 क्या हैं? 

टमड पूरा नाम कायड 

WPA2 
Wi-Fi Protected 
Access 2 

वाई-फाई िेटवकड  के ललए एक सुरक्षा प्रोटोकॉल, AES एजन्रप्शि का 
उपयोग करता है 

WPA3 
Wi-Fi Protected 
Access 3 

WPA2 से भी अगधक सुरक्षक्षत िया प्रोटोकॉल, बेहतर एजन्रप्शि और 
प्रोटेक्ट्शि 

 

 WPA2/WPA3 का उपयोग क्यों ज़रूरी है? 

1. नेटिकड  को पासििड से सुरक्षित रखना 
2. िेटा को एक्न्रप्ट करना (Encrypted Data Transfer) 

3. अनजान डििाइसेस को कनेक्ट होने से रोकना 
4. हैक्रकंग, MITM (Man-in-the-Middle) अटैक से सुरिा 

 

 WPA2 और WPA3 में अंतर: 

ब्रबदं ु WPA2 WPA3 

लॉन्च वषड 2004 2018 

सुरक्षा स्तर मजबूत बहुत अगधक मजबूत 

एजन्रप्शि AES AES + अगधक लसक्ट्योर 
ओपि िेटवकड  प्रोटेक्ट्शि िहीं हााँ (Individual Encryption) 

बू्रट फोसड प्रोटेक्ट्शि कम ज्यादा 
 

 Secure Wi-Fi नेटिकड  के सुझाि: 



1. हमेशा WPA2 या WPA3 सुरिा चुिें 
2. मजबूत पासवडड सटे करें (जैस:े HomeNet@2025) 

3. डडफॉल्ट िेटवकड  िाम (SSID) बदलें 
4. गेस्ट िेटवकड  अलग से बिाए ं

5. राउटर फमडवेयर अपडेट रखें 

 

 यदद Wi-Fi सुरक्षित न हो तो क्या हो सकता है? 

• कोई भी व्यजक्ट्त त्रबिा अिुमनत िेटवकड  का उपयोग कर सकता है 

• डाटा चोरी, स्िूवपगं और हैककंग के खतरे बढत ेहैं 
• िेटवकड  स्लो हो सकता है 

• लसस्टम वायरस या मालवेयर से प्रभाववत हो सकता है 

 

 O Level परीिा में संभावित प्रश्न: 

Q1. WPA2 और WPA3 क्या हैं? इनके ब़ीच अंतर बताइए। 
Q2. Wi-Fi नेटिकड  को सुरक्षित रखन ेके दो तरीके बताइए। 
Q3. Secure Wi-Fi क्यों ज़रूरी है? सिंेप में समझाइए। 

 

 (Quick Table): 

ब्रबदं ु WPA2 WPA3 

सुरक्षा अच्छी बेहतरीि 

लॉन्च 2004 2018 

उपयोग आज भी बहुत सामान्य िए डडवाइस में 
सुझाव कम से कम WPA2 तो होिा चादहए, WPA3 बेहतर  

 

नोट: अगर आपका Wi-Fi राउटर बहुत पुरािा है, तो उसमें WPA3 का सपोटड िहीं होगा। ऐसे में WPA2-PSK 

(AES) का उपयोग सबसे सुरक्षक्षत ववकल्प होता है। 

 



5.VPN का उपयोग  

   VPN क्या है? 

VPN का पूरा िाम है: Virtual Private Network 

यह एक सुरक्षित नेटिकड  कनेक्शन है जो इंटरिेट पर आपके िेटा को एक्न्रप्ट करता है और आपकी लोकेशन और 
पहचान को छुपाता है। 

सरल शब्दों में: VPN एक गुप्त सुरंग (secure tunnel) की तरह काम करता है जो आपके इंटरिेट रैकफक को 
नछपाता है। 

 

VPN का उपयोग (Uses of VPN): 

उपयोग वििरण 

    िेटा सुरिा Wi-Fi या इंटरिेट पर भेजा गया डेटा एजन्रप्ट ककया जाता है। 
                                गोपऩीयता बनाए रखना आपकी IP Address और लोकेशि छुपाई जाती है। 
   Blocked Websites एक्सेस करना VPN से जजयो-ररजस्रक्ट्टेड वबेसाइटें (जैस ेNetflix US) देख सकते हैं। 
       ररमोट एक्सेस कंपनियों में कमडचारी ऑकफस िेटवकड  को घर से एक्ट्सेस कर सकते हैं। 
     पक्ब्लक Wi-Fi पर सुरक्षित िाउक्ज़ंग पजब्लक िेटवकड  (जैस ेरेलवे स्टेशि) पर सुरक्षा देता है। 

 

प्रलसद्ध VPN सेिाएाँ (Popular VPN Services): 

• NordVPN 
• ExpressVPN 
• ProtonVPN 
• Surfshark 
• TunnelBear 
• Windscribe (Free option) 

   VPN के लाभ (Advantages of VPN): 

1. ऑिलाइि गनतववगधयों की गोपऩीयता बिी रहती है 

2. हैक्रकंग और िेटा चोरी से सुरक्षा 
3. क्जयो-ररक््रक्टेि कंटेंट एक्ट्ससे कर सकत ेहैं 
4. सािडजननक नेटिकड  पर भी सुरक्षक्षत ब्राउजज़ंग 



5. कंपिी िेटवकड  का ररमोट एक्सेस संभव 

 

VPN की स़ीमाएाँ (Disadvantages): 

1. इंटरिेट की स्पीड थोड़ी कम हो सकती है 

2. कुछ फ्री VPN सुरक्षक्षत िहीं होत े

3. सभी वेबसाइट या ऐप VPN को सपोटड िहीं करतीं 
4. कुछ देशों में VPN का उपयोग प्रनतबंगधत है 

 

O Level परीिा में संभावित प्रश्न: 

Q1. VPN क्या है? इसके दो उपयोग बताइए। 
Q2. VPN के दो लाभ और एक हानन ललखखए। 
Q3. VPN का उपयोग करत ेसमय क्रकन बातों का ध्यान रखना चादहए? 

 

 (Quick Table): 

ब्रबदं ु वििरण 

पूरा िाम Virtual Private Network 

कायड डेटा को एजन्रप्ट करके सुरक्षक्षत किेक्ट्शि बिािा 
मुख्य उपयोग प्राइवेसी, सेफ ब्राउजज़ंग, कंटेंट एक्ट्सेस 

लाभ सुरक्षा, गुमिामी, ररमोट एक्ट्सेस 

सीमा स्पीड कम, कुछ VPN असुरक्षक्षत हो सकते हैं 

 

 

 

Overview of Futureskills and Cyber Security Introduction to Internet of Things (IoT)  

Big Data Analytics, Cloud Computing, Virtual Reality, Artificial Intelligence, Social & Mobile, 

Blockchain Technology, 3D Printing/ Additive Manufacturing, Robotics Process Automation, 

Cyber Security, Need of Cyber Security, Securing PC, Securing Smart Phone. 



1. ब्रबग िेटा एनाललदटक्स (Big Data Analytics) 

पररभाषा: 

त्रबग डेटा एिाललदटक्ट्स एक ऐसी प्रकरया है जजसमें बहुत बडे़ और ववववध डेटा सटे्स का ववश्लेषण करके उपयोगी 
जािकारी, पैटिड और प्रववृियााँ (trends) खोजी जाती हैं। 

 ब्रबग िेटा की विशेषताएाँ: 

1. िॉल्यूम (Volume): डेटा की बहुत अगधक मािा 
2. िेलोलसटी (Velocity): तेजी से उत्पन्ि और प्रोसेस होिा 
3. िेरायटी (Variety): ववलभन्ि प्रकार के डेटा (जैस ेटेक्ट्स्ट, गचि, वीडडयो) 
4. िेरालसटी (Veracity): डेटा की सटीकता और ववश्वसिीयता 
5. िैल्यू (Value): ववश्लेषण से प्राप्त मूल्यवाि जािकारी 

 उपयोग: 

• व्यापाररक निणडय लेिा 
• धोखाधड़ी की पहचाि 

• स्वास््य सेवाओं में पूवाडिुमाि 

• ग्राहक व्यवहार का ववश्लेषण 

 टूल्स: 

• Hadoop 
• Apache Spark 
• Power BI 
• Tableau 

 2. क्लाउि कंप्यूदटगं (Cloud Computing) 

 पररभाषा: 

क्ट्लाउड कंप्यूदटगं वह तकिीक है जजसमें इंटरिेट के माध्यम से कंप्यूटर सेवाए ं(जैस ेडेटा स्टोरेज, सवडर, 
सॉफ्टवेयर) उपलब्ध कराई जाती हैं। 

 क्लाउि सेिाओं के प्रकार: 

1. IaaS (Infrastructure as a Service): हाडडवेयर सेवाए ं(जैस ेAmazon EC2) 



2. PaaS (Platform as a Service): एजप्लकेशि डेवलपमेंट प्लटेफॉमड (जैस ेGoogle App Engine) 

3. SaaS (Software as a Service): रेडीमेड सॉफ्टवेयर सवेाएं (जैस ेGmail, Dropbox) 

 क्लाउि के प्रकार: 

• पक्ब्लक क्लाउि: सभी के ललए इंटरिेट पर उपलब्ध 

• प्राइिेट क्लाउि: केवल एक सगंठि के ललए 

• हाइब्रिि क्लाउि: दोिों का सयंोजि 

 फायदे: 

• कम लागत 

• स्केलेबल और फ्लजेक्ट्सबल 

• कही ंसे भी एक्ट्सेस 

• डेटा बैकअप और ररकवरी आसाि 

    ALERT 

• सुरक्षा संबंधी खतरे 
• डेटा गोपिीयता की गचतंा 
• इंटरिेट पर निभडरता 

 3. िचुडअल ररयललटी (Virtual Reality - VR) 

पररभाषा: 

वचुडअल ररयललटी एक कंप्यूटर-निलमडत आभासी वातावरण होता है जजसमें उपयोगकताड ववशेष उपकरणों की मदद 

से खुद को उपजस्थत महसूस कर सकता है। 

 उपयोग क्रकए जाने िाले उपकरण: 

• VR हेडसेट (जैस ेOculus Rift, HTC Vive) 

• मोशि कंरोलर 
• VR दस्तािे या सूट 

 अनुप्रयोग: 

• गेलमगं और मिोरंजि 



• लशक्षा और प्रलशक्षण (जैस ेपायलट रेनिगं) 

• गचककत्सा (जैस ेसजडरी का अभ्यास) 

• वचुडअल टूररज्म 

 फायदे: 

• इमलसडव अिुभव 

• सुरक्षक्षत प्रलशक्षण वातावरण 

• सीखिे में रुगच और समझ बढािा 

 नुकसान: 

• महंग ेउपकरण 

• मोशि लसकिेस की संभाविा 
• वास्तववक दनुिया से कम संपकड  

1. आदटडक्रफलशयल इंटेललजेंस (Artificial Intelligence - AI) 

 पररभाषा: 

AI वह तकिीक है जजसमें मशीिें या कंप्यूटर लसस्टम मािव जैसी सोचि,े सीखि ेऔर निणडय लेिे की क्षमता 
प्राप्त करत ेहैं। 

 उदाहरण: 

• वॉयस अलसस्टेंट (जैसे Siri, Alexa) 

• चैटबॉट 

• सेल्फ-ड्राइववगं कार 
• फेस ररकजग्िशि लसस्टम 

 उपयोग: 

• स्वास््य सेवाए ं(बीमाररयों का पूवाडिुमाि) 

• लशक्षा (पसडिलाइज्ड लनििंग) 

• व्यापार (कस्टमर सववडस, डेटा एिालललसस) 

• सुरक्षा और निगरािी 



 फायदे: 

• तेज और सटीक कायड 
• मािव श्रम की बचत 

• 24x7 सेवा सभंव 

नुकसान: 

• िौकरी की संभाविाओं में कमी 
• उच्च लागत 

• निणडयों में पूवाडग्रह (Bias) 

 

 2. सोशल और मोबाइल टेक्नोलॉज़ी (Social & Mobile Technology) 

 सोशल टेक्नोलॉज़ी: 

लोगों के आपस में संवाद, जािकारी साझा करिे और सहयोग करिे के ललए उपयोग की जािे वाली तकिीक। 

 उदाहरण: 

• फेसबुक, ट्ववटर, इंस्टाग्राम, व्हाट्सएप 

• ब्लॉग और फोरम 

 मोबाइल टेक्नोलॉज़ी: 

संचार और कंप्यूदटगं डडवाइस जो पोटेबल होत ेहैं और कही ंसे भी उपयोग ककए जा सकत ेहैं। 

 उदाहरण: 

• स्माटडफोि 

• टैबलेट 

• मोबाइल ऐप्स 

 उपयोग: 

• त्वररत संचार 



• ऑिलाइि खरीदारी 
• डडजजटल भुगताि 

• मोबाइल बैंककंग 

लाभ: 

• सुववधा और गनत 

• वैजश्वक किेजक्ट्टववटी 
• लशक्षा और व्यापार में सुधार 

 

 3. ब्लॉकचेन टेक्नोलॉज़ी (Blockchain Technology) 

 पररभाषा: 

ब्लॉकचेि एक ववकें द्रीकृत डडजजटल लजेर है जजसमें लेि-देि को सुरक्षक्षत और पारदशी तरीके से ररकॉडड ककया जाता 
है। 

 मुख्य विशेषताएाँ: 

• ववकें द्रीकरण (Decentralization) 

• सुरक्षा (Security) 

• पारदलशडता (Transparency) 

• अपररवतडिीयता (Immutability) 

 उपयोग: 

• करप्टोकरेंसी (जैस ेBitcoin, Ethereum) 

• स्माटड कॉन्रैक्ट्ट 

• सप्लाई चेि रैककंग 

• डडजजटल वोदटगं 

 फायदे: 

• धोखाधड़ी में कमी 
• डेटा की सुरक्षा 
• रांसपेरेंसी बढती है 



 

 4. 3 ि़ी वप्रदंटगं / एडिदटि मैन्युफैक्चररगं (3D Printing / Additive Manufacturing) 

 पररभाषा: 

यह एक प्रकरया है जजसमें डडजजटल मॉडल से वस्तु को परत दर परत छापकर तैयार ककया जाता है। 

 प्रक्ररया: 

1. CAD सॉफ्टवेयर से 3D मॉडल बिािा 
2. 3D वप्रटंर में डेटा डालिा 
3. परतों के रूप में वस्तु का निमाडण 

 उपयोग: 

• गचककत्सा (जैस ेकृत्रिम अंग) 

• निमाडण (Prototype बिािा) 
• लशक्षा 
• फैशि और आटड 

लाभ: 

• डडजाइि में लचीलापि 

• जल्दी निमाडण 

• कस्टमाइज़ ककया जा सकता है 

 नुकसान: 

• महंग ेउपकरण 

• कुछ सामगग्रयों की सीमा 
• समय-समय पर रख-रखाव की आवश्यकता 

1. रोबोदटक प्रोसेस ऑटोमेशन (Robotic Process Automation - RPA) 

 पररभाषा: 



RPA एक सॉफ्टिेयर तकऩीक है जो मािव द्वारा ककए जािे वाले दोहराव वाले कायों को ्िचाललत (automate) 

करिे के ललए उपयोग होती है। 

 उदाहरण: 

• डाटा एंरी 
• ईमेल स्वचालि 

• ररपोटड जिरेशि 

• बैंक राजंेक्ट्शि की प्रकरया 

 लाभ: 

• समय की बचत 

• लागत में कमी 
• िुदटयााँ कम होती हैं 
• उत्पादकता बढती है 

 नुकसान: 

• िौकरी पर असर 
• जदटल निणडयों के ललए उपयुक्ट्त िहीं 
• प्रारंलभक लागत अगधक 

 

 2. साइबर सुरिा (Cyber Security) 

पररभाषा: 

साइबर सुरिा िह प्रक्ररया है जजसके अंतगडत कंप्यूटर लसस्टम, िेटवकड , और डेटा को अनचधकृत एक्सेस, हमले, 

िायरस और हैक्रकंग से सुरक्षक्षत ककया जाता है। 

 

 3. साइबर सुरिा की आिश्यकता (Need of Cyber Security) 

 क्यों जरूरी है: 



• िेटा चोरी को रोकिे के ललए 

• हैक्रकंग से बचिे के ललए 

• ऑनलाइन फ्रॉि से सुरक्षा 
• प्राइिेस़ी बनाए रखने के ललए 

• सरकारी, बैंककंग और मडेडकल डाटा की रक्षा 

 

 4. कंप्यूटर की सुरिा (Securing a PC) 

 सुरिा उपाय: 

1. एंटीिायरस सॉफ्टिेयर इंस्टॉल करें 
2. फायरिॉल (Firewall) को एजक्ट्टव रखें 
3. ऑपरेदटगं लस्टम और सॉफ्टिेयर अपिेट रखें 
4. मजबूत पासििड का प्रयोग करें 
5. अनजान ललकं या अटैचमेंट ि खोलें 
6. बैकअप लेते रहें 

 

5. ्माटडफोन की सुरिा (Securing a Smartphone) 

 सुरिा उपाय: 

1. ्रीन लॉक (PIN, पासवडड, कफंगरवप्रटं) का उपयोग करें 
2. एंटीिायरस ऐप इंस्टॉल करें 
3. अज्ञात स्रोतों से ऐप इं्टॉल न करें 
4. Wi-Fi और Bluetooth को सुरक्षित रखें 
5. ऐप परलमशन की जांच करें 
6. डििाइस रैक्रकंग सिम करें  

 

 

Libra sortcut kyes 

Ctrl+A Select All 



Ctrl+J  Justify 

Ctrl+D Double Underline 

Ctrl+E Centered 

Ctrl+H Find and Replace 

Ctrl+Shift+P Superscript 

Ctrl+L Align Left 

Ctrl+R Align Right 

Ctrl+Shift+ⓑ Subscript 

Ctrl+Y Redo last action 

Ctrl+0 Apply Text Body paragraph style 

Ctrl+1 Apply Heading 1 paragraph style 

Ctrl+2 Apply Heading 2 paragraph style 

Ctrl+3 Apply Heading 3 paragraph style 

Ctrl+4 Apply Heading 4 paragraph style 

Ctrl+5 Apply Heading 5 paragraph style 

Ctrl+plus Calculates the selected text and copies the result to the clipboard. 

Ctrl+Shift+- Non-breaking hyphen (is not used for hyphenation) 

Ctrl+* (only on number 

pad) Run macro field 

Ctrl+Shift+Space Non-breaking spaces. Non-breaking spaces are not used for  
hyphenation and are not expanded if the text is justified. 

Shift+Enter Line break without paragraph change 

Ctrl+Enter Manual page break 

Ctrl+Shift+Enter Column break in multicolumnar texts 

Alt+Enter 
Inserting a new paragraph without numbering inside a list. Does not  
work when rk when the cursor is at the end of the list. 

Alt+Enter 
Inserting a new paragraph directly before or after a section, or before 
 a table. 

Arrow Left Move cursor to left 

Shift+Arrow Left Move cursor with selection to the left 



Ctrl+Arrow Left Go to beginning of word 

Ctrl+Shift+Arrow Left Selecting to the left word by word 

Arrow Right Move cursor to right 

Shift+Arrow Right Move cursor with selection to the right 

Ctrl+Arrow Right Go to start of next word 

Ctrl+Shift+Arrow Right Selecting to the right word by word 

Arrow Up Move cursor up one line 

Shift+Arrow Up Selecting lines in an upwards direction 

Ctrl+Arrow Up Move cursor to beginning of the previous paragraph 

Ctrl+Shift+Arrow Up Select to beginning of paragraph. Next keystroke extends selection to beginning of 
previous paragraph 

Arrow Down Move cursor down one line 

Shift+Arrow Down Selecting lines in a downward direction 

Ctrl+Arrow Down Move cursor to beginning of next paragraph. 

Ctrl+Shift+Arrow Down Select to end of paragraph. Next keystroke extends selection to end of next paragraph 

Home Go to beginning of line 

Home+Shift Go and select to the beginning of a line 

End Go to end of line 

End+Shift Go and select to end of line 

Ctrl+Home Go to start of document 

Ctrl+Home+Shift Go and select text to start of document 

Ctrl+End Go to end of document 

Ctrl+End+Shift Go and select text to end of document 

Ctrl+PageUp Switch cursor between text and header 

Ctrl+PageDown Switch cursor between text and footer 

Insert Insert mode on/off 

PageUp Screen page up 

Shift+PageUp Move up screen page with selection 



PageDown Move down screen page 

Shift+PageDown Move down screen page with selection 

Ctrl+Delete Delete text to end of word 

Ctrl+Backspace Delete text to beginning of word In a list 

Ctrl+Delete+Shift Delete text to end of sentence 

Ctrl+Shift+Backspace Delete text to beginning of sentence 

Ctrl+Tab Next suggestion with Automatic Word Completion 

Ctrl+Shift+Tab Use previous suggestion with Automatic Word Completion 

Ctrl+Alt+Shift+V Paste the contents of the clipboard as unformatted text. 

Ctrl+Shift+F10 
Use this combination to quickly dock or undock the Navigator, Styles  
and Formatting window, or other windows 

7. 2. Function Keys 

F2 Formula Bar 

Ctrl+F2 Insert Fields 

F3 Complete AutoText 

Ctrl+F3 Edit AutoText 

F4 Open Data Source View 

Shift+F4 Select next frame 

F5 Navigator on/off 

Ctrl+Shift+F5 Navigator on, go to page number 

F7 Spellcheck 

Ctrl+F7 Thesaurus 

F8 Extension mode 

Ctrl+F8 Field shadings on / off 

Shift+F8 Additional selection mode 

Ctrl+Shift+F8 Block selection mode 

F9 Update fields 

Ctrl+F9 Show fields 



Shift+F9 Calculate Table 

Ctrl+Shift+F9 Update Input Fields and Input Lists 

Ctrl+F10 Nonprinting Characters on/off 

F11 Styles and Formatting window on/off 

Shift+F11 Create Style 

Ctrl+F11 Sets focus to Apply Style box 

Ctrl+Shift+F11 Update Style 

F12 Numbering on 

Ctrl+F12 Insert or edit Table 

Shift+F12 Bullets on 

Ctrl+Shift+F12 Numbering / Bullets off 

8. 3. Paragraphs and Heading Levels 

Ctrl+Alt+Arrow Up Move the active paragraph or selected paragraphs up one  
paragraph. 

Ctrl+Alt+Arrow Down 
 
Move the active paragraph or selected paragraphs down one  
paragraph. 

Tab The heading in format "Heading X" (X = 1-9) is moved down one level  
in the outline. 

Shift+Tab 
 
The heading in format "Heading X" (X = 2-10) is moved up one level 
 in the outline. 

9. 4. Tables 

Ctrl+A 
If the active cell is empty: selects the whole table. Otherwise: selects  
the contents of the active cell. Pressing again selects the entire table. 

Ctrl+Home 

 
If the active cell is empty: goes to the beginning of the table.  
Otherwise: first press goes to beginning of the active cell, second press goes to  
beginning of the current table, third press goes to beginning of  
document. 

Ctrl+End 

 
If the active cell is empty: goes to the end of the table. Otherwise: first 
press goes to the end of the active cell, second press goes to the end  
of the current table, third press goes to the end of the document. 

Ctrl+Tab 
Inserts a tab stop (only in tables). Depending on the Window Manager in use, Alt+Tab 

may be used instead. 



Alt+Arrow Keys Increases/decreases the size of the column/row on the right/bottom  
cell edge 

Alt+Shift+Arrow Keys 
Increase/decrease the size of the column/row on the left/top cell  
Edge 

Alt+Ctrl+Arrow Keys Like Alt, but only the active cell is modified 

Ctrl+Alt+Shift+Arrow Keys Like Alt, but only the active cell is modified 

Alt+Insert 
3 seconds in Insert mode, Arrow Key inserts row/column, Ctrl+Arrow  
Key inserts cell 

Alt+Delete 
3 seconds in Delete mode, Arrow key deletes row/column, Ctrl+Arrow 
 key merges cell with neighboring cell 

 

 

 

 

10. 5. Moving,Resizing Frames, Graphics and Objects 

Esc Cursor is inside a text frame and no text is selected: Escape selects the text frame. 

F2 
If a text frame is selected: positions the cursor to the end of the text in 
 the text frame. If you press any key that produces a character on  
screen, and the document is in edit mode, the character is appended to the text. 

Alt+Arrow Keys Move object. 

Alt+Ctrl+Arrow Keys Resizes by moving lower right corner. 

Alt+Ctrl+Shift+Arrow Keys Resizes by moving top left corner. 

Ctrl+Tab Selects the anchor of an object (in Edit Points mode). 

 
LibreOffice writer Questions 
 
Q1. In LibreOffice Writer, mail merge option is in which menu? 
(A) Insert 
(B) Format 
(C) Tools 
(D) Form 
Ans: C 
Q2. What is the shortcut key of manage template key in LibreOffice Writer? 
(A) Ctrl + T 
(B) Ctrl + shift + N 
(C) Shift + N 
(D) None of above 
Ans: B 
Q3.Find the Minimum zoom percentage in LibreOffice Writer? 



(A) 20 
(B) 10 
(C) 15 
(D) 5 
Ans: A 
Q4.What is the maximum font size in LibreOffice writer? 
(A) 72 
(B) 96 
(C) 11 
(D) 48 
Ans: B 
Q5.What is the shortcut key of superscript in LibreOffice Writer? 
(A) Ctrl + shift + P 
(B) Ctrl +shift + B 
(C) Ctrl +Shift + S 
(D) None of Above 
Ans: A 
 
Q6. What is the shortcut key of increasing font size in LibreOffice? 
(A) Ctrl + ] 
(B) Ctrl + } 
(C) Ctrl+[ 
(D) Both A and B 
Ans: D 
 
Q7. What is the shortcut key for Autotext used in LibreOffice Writer? 
(A) Ctrl + F3 
(B) Ctrl + F2 
(C) Ctrl+F4 
(D) None of the above 
Ans: B 
 
Q8. What is the shortcut key for save as in LibreOffice Writer? 
(A) Ctrl + Shift + S 
(B) Ctrl + S 
(C) F12 
(D) None of the above 
Ans: A 
 
Q9. What is the shortcut key for Auto spell check used in LibreOffice Writer? 
(A) Shift + F7 
(B) Ctrl + F7 
(C) F7 
(D) Ctrl + Shift +F7 
Ans: A 
 
Q10. What is the shortcut key for heading 3 in LibreOffice Writer? 
(A) Ctrl + 1 
(B) Ctrl + 2 
(C) Ctrl+ Shift + 3 
(D) Ctrl + 3 



Ans: D 
 
Q11. In LibreOffice Writer, find the location of footnote? 
(A) Bottom of the page 
(B) Top of the page 
(C) Bottom of the document 
(D) Top of the document 
Ans: A 
 
Q12. By default Line spacing in LibreOffice Writer is? 
(A) 1 
(B) 1.5 
(C) 2 
(D) 2.5 
Ans: A 
 
Q13. What is the shortcut key for double underlying in LibreOffice Writer? 
(A) Ctrl + Shift + D 
(B) Ctrl + D 
(C) Ctrl+U 
(D) Ctrl + Shift + U 
Ans: B 
 
Q14. What is the shortcut key for inserting a table in LibreOffice Writer? 
(A) Ctrl + F12 
(B) Ctrl + F2 
(C) Ctrl+F1 
(D) None of the above 
Ans: A 
 
Q15. What is the shortcut key for page break in LibreOffice Writer? 
(A) Ctrl + Enter 
(B) Ctrl + Shift + Enter 
(C) Sift + Enter 
(D) Enter 
Ans: A 
 
Q16. What is the default file extension in LibreOffice Writer? 
(A) .odt 
(B) .ods 
(C) .odp 
(D) .docx 
Ans: A 
 
Q17. In which menu the commands like bold, italic, underline are found in the LibreOffice 
Writer? 
(A) Style 
(B) Format 
(C) Insert 
(D) View 
Ans: B 



 
Q18. In LibreOffice, the shortcut key of going at the last of the left of the cell is 
(A) Alt + Tab 
(B) Tab 
(C) Alt 
(D) Shift + Tab 
Ans: D 
 
Q19. In LibreOffice Writer, scroll bar option is in which menu? 
(A) File 
(B) Insert 
(C) Tools 
(D) View 
Ans: D 
 
Q20. Thesaurus option is in which menu of LibreOffice? 
(A) Format 
(B) Tools 
(C) View 
(D) None of the above 
Ans: B 
 
Q21. Which shortcut key is used for full screen in LibreOffice? 
(A) Ctrl + Shift + J 
(B) Ctrl + Shift +K 
(C) Shift +J 
(D) None of the above 
Ans: A 
 
Q22. Which shortcut key is used in LibreOffice to hide or unhide the ruler? 
(A) Ctrl + Shift + R 
(B) Ctrl + Shift + P 
(C) Ctrl+ Shift + B 
(D) None of the above 
Ans: A 
 
Q23. What is the shortcut key for clear format in LibreOffice Writer? 
(A) Ctrl + C 
(B) Ctrl + M 
(C) Ctrl+ Shift+ M  
(D) None of the above 
Ans: B 
 
Q24. What is the shortcut key to close the current window in LibreOffice Writer? 
(A) Ctrl + Q 
(B) Ctrl + W 
(C) Ctrl+T 
(D) None of the above 
Ans: B 
 
Q25. Ruler option is found in which menu? 



(A) Home 
(B) Insert 
(C) View 
(D) Tools 
Ans: C 
 
Q26. What is the default location of save in LibreOffice Writer? 
(A) Desktop 
(B) Documents 
(C) Downloads 
(D) All of above 
Ans: B 
 
Q27. What is the shortcut key for heading 2 in LibreOffice Writer? 
(A) Ctrl + 1 
(B) Ctrl + 2 
(C) Ctrl+3 
(D) None of the above 
Ans: B 
 
Q28. What is the margin in LibreOffice Writer document? 
(A) .5 
(B) 1.5 
(C) 0 
(D) 1 
Ans: D 
 
Q29. What is the word processing in LibreOffice? 
(A) Draw 
(B) Impress 
(C) Calc 
(D) Writer 
Ans: D 
 
Q30. What is the file extension for template in LibreOffice Writer? 
(A) .odp 
(B) .odt 
(C) .ott 
(D) .doc 
Ans: C 
 
Q31. Which of the following is not shown in status bar of LibreOffice Writer? 
(A) Total Characters 
(B) Current page number 
(C) Total numbers of words 
(D) Computer’s name 
Ans: D 
 
Q32. Which of the following keyboard shortcut is used to exit writer? 
(A) Ctrl + F4 
(B) Ctrl + F2 



(C) Ctrl+F1 
(D) Alt + F4 
Ans: D 
 
Q33. How do you paste special in LibreOffice ? 
(A) Ctrl + Shift + V@ 
(B) Ctrl + V 
(C) Ctrl + Shift + P 
(D) Ctrl + P 
Ans: A 
 
Q34. What is the shortcut key to create a new document in LibreOffice Writer? 
(A) Ctrl + N 
(B) Ctrl + Shift+ N 
(C) Shft + N 
(D) None of the above 
Ans: A 
 

Q35. LibreOffice Writer के ककस menu में mail merge या लटेर विजार्ड पाया जाता है? 

a) फॉरमटै 

b) फाइल 

c) टूल्स 

d) इंसटट 
Ans : c) 

Q36. LibreOffice Writer में default font size ककतना होता है? 

a) 10 
b) 12 
c) 15 
d) 6 
Ans : b) 
 

Q37. Libreoffice Writer में new style के ललए ककस shortcut key का प्रयोग करते हैं? 

a) Shift + F12 
b) Ctrl + F11 
c) Ctrl + Shift + F11 
d) Shift + F11 
Ans : d) 

Q38. Libreoffice Writer में redu करने की shortcut key है? 

a) Ctrl + Z 
b) Ctrl + Y 
c) Ctrl + R 
d) Ctrl + Shift + R 
Ans : b) 
 

Q39. LibreOffice Writer में Manage template की shortcut key क्या होती है? 

a) Ctrl + T 
b) Ctrl + shift + N 



c) Shift + N 
d) None 
Ans : b) 
 

Q40. LibreOffice writer में बुलेट ललस्ट जोड़ने के ललए ककस कुुं जी का प्रयोग करत ेहैं? 

a) Shift + F12 
b) F12 
c) Ctrl + F12 
d) None 
Ans : a) 
 

Q41. Super script and sub script दोनों सामान करैक्टर की तुलना में बडे़ ददखाई देते हैं? 

a) True 
b) False 
Ans : b) 
 

Q42. LibreOffice writer में status bar को हटाया जा सकता है? 

a) True 
b) False 
Ans : a) 
 

Q43. LibreOffice writer एक ओपन सोसड system software है? 

a) True 
b) False 
Ans : b) 
 

Q44. LibreOffice Writer और एमएस ऑकिस दोनों में Ctrl + F का समान कायड होता है? 

a) True 
b) False 
Ans : a) 
 

Q45. LibreOffice Writer में सामान्यता लैंर्स्केप होता है? 

a) True 
b) False 
Ans : b) 
 

Q46. LibreOffice writer document को हम doc, docx, xml जैस ेfiles में save नह ुं कर सकते क्योंकक 

यह ओपन सोसड होता है? 

a) True 
b) False 
Ans : b) 
 
 
 
 
Libre Office calc  Questions: 
 



Q47. In LibreOffice Calc, the shortcut key of going at the last of left of the cell is? 
(A) Alt + Tab 
(B) Tab 
(C) Alt 
(D) Shift + Tab 
Ans: D 
 
Q48. What is the last column in LibreOffice Calc? 
(A) AMJ 
(B) XFD 
S 
(C) AMG 
(D) EMJ 
Ans: A 
 
Q49. What is the combination of row and column in LibreOffice Calc? 
(A) Cell 
(B) Table 
(C) Position 
(D) Data 
Ans: A 
 
Q50. In LibreOffice Calc, Which symbol appears when a formula error occurs? 
(A) $ 
(B) * 
(C) \ 
(D) # 
Ans: D 
 
Q51. What will be the result of =product (7,-2)? 
(A) 14 
(B) -14 
(C) 5 
(D) None of the above 
Ans: B 
 
Q52. In LibreOffice Calc, cos,sin, fact,exp are category of? 
(A) Data 
(B) Math/Tring 
(C) Mathematical 
(D) String 
Ans: C 
 
Q53. What is the shortcut key of print preview in LibreOffice Calc? 
(A) Ctrl + Shift + P 
(B) Ctrl + Shift + O 
(C) Ctrl + P 
(D) None of the above 
Ans: B 
 
Q54. What is the shortcut key of inserting function in LibreOffice Calc? 



(A) Ctrl + F2 
(B) Ctrl + F4 
(C) Ctrl + F3 
(D) None of the above 
Ans: A 
 
Q55. What is the default file extension in LibreOffice Calc? 
(A) .odt 
(B) .ods 
(C) .odp 
(D) .xlsx 
Ans: B 
 
Q56. What is the shortcut key of edit mode of a cell in LibreOffice Calc? 
(A) F2 
(B) Ctrl + Shift + M 
(C) Ctrl + M 
(D) F3 
Ans: A 
 
Q57. What is the shortcut key of inserting time in LibreOffice Calc? 
(A) Ctrl + ; 
(B) Ctrl + Shift + ; 
(C) Ctrl + T 
(D) None of the above 
Ans: B 
 
Q58. What is the shortcut key of formatting of the cell in LibreOffice Calc? 
(A) Ctrl + 1 
(B) Ctrl + F2 
(C) Ctrl + 2 
(D) Ctrl + M 
Ans: A 
 
Q59. In which menu, merge cells command is found? 
(A) Format 
(B) Style 
(C) Sheet 
(D) Edit 
Ans: A 
 
Q60. What is the shortcut key of deleting of the cell in LibreOffice Calc? 
(A) Ctrl + + 
(B) Ctrl + - 
(C) Ctrl + D 
(D) Delete 
Ans: B 
 
 
Q61. In LibreOffice Calc, if the value is larger than the cell space, what result comes? 
(A) ### 



(B) Cell enlarges and result comes correctly 
(C) #### 
(D)NAME 
Ans: A 
 
Q62. What is maximum zoom in LibreOffice Calc? 
(A) 300% 
(B) 200% 
(C) 400% 
(D) 500% 
Ans: C 
 
Q63. What is the minimum zoom in LibreOffice Calc? 
(A) 10 
(B) 15 
(C) 8 
(D) 20 
Ans: D 
 
Q64. How many total columns are there in LibreOffice Calc? 
(A) 1024 
(B) 1048576 
(C) 16384 
(D) None of Above 
Ans: A 
 
Q65. How many total rows are there in LibreOffice Calc? 
(A) 1024 
(B) 1048576 
(C) 16384 
(D) None of Above 
Ans: B 
 
Q66. How many maximum characters in one cell in LibreOffice Calc? 
(A) 32767 
(B) 1048576 
(C) 16384 
(D) 1024 
Ans: A 
 
Q67. What is the shortcut key to reach of last cell of a spreadsheet in LibreOffice Calc? 
(A) Ctrl + Home 
(B) Ctrl + End 
(C) Ctrl + Shift + Home 
(D) None of above 
Ans: B 
 
Q68. What is the shortcut key for adding cell in LibreOffice Calc? 
(A) Ctrl + + 
(B) Ctrl + - 
(C) Ctrl + D 



(D) Delete 
Ans: A 
 
Q69. How many total charts in LibreOffice Calc? 
(A) 8 
(B) 5 
(C) 10 
(D) None of Above 
Ans: C 
 
 
Q70. What is the value of =round (175,-2)? 
(A) 100 
(B) 173 
(C) 200 
(D) None of Above 
Ans: C 
 

Q71. What is the value of =round (1175,-2)? 

(A) 1100 
(B) 1173 
(C) 1200 
(D) None of Above 
Ans: C 
 
Q72. which shortcut key is used for current date? 
(A) Ctrl +: 
(B) Ctrl + ; 
(C) Ctrl + shift : 
(D) None of above 
Ans: B 
 
Q73. What is the mail merge option in LibreOffice Calc? 
(A) To mail a created file to someone 
(B) Used for mailing many people 
(C) Used to merge two mails together 
(D) None of Above 
Ans: B 
 
Q74. What is the shortcut key to reach first column in LibreOffice Calc? 
(A) Home 
(B) Ctrl + Home 
(C) Alt + Home 
(D) None of above 
Ans: B 
 
Q75. What is the shortcut command to open a new file in LibreOffice Calc? 
(A) Ctrl + N 
(B) Ctrl + M 
(C) Ctrl + Shift + N 



(D) None of Above 
Ans: A 
 
Q76. What is the shortcut key to increase the cell width in LibreOffice Calc? 
(A) Alt + Left Arrow 
(B) Alt + Right Arrow 
(C) Ctrl + Right Arrow 
(D) None of Above 
Ans: B 
 

Q77. LibreOffice Calc में function insert करने की shortcut key है? 

a) Shift + F3 
b) Ctrl + F2 
c) Ctrl + F3 
d) Alt + F3 
Ans : b) 
 

Q78. LibreOffice Calc में print preview की shortcut key क्या है? 

a) Ctrl + Shift + P 
b) Ctrl + Shift + O 
c) Ctrl + P 
d) None 
Ans : b) 
 

Q79. LibreOffice Calc में टाइम इुंसटड करने के ललए ककस shortcut key का प्रयोग करत ेहैं? 

a) Ctrl + ; 
b) Ctrl + Shift + ; 
c) Ctrl + T 
d) None 
Ans : b) 
 

Q80. LibreOffice Calc में Cell िॉमदेटुंग के ललए ककस shortcut key का प्रयोग करते हैं? 

a) Ctrl + 1 
b) Ctrl + F2 
c) Ctrl + 2 
d) Ctrl + M 
Ans : a) 
 

Q81. पूरे रो को सेलेक्ट करने के ललए ककस shortcut key का प्रयोग करत ेहैं? 

a) Ctrl + Space 
b) Shift + Space 
c) Ctrl + Shift + Page down 
d) None 
Ans : b) 
 



Q82. LibreOffice Calc िाइल by default ककस नाम से से save होता है? 

a) Untitled1 
b) Calc1 
c) Spreadsheet1 
d) None 
Ans : a) 
 

Q83. LibreOffice में comment के ललए ककस key का प्रयोग करत ेहैं? 

a) Ctrl + Shift + C 
b) Ctrl + C 
c) Ctrl + Shift + T 
d) Ctrl + Alt + C 
Ans : d) 
 

Q84. LibreOffice Calc में ककसी नुंबर को करेंसी िॉमेट में बदलने के ललए ककस कुुं जी का प्रयोग करत ेहैं? 

a) Ctrl + Shift + 1 
b) Ctrl + Shift + 5 
c) Ctrl + Shift + 4 
d) Ctrl + Shift + 3 
Ans : c) 
 

Q85. LibreOffice Calc में र्ायरेक्ट िॉमटे क्क्लयर करने की शॉटडकट की है? 

a) Ctrl + v 
b) Ctrl + M 
c) Ctrl + Shift + F 
d) Ctrl + 1 
Ans : b) 
 

Q86. Name box कहाुं होता है? 

a) मेनू बार के नीच ेबाए तरफ 

b) मेनू बार के ऊपर बाएं तरफ 

c) स्टेटस बार पर 

d) मेनू बार के नीच ेदाए ंतरफ 

Ans : a) 
 

Q87. अगल  सीट में जाने के ललए ककस key का प्रयोग करत ेहैं? 

a) Tab 
b) Ctrl + Tab 
c) Ctrl + Shift + Tab 
d) Shift + Tab 
Ans : b) 
 

Q88. LibreOffice Calc में ककसी value को हाईलाइट करने के ललए ककस shortcut key का प्रयोग करत ेहैं? 

a) Ctrl + F6 
b) Ctrl 
c) Ctrl + F8 



d) Ctrl + F1 
Ans : c) 
 

Q89. LibreOffice Calc में ककसी cell का address कहाुं ददखाई देता है? 

a) Formula Bar 
b) Address Book 
c) Name box 
d) None 
Ans : c) 
 

Q90. Calc में लास्ट cell का address क्या होता है? 

a) $D$10 
b) AMJ1048575 
c) XFD1048576 
d) $AMD$1048576 
Ans : b) 
 

Q91. LibreOffice Calc में Monday से लकेर Sunday तक ललखने के ललए क्या करते हैं? 

a) Monday ललखकर राइट डाउन corner पकड़कर नीच ेकी तरफ खीचंते हैं 
b) Monday ललखकर enter press करत ेहैं 
c) =week() function का use करत ेहैं 
d) उपरोक्त सभी 
Ans : a) 
 

Q92. Libreoffice Calc सले के लफे्ट जाने के ललए कौन सी key का use करत ेहैं? 

a) Alt +Tab 
b) Tab 
c) Alt 
d) Shift + Tab 
Ans : d) 
 

Q93. सभी िकड शीट के formula को क्या कहत ेहैं? 

a) Manipulate Values 
b) Manipulate Labels 
c) Return of formula Result 
d) Use The Additional Operator 
Ans : c) 
 

Q94. LibreOffice Calc में =10*20/4*8 का क्या मान आएगा? 

a) 400 
b) 6.25 
c) 7 
d) 500 
Ans : a) 



 

Q95. LibreOffice Calc में नुंबर लफे्ट एलाइनमेंट और अल्िाबेट राइट अलाइनमेंट होता है? 

a) True 
b) False 
Ans : b) 
 

Q96. LibreOffice Calc by default एक ऑटो कैलकुलेटर feature उपलब्ध कराता जो कक एक चयननत 

सीमा पररसर में मानो को प्रदलशडत करता है? 

a) True 
b) False 
Ans : a) 
 

Q97. LibreOffice calc में पूरे Cell को एक Cell में बदल सकते हैं? 

a) False 
b) True 
Ans : b) 
 

Q98. LibreOffice Calc और Writer में है Ctrl + D का काम समान होता है? 

a) True 
b) False 
Ans : b) 
 

Q99. Round और Trunc function एक समान होत ेहैं? 

a) True 
b) False 
Ans : b) 
 

 

LibreOffice Impress Questions : 
 
Q100. What is the minimum zoom in LibreOffice Impress? 
(A) 10 
(B) 5 
(C) 8 
(D) 20 
Ans: B 
 
Q101. What is the Maximum zoom in LibreOffice Impress? 
(A) 1000 
(B) 2000 
(C) 3000 
(D) 4000 
Ans: C  
 
Q102. How many slide printed on an A4 paper in LibreOffice Impress? 
(A) 6 
(B) 9 



(C) 12 
(D) 15 
Ans: B 
 
Q103. What is the default file extension in LibreOffice Impress? 
(A) .odt 
(B) .ods 
(C) .odp 
(D) pptx 
Ans: C 
 
Q104. Which of the following view is not available in LibreOffice Impress? 
(A) Outline 
(B) Notes 
(C) Slide sorter 
(D) Master 
Ans: D 
 
Q105. Which of the following is a slide transition effect in LibreOffice Impress? 
(A) Wipe all over 
(B) Fine Dissolve 
(C) Bit by bit 
(D) None of the above 
Ans: B 
 
Q106. What is shortcut key to exit LibreOffice Impress? 
(A) Ctrl + Q 
(B) Ctrl + W 
(C) Shift + C 
(D) None of Above 
Ans: B 
 
Q107. What is shortcut key to add new slide in LibreOffice Impress? 
(A) Ctrl + N 
(B) Ctrl + M 
(C) Shift + N 
(D) Ctrl + Shift + N 
Ans: B 
 
Q108. What is Power point known as in LibreOffice Impress? 
(A) Draw 
(B) Impress 
(C) Calc 
(D) writer 
Ans: B 
 
Q109. What is shortcut key for slide show from current slide of the presentation? 
(A) F5 
(B) Ctrl + F5 
(C) Shift + F5 
(D) Alt + F5 



Ans: C 

Q110. LibreOffice Impress में कौन सा Alignment नह ुं होता है? 

a) Central Alignment 
b) Left Alignment 
c) Right Alignment 
d) Justification 
Ans : d) 

Q111. LibreOffice Impress में Macros command ककस menu में लमलता है? 

a) Insert 
b) slide 
c) Tools 
d) None 
Ans : c) 

Q112. LibreOffice Impress ककस तरह का program है? 

a) स्रेडशीट 

b) वडट रोसेलसगं 

c) रेजेंटेशन 

d) इनमें से कोई नह  ं
Ans : c) 

Q113. LibreOffice Impress में बने Presentation का By Default क्या नाम होता है? 

a) Shw1 
b) Slide1 
c) Presentation1 
d) Untitled1 
Ans : d) 
 

Q114. LibreOffice Impress में कौन सी file का प्रारूप नह ुं जोड़ा जाता है? 

a) जेपीईजी (JPEG) 

b) एच ट  एम एल (HTML) 

c) जी आई एफ (GIF) 

d) डब्लू ए वीI (WAV) 

Ans : b) 
 

Q115. Libre Office presentation को ककस नाम से जाना जाता है? 

1. Silde Animation 

2. Impress 
3. Writer 

4. Graphics  

Ans : 2) 
 

Q116. Jump to Last edited slide पर जाने की shortcut key क्या है 

1. CTRL+NUMBER 



2. ALT+SHIFT+F5 
3. SHIFT+F5 

4. None of above  

Ans : 2) 

Q117. Slide pane का option ककस Menu में होता है? 

1. View 
2. Page Layout 

3. Insert 

4. Format  

Ans : 1) 
 

Q118. Slide Transition का option ककस में होता है? 

1. Slide 

2. View 

3. 1 and 2 
4. Insert  

Ans : 3) 
 

Q119. Libreoffice draw में ruler की shortcut key क्या है?  

1. Ctrl+Shift+R 
2. Shift+F3 

3. Ctrl+ Alt+ O 

4. None Of These  

Ans : 1) 
 

Q120. ललब्रा ऑकिस Impress में ककतनी मीनू होत ेहैं? 

1. 12 

2. 8 

3. 10 
4. 7  

Ans : 3) 
 

Q121. Impress में text box के ललए ककस key का प्रयोग करत ेहैं? 

1. F3 

2. Ctrl+F2 

3. IShift+F2 

4. F2  
Ans : 4) 
 

Q122. Impress में previous slide पर जाने के ललए ककस key का प्रयोग करत ेहैं- 



1. N 

2. M 

3. W 

4. P  
Ans : 4) 
 

 

 


